You are on page 1of 29

Unit 2

AIX System Management Tools

Copyright IBM Corporation 2009


Course materials may not be reproduced in whole or in part without the prior written permission of IBM.

5.2

Unit objectives
IBM Power Systems

After completing this unit, you should be able to:


Describe the benefits of the system management tools
available with AIX version 6.1
Discuss the functionality of SMIT, WebSM, and the new IBM
Systems Director Console for AIX
Explain how system management activity is logged
Look at how we can use IBM Systems Director Console to
monitor system health and to run commands concurrently on
multiple hosts

UNIX system administration challenges


IBM Power Systems

Lots of commands to remember


Complex syntax
Prone to error!

Flat file configuration


Most UNIX flat files have different layouts, syntax and options
Again prone to error, sometimes causing bad things to happen.
#crfsvjfsgrootvgm/testasize=42Mefs=yes
Usage:crfsvVfs{gVolumegroup|dDevice}m
Mountpoint[uMountgroup][A{yes|no}][t{yes|no}][p
{ro|rw}][lLogpartitions][nnodename][a
Attribute=Value]

How do I create
an encrypted
filesystem?

System management objectives


IBM Power Systems

Minimize time and resources spent managing systems


Maximize reliability, performance, and productivity
Provide remote system management solutions

AIX administration
IBM Power Systems

Designed to make Administration on AIX simple


System
Management
Interface Tool
(smit)

Web-based
System
Manager
(WebSM)

IBM
Systems Director
Console for AIX
(pconsole)

Text based

Java GUI

Web Interface

New
in AIX6

High-level commands
Low-level
commands
System
calls

Kernel
services

Intermediate-level
commands
System
Resource
Controller

Object Data
Manager

ASCII
files

SMIT
IBM Power Systems

An interactive application that simplifies virtually every aspect of AIX


system administration
Part of AIX, available by default
SMIT doesn't use any special hooks. Everything is based on standard
AIX commands and Korn shell functions.
You can see exactly what commands it performs either before or after
execution.
This is especially useful when you need to automate a repetitive task. You
can then use these commands in your own scripts.

Text / ASCII based by default.


If on a graphical display, such as the Virtual Network Computing (VNC)
viewer, and the DISPLAY variable is set, a Motif GUI version is displayed.
Most users prefer the text based version called smitty

SMIT main menu (text based)


IBM Power Systems

# smit
System
System Management
Management
Move
Move cursor
cursor to
to desired
desired item
item and
and press
press Enter.
Enter.
Software
Software Installation
Installation and
and Maintenance
Maintenance
Software
Software License
License Management
Management
Devices
Devices
System
System Storage
Storage Management
Management (Physical
(Physical && Logical
Logical Storage)
Storage)
Security
Security && Users
Users
Communications
Communications Applications
Applications and
and Services
Services
Workload
Workload Partition
Partition Administration
Administration
Print
Spooling
Print Spooling
Advanced
Advanced Accounting
Accounting
Problem
Problem Determination
Determination
Performance
Performance && Resource
Resource Scheduling
Scheduling
System
System Environments
Environments
Processes
&
Subsystems
Processes & Subsystems
Applications
Applications
Installation
Installation Assistant
Assistant
Cluster
Cluster Systems
Systems Management
Management
Using
Using SMIT
SMIT (information
(information only)
only)
F1=Help
F1=Help
F9=Shell
F9=Shell

F2=Refresh
F2=Refresh
F10=Exit
F10=Exit

F3=Cancel
F3=Cancel
Enter=Do
Enter=Do

F8=Image
F8=Image

Dialog screen
IBM Power Systems

# smit date
Change
Change // Show
Show Day
Day and
and Time
Time
Type
Type or
or select
select values
values in
in entry
entry fields.
fields.
Press
Press Enter
Enter AFTER
AFTER making
making all
all desired
desired changes.
changes.
[Entry
[Entry Fields]
Fields]
[08]
[08]
[10]
[10]
[08]
[08]
[11]
[11]
[23]
[23]
[06]
[06]

YEAR
YEAR (00-99)
(00-99)
MONTH
MONTH (01-12)
(01-12)
DAY
DAY (1-31)
(1-31)
HOUR
HOUR (00-23)
(00-23)
MINUTES
MINUTES (00-59)
(00-59)
SECONDS
SECONDS (00-59)
(00-59)

Shell exit, very


useful to check
something prior to
execution
F1=Help
F1=Help
F5=Reset
F5=Reset
F9=Shell
F9=Shell

F2=Refresh
F2=Refresh
F6=Command
F6=Command
F10=Exit
F10=Exit

Command
preview
F3=Cancel
F3=Cancel
F7=Edit
F7=Edit
Enter=Do
Enter=Do

##
##
##
##
##
##

Current fast path:


"date"
F4=List
F4=List
F8=Image
F8=Image

Output screen
IBM Power Systems

Command
completed
successfully
Command:
Command: OK
OK

COMMAND
COMMAND STATUS
STATUS

stdout:
stdout: yes
yes

No
Standard
error

stderr:
stderr: no
no

Before
Before command
command completion,
completion, additional
additional instructions
instructions may
may appear
appear below.
below.
Wed
Wed 88 Oct
Oct 11:23:06
11:23:06 2008
2008

Standard Output
following command
execution
(Stdout)

F1=Help
F1=Help
F8=Image
F8=Image
n=Find
n=Find Next
Next

F2=Refresh
F2=Refresh
F9=Shell
F9=Shell

F3=Cancel
F3=Cancel
F10=Exit
F10=Exit

F6=Command
F6=Command
/=Find
/=Find

SMIT log and script files


IBM Power Systems

smit.log
smit
Command
execution

smit.script
smit.transaction

$HOME/smit.log
Records a log of all menu and dialog screens visited, all commands executed,
and their output.
Records any errors during the SMIT session.

$HOME/smit.script
Shell script containing all AIX commands executed by SMIT

$HOME/smit.transaction
SMIT transactions log
Records date, description and command script output of the commands executed

# smitty xs /tmp/new-script

SMIT output will be


redirected to file: /tmp/newscript. No commands will
be run.

Web-Based System Manager


IBM Power Systems

A Java based GUI, similar to SMIT in functionality


Part of AIX (available by default), based on a client/server model
Resource intensive and more cumbersome to use than SMIT
For AIX6, users should consider using IBM Systems Director Console
for AIX

IBM Systems Director Console for AIX


IBM Power Systems

New web based management interface in AIX 6.1


Enables converged consoles
Integrated solutions console
Lightweight infrastructure

Includes links to SMIT and WebSM tasks


Requires Java v5
Installed by default

sysmgt.pconsole.rte
sysmgt.pconsole.apps.wdcem
sysmgt.pconsole.apps.websm
sysmgt.pconsole.apps.wrbac
sysmgt.pconsole.apps.wsmit
lwi.runtime

## lssrc
lssrc -s
-s pconsole
pconsole
Subsystem
Group
Subsystem
Group
pconsole
pconsole
pconsole
pconsole
## netstat
netstat -a
-a |grep
|grep 5336
5336
tcp
0
00 *.5336
tcp
0
*.5336

How to check
that it is
running

PID
PID
737388
737388

Status
Status
active
active
*.*
*.*

LISTEN
LISTEN

Console interface
IBM Power Systems

Web browser-based access


https://<hostname (or IP)>:5336/ibm/console (Defaults to SSL. Use 5335 for non-SSL)

Console applications
IBM Power Systems

OS Management (new SMIT-based tasks)


Portlets/Modules
For example, System Health

Classical SMIT
Classic-style smit menus for those who prefer a more traditional look
and feel

Distributed Command Execution Manager (DCEM)


Is used to execute commands on multiple systems in parallel.
Is based on the standard UNIX dsh function
On AIX, this is part of the Cluster Systems Management (CSM) product,
csm.dsh which is installed as part of a base AIX install.

Supports groups of systems


Supports rsh and ssh authentication

Console management view


IBM Power Systems

New look and feel

Navigation
area

Toolbar

Define
start-up
pages

Work area

System health (1 of 3)
IBM Power Systems

Portlets: System summary and Metric Details


Time to
refresh

Sectionspecific
help

Refresh
immediately

System health (2 of 3)
IBM Power Systems

Configuration Information

System health (3 of 3)
IBM Power Systems

Portlets: Top Processes and File Systems

Classical SMIT
IBM Power Systems

DCEM portlet (1 of 5)
IBM Power Systems

Graphical
driven UNIX dsh
functionality

Commands

LPAR:
AIX4

LPAR:
AIX3

LPAR:
AIX2

LPAR:
AIX1

dsh

DCEM portlet (2 of 5)
IBM Power Systems

Enter job
name and
description.

Defaults to
standard PATH
and user root

Enter
commands to
run.

DCEM portlet (3 of 5)
IBM Power Systems

Specify
target
machines.

DCEM portlet (4 of 5)
IBM Power Systems

Defaults to
rsh, ssh is
optional

Confirmation
that job is
running

DCEM portlet (5 of 5)
IBM Power Systems

Status:
Completed
OK or failure!

Report output.
Further host
output can be
seen by selecting
the links below.

Console logging and tracing


IBM Power Systems

Console Logs
Location: /var/log/pconsole/logs

Formatted using XML


Rotated using filenames error-log-#.xml and trace-log-#.xml
## ls
ls /var/log/pconsole/logs
/var/log/pconsole/logs
error-log-0.xml
error-log-5.xml
error-log-0.xml
error-log-5.xml
error-log-0.xml.lck
Log_Viewer.xml
error-log-0.xml.lck
Log_Viewer.xml
error-log-1.xml
trace-log-0.xml
error-log-1.xml
trace-log-0.xml
error-log-2.xml
trace-log-0.xml.lck
error-log-2.xml
trace-log-0.xml.lck
error-log-3.xml
trace-log-1.xml
error-log-3.xml
trace-log-1.xml
error-log-4.xml
trace-log-2.xml
error-log-4.xml
trace-log-2.xml

Classical SMIT logs


Location: $HOME/wsmit.log & wsmit.script

DCEM log
Location: $HOME/dcem/logs/dcem.log

trace-log-3.xml
trace-log-3.xml
trace-log-4.xml
trace-log-4.xml
trace-log-5.xml
trace-log-5.xml

Checkpoint
IBM Power Systems

1. List the three main system management tools available on AIX.


1. ______________
2. ______________
3. ______________

2. What is the purpose of the smit.script file?


_______________________________
_______________________________

3. What information can one get from looking at the


system configuration details in IBM Systems Director
Console?
________________________________
________________________________
________________________________
________________________________
________________________________

Checkpoint solutions
IBM Power Systems

1. List the three main system management tools available on


AIX.
SMIT, WebSM, and IBM Systems Director console for AIX

2. What is the purpose of the smit.script file?


To obtain the command(s) SMIT has just executed

3. What information can one get from looking at the


system configuration details in IBM Systems Director
Console?
Firmware/model information
Network configuration, IP address etc
Paging Space Information
A list of Top CPU logging processes
File system information

Exercise 2
IBM Power Systems

AIX system management

Unit summary
IBM Power Systems

Having completed this unit, you should be able to:


Describe the benefits of the system management
tools available with AIX version 6.1
Understand the functionality of SMIT, WebSM, and
the new IBM Systems Director Console for AIX
Explain how system management activity is logged
Look at how we can use IBM Systems Director
Console to monitor system health and to run
commands concurrently on multiple hosts

You might also like