You are on page 1of 5

Rouer Pasword configuration

switch>enable
switch>#confi ter
switch-config>#enable secret password //how to set secret password
switch-config>#line console 0 //How to set console passowrd
switch-config-line>#password cisco1
switch-config-line>#login
switch-config>#line vty 0 5//How to set console passowrd
switch-config-line>#password cisco2
switch-config-line>#login
********************************************************************************
*****************************************************
RIP
switch-config>#router rip
switch-config>#version 2
switch-config>#network 192.168.3.1
switch-config>#network 192.168.4.1

********************************************************************************
*****************************************************
Switch configuration commands
switch1>enable
switch1>#configure terminal
switch1-config>#interface vlan1
switch1-config-if>#ip address 10.19.105.3 255.255.255.0
switch1-config-if>#no shutdown
switch1-config-if>#exit
switch1-config>#int fa0/1
switch1-config-if>#duplex full
switch1-config-if>#speed auto
switch1-config-if>#no shut
switch1-config-if>#switchport mode trunk allowed vlan all
********************************************************************************
*****************************************************
EIGRP configuration commands
switch1>enable
switch1>#configure terminal
switch1-config>#router eigrp 10
switch1-config-eigrp>#network 192.168.3.1
switch1-config-eigrp>#no auto-summary
********************************************************************************
*****************************************************
VTP
Commands used in the lab we bought

show int trunk


show cdp neighbors
show vlan
show ip int br
show mac-address-table (In order to find out which interfaces is asociated to a
MAC address)
show vtp status
(In order to find out from where a switch is getting VLAN
informartion)
show spanning-tree
show spanning-tree vlan 30
Q.A switch has been taken out from a Network.What will happen if swtich is re-co
nnected to network again and the swticvh has Trunk inteface to the network)
Ans. Execute "show VTP stat" to find out if the new switch and the existing swti
ch has same VTP domain name, Server/ client relation and configuration revision.
Secondly run "show vlan" in orde to find out which VLAN would be deleted and wh
ich VLAN would remain in the client switch.
Q. What switch would be the root bridge for VLAN1
Ans#1. "show spaning-tree vlan 1" will give you role/state for the interfaces in
the VLAN..If all ports for a VLAN are having "Desg forwarding" role, that switc
h would be the root bridge in that VLAN...You need to execute this command on al
l routers.
Ans#2. (If you can access only SW-AC3, than you can use this method). "show span
ing-tree vlan 1" will give you role/state for the interfaces in the VLAN..If all
ports for a VLAN are having "Desg" role, that switch would be the root bridge i
n that VLAN..If there is a port is having role "root", than this port will face
to the root bridgde. Execute "show CDP neighbour" to find out switch connected t
o the port. This switch would be Rood Bridge.
Q. Which two commands shows that there is native VLAN mismatch
Ans. "show int switch port" will give the details of interface,VLAN associated t
o interface and whether the VLAN is natvie or not. Than execute
"show int trunk" to find out which interface is configured is configured as Trun
k. Compare the output of two commands to find out which ports are Trunk inteface
s and which VLAN's are associated to them.
********************************************************************************
*****************************************************
Q.How to descide what should be the default Gateway for a PC
Ans>
FInd out the interface on switch where PC is connected
Find out VLAN (in switch)configured for that interface show vlan
Find out IP address assigned to interface(in router)
show ip int br
********************************************************************************
*****************************************************
Q.> How to find out from which switch did SW-AC3 is receving VLAN information
ANS.>
1-Run the command "show VTP status" and find out the IP of the desired switch fr
om line "configuration last modified by 1.1.1.1"..Note down the IP.
2-Run the command "show cdp nei det" to find out the switch corresponding to the
above IP.
********************************************************************************
*****************************************************
ACL (Wild mask)

config)#access-list 100 permit tcp host 192.168.33.3 host 172.22.242.23 eq 80


config)#access-list 100 deny tcp any host 172.22.242.23 eq 80
config)#access-list 100 permit ip any any
config-if)#ip access-group 100 out
********************************************************************************
*****************************************************
NAT (normal subnet mask)
extended
Config)#IP NAT pool todd 198.3.1.1 198.3.1.5 netmask 255.255.255.248
Config)#ip access-list standard 1
Config)#permit 192.168.3.1 0.0.0.255
Config)#access-list 1 deny any
Config)#Ip nat inside source list 1 pool todd
Config)#int fe1/0
Config-if)ip nat inside
Config)#int se0/0/0
Config-if)ip nat outside
overload
Ip nat pool todd 198.3.2.1 198.3.2.1 netmask 255.255.255.248
access-list 1 permit IP 192.168.3.1 0.0.0.3
Ip nat inside source list 1 pool todd overload (source many destination 1)
This might be correct
ip nat pool todd 198.18.237.225 198.18.237.230 prefix-length 29
access-list 1 permit ip 192.168.16.33 0.0.0.15
ip nat inside source list 1 pool todd overload
********************************************************************************
*****************************************************
VLAN
question 384
config)#int fa0/0.3
config-if)#encap dot1q 3
config-if)#ip address 192.168.3.1 255.255.255.0
config-if)#no shutdown
config)#int fa0/0.2
config-if)#encap dot1q 2
config-if)#ip address 192.168.2.1 255.255.255.0
config-if)#no shutdown
config)#int fa0/1
config-if)switchport mode trunk
config-if)switchport trunk vlan 10
config-if)switchport trunk vlan 20
********************************************************************************
*****************************************************
CISCO passwords

question 388
config)#int fa0/0.3
config-if)#encap dot1q 3
********************************************************************************
*****************************************************
Frame Relay
show frame-relay map (shows frame relay mapping)
show frame-relay pvc (shows frame relay counters BECN,FECN etc)
********************************************************************************
*****************************************************
OSPF (wild mask)
********************************************************************************
*****************************************************
EIGRP
show ip EIGRP topology
Router 2
onfig)#no router EIGRP 22
config)#router EIGRP 212
network 192.16.60.0
network 192.16.77.0
Router 1
config)#router EIGRP 212
network 192.16.77.0
********************************************************************************
*****************************************************
IPV6
0:0:0:0:0:0 ===:: ===0.0.0.0 (IpV4)
0:0:0:0:0:1 ===::1 ===127.0.0.1 (IpV4)
0:0:0:0:0:0:192.168.0.1
(IPV4/IPv6)
2000::/3
(Golbal Unicast address range)
FC00::/7
(Unique Local unicast range)
FE80::/10
(Link Local uni-cast range)
FF00::/8
(multi-cast range)
3FFF:FFFF::/32
(Reserved for documantation)
2001:0DB8::/32
(Reserved for documantation)
2002::/16
(Used with 6/4 ip transition)
FE02::8
(IS-IS for IPV6)
FE02::9
(RIPng for IPV6)
********************************************************************************
*****************************************************
Questions to be asked
when a switch x is connected to an existing network of switches, how vlan will b
e copied from server switch to the client switches
78,79.110,132,147,151,154,176,268,275,280,306,307,311,351,356,362,365,381,386,38
8,399,406,408,410,420,423,425,429,456,467,470,458,463,464,472,473,475,488,493,50
9,511,515,524,528,530,531,534,535,542,545,560,563,565,568,569,573,574,576,586,59

4,599,600,
********************************************************************************
*****************************************************
Important Notes
802.1q
is a protocol which assign tags to un-tagged frames. When we make a port as acce
ss or trunk, we need to activate this software. Normally a port is Tag aware. If
we define VLAN on a tag aware port, a lap top can not talk to the port bc lapto
p has un-tagged traffic which can not talk to tagged traff\ic.
802.1d
is a prtocol which used to define RSTP specifications
8
********************************************************************************
*****************************************************
backup of questions
Questions to be asked
when a switch x is connected to an existing network of switches, how vlan will b
e copied from server switch to the client switches
Q(356 and Q351, Q388, 406,410,420,423,425,429,456,467,470,458,463,464,472,473,47
5,488,493
509,511,515,524,528,531,534,535,544,560,78,79.110,132,147,151,154,176,268,275,28
0,306,307,311,362,365,381,386,399,408
********************************************************************************
*****************************************************
QUestion Grouping
1) (32,512)--- Regarding the AP points with 10% shared overlapping area.
2) (155,159)-- 3 advantage of VLAN (bC domain, logical grouping, simplify addi
ing, enhance nw security)
********************************************************************************
*****************************************************
Question to be practiced on the packet Tracer
Q377,378,384,388,344,350,359,202,436,431

You might also like