You are on page 1of 9

Lab 2.

1a Configure CME using the CLI and Cisco IP Phone 7960


Series
Learning Objectives
• Configure Cisco Unified Call Manager Express (CME)
• Install Cisco IP Phone 7960 Series
• Verify CME and IP Phone Operation

Topology Diagram

Scenario

In this lab, you will configure Cisco Unified Call Manager Express using the IOS
command line. You will install 2 Cisco IP Phone 7960 Series and have one
phone call the other.

This lab uses Cisco’s newest version of Cisco Unified Call Manager Express at
the time of this writing (CME 4.0(2)) which was tested using Cisco IOS Release
12.4(9)T1 running on a Cisco 2800 Series router. The IP Voice image is
required in order to be able to manipulate codecs.

Step 1: Configure Addressing

Configure the router with the IP address shown in the diagram.


R1(config)# interface fastethernet 0/0
R1(config-if)# ip address 172.16.10.1 255.255.255.0
R1(config-if)# no shutdown

1-9 CCNP: Optimizing Converged Networks v5.0 - Lab 2-1 Copyright © 2007, Cisco Systems, Inc
Step 2: Configure router for phone firmware

Tell the router that the phone firmware is located in Flash


R1(config)#tftp-server flash:P00308000500.bin
R1(config)#tftp-server flash:P00308000500.loads
R1(config)#tftp-server flash:P00308000500.sbn
R1(config)#tftp-server flash:P00308000500.sb2

Step 3: Set up DHCP for phones to load networking information

Configure the IP Telephony DHCP range

R1(config)#ip dhcp excluded-address 172.16.10.1 172.16.10.10


R1(config)#ip dhcp pool VOICE
R1(dhcp-config)#network 172.16.10.0 255.255.255.0
R1(dhcp-config)#default-router 172.16.10.1
R1(dhcp-config)#option 150 ip 172.16.10.1

Note: Option 150 is used to specify the TFTP server address from which the
Cisco Unified IP Phone downloads the image configuration file.

Step 4: Configure phones to receive correct time and timezone for Daylight
Savings

Configure for timezone and set to provide time to phones:


Melbourne Australia has a time zone of GMT +10

R1(config)#clock timezone EST 10

Daylight Savings for Melbourne Australia begins on the First Sunday in October
at 02:00 and ends on the First Sunday in April at 02:00. This is set for each year
hence is recurring.
R1(config)#clock summertime EST recurring 1 Sunday October 02:00 1 Sunday
April 02:00

Set the clock to the correct time.

R1#clock set 10:50:00 4 Aug 2010

Set R1 to be the NTP master for the phones.


R1(config)#ntp master

2-9 CCNP: Optimizing Converged Networks v5.0 - Lab 2-1 Copyright © 2007, Cisco Systems, Inc
Step 5: Configure Router Telephony Service

Cisco’s Call Manager Express (CME) is a slimmed-down version of the Call


Manager (CM) server application. CM runs on a dedicated server, while CME
runs on a router. CME possesses much of the basic functionality of CM, which
may be all that is needed in a smaller network without a large number of
phones. CME may also be much more cost-effective in many environments
where the full power of CM is not necessary. CM and CME both act as servers
whose main function is to establish calls between phones, as well as many
other voice-related functions. A Cisco IP phone deployment requires either a
deployment of CME or CM to provide telephony services to the IP phones.

Cisco IP phones rely on Call Manager or Call Manager Express primarily during
their boot sequence and dialing procedure to provide configuration and
directory services.

To enable the CME functionality of a Cisco router running a CME-installed


image, use the telephony-service command in global configuration mode. This
will bring you into the telephony service configuration prompt. If you issue the ?
character at this prompt, you will see that there are many CME-specific
commands available to customize a CME installation.
R1(config)# telephony-service
R1(config-telephony)# ?
Cisco Unified CallManager Express configuration commands.
For detailed documentation see:
www.cisco.com/univercd/cc/td/doc/product/access/ip_ph/ip_ks/index.htm

after-hours define after-hours patterns, date, etc


application The selected application
auto Define dn range for auto assignment
auto-reg-ephone Enable Ephone Auto-Registration
bulk-speed-dial Bulk Speed dial config
call-forward Configure parameters for call forwarding
call-park Configure parameters for call park
caller-id Configure caller id parameters
calling-number Replace calling number with local for hairpin
cnf-file Ephone CNF file config options
...

Since there are two Ip Phones, configure the maximum number of phones to be
2 using the max-ephones number command. Configure the maximum number
of directory numbers to be 10 using max-dn number. Later in the lab exercise,
you will demonstrate what the configuration of ephones and directory numbers
represent.
R1(config-telephony)# max-ephones 2
R1(config-telephony)# max-dn 10

Configure the phone keepalive timeout period to be 15 seconds by issuing the


keepalive seconds command. This timer specifies how long CME will wait
before considering an IP phone unreachable and taking action to deregister it.
The default timeout is 30 seconds.

3-9 CCNP: Optimizing Converged Networks v5.0 - Lab 2-1 Copyright © 2007, Cisco Systems, Inc
R1(config-telephony)# keepalive 15

Configure a system message using the system message line command. This
line will appear on phones associated with the CME.
R1(config-telephony)# system message Cisco VOIP

Next, tell the router to generate the configuration files for phones that associate
with the CME using the create cnf-files command. It may take a couple
minutes for the configuration process to be enabled.
R1(config-telephony)# create cnf-files

Finally, configure the source address for SCCP using the ip source address
address port port command. Use the local Fast Ethernet address with a port
number of 2000.
R1(config-telephony)# ip source-address 172.16.10.1 port 2000
R1(config-telephony)# load 7960-7940 P00308000500
R1(config-telephony)# time-format 24
R1(config-telephony)# date-format dd-mm-yy

Step 6: Create Directory Numbers

When CME configuration references an “ephone,” it is referring to an Ethernet


phone connected via an IP network. An ephone represents the physical phone,
and can be associated with a phone MAC address and other physical
properties. A phone will only have one globally-unique, hard-coded MAC
address, so to uniquely identify an ephone on your network, refer to the MAC
address.

At the logical layer of the VoIP model, a directory number represents a logical
phone with an associated phone number and name (label). A Cisco IP phone
can be associated with more than one directory number at a time, effectively
making it a multi-line device with each line possessing its own directory number.
The soft buttons on an IP phone each represent a single line. To configure a
directory number, use the global configuration ephone-dn tag command. Use a
tag of 1 for the first phone.
R1(config)# ephone-dn 1

At the ephone-dn configuration prompt, use the number number command to


configure a phone number of 5001. Assign a name of “Host A” with the name
name command. This will be the directory number associated with host A’s
phone, which we will configure shortly.
R1(config-ephone-dn)# number 5001
R1(config-ephone-dn)# name Host A

Configure ephone-dn 2 similarly.

4-9 CCNP: Optimizing Converged Networks v5.0 - Lab 2-1 Copyright © 2007, Cisco Systems, Inc
R1(config-ephone-dn)# ephone-dn 2
R1(config-ephone-dn)# number 5002
R1(config-ephone-dn)# name Host B

Step 7: Create Phones

Before configuring the phones on the router, you will need to find out the MAC
addresses of the phones. You will find the MAC address of the phone by turning
the phone upside down and the MAC address will be printed as a hexadecimal
string on a sticker in the middle at the bottom of the phone.

Write down the MAC addresses for both phones, since you will need them in
this step.

Note: Your MAC addresses will be different from the addresses shown in the
sample commands.

On R1, enter the ephone configuration prompt by typing the ephone tag
command in global configuration mode.
R1(config)# ephone 1

Associate the MAC address with this ephone using the mac-address address
command. The address must be in the format HHHH.HHHH.HHHH.
R1(config-ephone)# mac-address 0002.B3CE.72A3

Use the type type command to configure the type of phone. Since you are
configuring Cisco IP phones 7960 series, use 7960 as the phone type.
R1(config-ephone)# type 7960

Assign the first button on the phone to directory number 1 using the button line
command. The button command assigns buttons to phone lines, as well as
determines the type of ringer assigned to that phone line. The format for the
button command we will use is “1:1”. The first 1 indicates the first button. The
colon indicates a normal ringer. The second 1 represents directory number 1,
previously configured with the ephone-dn 1 command.
R1(config-ephone)# button 1:1

Apply a similar configuration for ephone 2. Change the configuration


parameters where appropriate.
R1(config-ephone)# ephone 2
R1(config-ephone)# mac-address 0009.5B1B.67BD
R1(config-ephone)# type 7960
R1(config-ephone)# button 1:2

5-9 CCNP: Optimizing Converged Networks v5.0 - Lab 2-1 Copyright © 2007, Cisco Systems, Inc
Step 8: Debug ephone registration

Before running CIPC, enable debugging for ephone registration on R1 using the
debug ephone register command. This will let you see ephone registration
output.
R1# debug ephone register
EPHONE registration debugging is enabled

On R1, look at the debug output generated when R1 registered. The output is
rather lengthy, so not all of it is included here.
*Jan 30 06:47:37.155: New Skinny socket accepted [2] (0 active)
*Jan 30 06:47:37.155: sin_family 2, sin_port 1034, in_addr 172.16.10.50
*Jan 30 06:47:37.155: skinny_add_socket 2 172.16.10.50 1034
*Jan 30 06:47:37.211: %IPPHONE-6-REG_ALARM: 25: Name=SEP0002B3CE72A3 Load=
2.0.2.0 Last=Initialized
*Jan 30 06:47:37.211:
Skinny StationAlarmMessage on socket [1] 172.16.10.50
*Jan 30 06:47:37.211: severityInformational p1=0 [0x0] p2=0 [0x0]
*Jan 30 06:47:37.211: 25: Name=SEP0002B3CE72A3 Load= 2.0.2.0 Last=Initialized
*Jan 30 06:47:37.411: ephone-(1)[1] StationRegisterMessage (0/0/4) from
172.16.10.50
*Jan 30 06:47:37.411: ephone-(1)[1] Register StationIdentifier DeviceName
SEP0002B3CE72A3
*Jan 30 06:47:37.411: ephone-(1)[1] StationIdentifier Instance 0 deviceType
30016
*Jan 30 06:47:37.411: ephone-1[-1]:stationIpAddr 172.16.10.50
*Jan 30 06:47:37.411: ephone-1[-1]:maxStreams 3
*Jan 30 06:47:37.411: ephone-1[-1]:protocol Ver 0x84000006
*Jan 30 06:47:37.411: ephone-1[-1]:phone-size 4700 dn-size 568
*Jan 30 06:47:37.411: ephone-(1) Allow any Skinny Server IP address
172.16.10.1
*Jan 30 06:47:37.411: ephone-1[-1]:Found entry 0 for 0002B3CE72A3
*Jan 30 06:47:37.411: ephone-1[-1]:socket change -1 to 1
*Jan 30 06:47:37.411: ephone-1[-1]:FAILED: CLOSED old socket -1
*Jan 30 06:47:37.411: ephone-1[1]:phone SEP0002B3CE72A3 re-associate OK on
socket [1]
*Jan 30 06:47:37.411: %IPPHONE-6-REGISTER: ephone-1:SEP0002B3CE72A3
IP:172.16.10.50 Socket:1 DeviceType:Phone has registered.
<OUTPUT OMITTED>

You may disable debugging using undebug all, or leave it on if you wish to see
the other phone as well (just remember to undebug when you are done with the
lab).

Step 9: Configure Speed Dial

Speed dial allows a phone user to quickly dial a number from a list. For IP phones, the
first entries that are set up occupy any unused line buttons and are invoked when a user
presses one of these line buttons. Subsequent entries are invoked when a phone user
dials the speed-dial code (tag) and the Abbr soft key.

R1(config)# ephone 1
R1(config-ephone)# speed-dial 1 5002 Label “Host B”
R1(config-ephone)#restart
R1(config-ephone)# ephone 2

6-9 CCNP: Optimizing Converged Networks v5.0 - Lab 2-1 Copyright © 2007, Cisco Systems, Inc
R1(config-ephone)# speed-dial 1 5001 Label “Host A”
R1(config-ephone)#restart

The restart command will cause the phone to download the new configuration.

Step 9: Configuring Ring Tones.

Cisco Unified IP Phones have two default ring types: Chirp1 and Chirp2.
Cisco Unified CME also supports customized ring tones using pulse code modulation
(PCM) files.

An XML file called RingList.xml specifies the ring tone options available for the default
ring on an IP phone registered to Cisco Unified CME. An XML file called
DistinctiveRingList.xml specifies the ring tones available on each individual line
appearance on an IP phone registered to Cisco Unified CME.

The version of the IOS we are using has 26 different ring tones including the two default
ring tones. These are found in the two XML files listed above. Use the tftp-server
command to enable access to the files.

R1(config)# tftp-server flash:RingList.xml


R1(config)# tftp-server flash:DistinctiveRingList.xml
R1(config)# tftp-server flash:Analog1.raw
R1(config)# tftp-server flash:Analog2.raw
R1(config)# tftp-server flash:AreYouThere.raw
R1(config)# tftp-server flash:AreYouThereF.raw
R1(config)# tftp-server flash:Bass.raw
R1(config)# tftp-server flash:CallBack.raw
R1(config)# tftp-server flash:Chime.raw
R1(config)# tftp-server flash:Classic1.raw
R1(config)# tftp-server flash:Classic2.raw
R1(config)# tftp-server flash:ClockShop.raw
R1(config)# tftp-server flash:Drums1.raw
R1(config)# tftp-server flash:Drums2.raw
R1(config)# tftp-server flash:FilmScore.raw
R1(config)# tftp-server flash:HarpSynth.raw
R1(config)# tftp-server flash:Jamaica.raw
R1(config)# tftp-server flash:KotoEffect.raw
R1(config)# tftp-server flash:MusicBox.raw
R1(config)# tftp-server flash:Piano1.raw
R1(config)# tftp-server flash:Piano2.raw
R1(config)# tftp-server flash:Pop.raw
R1(config)# tftp-server flash:Pulse1.raw
R1(config)# tftp-server flash:Ring1.raw
R1(config)# tftp-server flash:Ring2.raw
R1(config)# tftp-server flash:Ring3.raw
R1(config)# tftp-server flash:Ring4.raw
R1(config)# tftp-server flash:Ring5.raw
R1(config)# tftp-server flash:Ring6.raw
R1(config)# tftp-server flash:Ring7.raw
R1(config)# tftp-server flash:Sax1.raw
R1(config)# tftp-server flash:Sax2.raw
R1(config)# tftp-server flash:Vibe.raw

7-9 CCNP: Optimizing Converged Networks v5.0 - Lab 2-1 Copyright © 2007, Cisco Systems, Inc
Reboot the IP phones. After reboot, the IP phones download the XML and ring tone
files. Select the customized ring by pressing the Settings button followed by the Ring
Type menu option on a phone.

Step 10: Change the Codec Being Used (OPTIONAL - Requires a version of the
IOS that has Call Manager Express (CME))

There are multiple codecs that can be used for VOIP. A codec is the method
used to encode and decode between analog (sound) voice data and a digital
format.

End the call. On R1, under both ephone prompts, use the codec type command
to change the codec from the default, g711ulaw, to g729r8.
R1(config)# ephone 1
R1(config-ephone)# codec g729r8
R1(config-ephone)# ephone 2
R1(config-ephone)# codec g729r8

Notice the codecs listed now on the phone. G.729 only uses 8Kb of bandwidth,
versus G.711, which uses 64Kb. Of course, there must be a tradeoff to
decrease bandwidth usage, which in this case is sound quality. Once you are
done observing the statistics, you may hang up the call.

Final Configurations

R1# show run


hostname R1
!
clock timezone EST 10
clock summer-time EST recurring 1 Sun Oct 2:00 1 Sun Apr 2:00
!
ip dhcp excluded-address 172.16.10.1 172.16.10.10
!
ip dhcp pool VOICE
network 172.16.10.0 255.255.255.0
default-router 172.16.10.1
option 150 ip 172.16.10.1
!
interface FastEthernet0/0
ip address 172.16.10.1 255.255.255.0
!
tftp-server flash:P00308000500.bin
tftp-server flash:P00308000500.loads
tftp-server flash:P00308000500.sbn
tftp-server flash:P00308000500.sb2
tftp-server flash:RingList.xml
tftp-server flash:DistinctiveRingList.xml
tftp-server flash:Analog1.raw
tftp-server flash:Analog2.raw
tftp-server flash:AreYouThere.raw
tftp-server flash:AreYouThereF.raw
tftp-server flash:Bass.raw
tftp-server flash:CallBack.raw

8-9 CCNP: Optimizing Converged Networks v5.0 - Lab 2-1 Copyright © 2007, Cisco Systems, Inc
tftp-server flash:Chime.raw
tftp-server flash:Classic1.raw
tftp-server flash:Classic2.raw
tftp-server flash:ClockShop.raw
tftp-server flash:Drums1.raw
tftp-server flash:Drums2.raw
tftp-server flash:FilmScore.raw
tftp-server flash:HarpSynth.raw
tftp-server flash:Jamaica.raw
tftp-server flash:KotoEffect.raw
tftp-server flash:MusicBox.raw
tftp-server flash:Piano1.raw
tftp-server flash:Piano2.raw
tftp-server flash:Pop.raw
tftp-server flash:Pulse1.raw
tftp-server flash:Ring1.raw
tftp-server flash:Ring2.raw
tftp-server flash:Ring3.raw
tftp-server flash:Ring4.raw
tftp-server flash:Ring5.raw
tftp-server flash:Ring6.raw
tftp-server flash:Ring7.raw
tftp-server flash:Sax1.raw
tftp-server flash:Sax2.raw
tftp-server flash:Vibe.raw
!
telephony-service
max-ephones 2
max-dn 10
ip source-address 172.16.10.1 port 2000
system message Cisco VoIP
time-format 24
date-format dd-mm-yy
keepalive 15
max-conferences 8 gain -6
moh music-on-hold.au
transfer-system full-consult
create cnf-files version-stamp Aug 12 2010 13:29:30
!
ephone-dn 1 dual-line
ring internal
number 5001
name Host A
!
ephone-dn 2 dual-line
ring internal
number 5002
name Host B
!
ephone 1
mac-address 000F.F7C0.3506
speed-dial 1 5002 label "Host B"
type 7960
button 1:1
!
ephone 2
mac-address 0011.2013.6C74
speed-dial 1 5001 label "Host A"
type 7960
button 1:2
!
ntp master
end

9-9 CCNP: Optimizing Converged Networks v5.0 - Lab 2-1 Copyright © 2007, Cisco Systems, Inc

You might also like