You are on page 1of 135

Lab 7: Redistribution

Task

1. Configure IP Address as per given in topology.


2. Configure OSPF Area's as per given in topology and provide router id as per router number (like
1.1.1.1 for R1) and configure OSPF through interface only in Area 20.
3. Make sure R5 and R6 able to ping R1. (Do possible changes according to you).
4. Configure EIGRP as per given in topology. Make sure EIGRP AS number is 100.
5. Enable RIP as per given in topology. Make sure RIP v2 configure.
6. Basic redistribution between RIP and OSPF. (All subnets will be redistribute)
7. Basic redistribution between OSPF to EIGRP (all subnets will be redistribute and exclude R6 for
Redistribution).
8. All the Loopback will be manual summarize.

After Completion of this task, verify routes and ping all the routers each other.
Lab 7: Redistribution
Solution
 Task 2: Configure OSPF Area's as per given in topology and provide router id as per router
number (like 1.1.1.1 for R1) and configure OSPF through interface only in Area 20.

R1

router ospf 1
router-id 1.1.1.1
network 10.0.12.0 0.0.0.255 area 0
network 10.0.13.0 0.0.0.255 area 0

R2

router ospf 1
router-id 2.2.2.2
network 10.0.12.0 0.0.0.255 area 0
network 10.0.24.0 0.0.0.255 area 10

R3

router ospf 1
router-id 3.3.3.3
network 10.0.13.0 0.0.0.255 area 0
network 10.0.34.0 0.0.0.255 area 10

R4

router ospf 1
router-id 4.4.4.4
network 10.0.24.0 0.0.0.255 area 10
network 10.0.34.0 0.0.0.255 area 10

R5

interface Serial0/0
ip ospf 1 area 20

R6

interface Serial0/0
ip ospf 1 area 20
Lab 7: Redistribution
 Task 3: Make sure R5 and R6 able to ping R1. (Do possible changes according to you).

R2

router ospf 1
area 10 virtual-link 4.4.4.4

R3

router ospf 1
area 10 virtual-link 4.4.4.4

R4

router ospf 1
area 10 virtual-link 3.3.3.3
area 10 virtual-link 2.2.2.2

 Task 4: Configure EIGRP as per given in topology. Make sure EIGRP AS number is 100.

R3

router eigrp 100


network 10.0.37.0 0.0.0.255
no auto-summary

R6

router eigrp 100


network 10.0.67.0 0.0.0.255
no auto-summary

R7

router eigrp 100


network 10.0.37.0 0.0.0.255
network 10.0.67.0 0.0.0.255
network 10.0.70.0 0.0.0.255
network 10.0.71.0 0.0.0.255
no auto-summary

R10

router eigrp 100


network 10.0.70.0 0.0.0.255
network 10.0.110.0 0.0.0.255
Lab 7: Redistribution
network 10.10.1.0 0.0.0.255
network 10.10.2.0 0.0.0.255
network 10.10.3.0 0.0.0.255
network 10.10.4.0 0.0.0.255
no auto-summary

R11

router eigrp 100


network 10.0.71.0 0.0.0.255
network 10.0.110.0 0.0.0.255
network 11.11.1.0 0.0.0.255
network 11.11.2.0 0.0.0.255
network 11.11.3.0 0.0.0.255
network 11.11.4.0 0.0.0.255
no auto-summary

 Task 5: Enable RIP as per given in topology. Make sure RIP v2 configure.

R2

router rip
version 2
network 10.0.0.0
no auto-summary

R5

router rip
version 2
network 10.0.0.0
no auto-summary

R8

router rip
version 2
network 10.0.0.0
no auto-summary

R9

router rip
version 2
Lab 7: Redistribution
network 9.0.0.0
network 10.0.0.0
no auto-summary

 Task 6: Basic redistribution between RIP and OSPF. (All subnets will be redistribute)

R2

router ospf 1
redistribute rip metric 1 subnets

router rip
redistribute ospf 1 metric 1

R5

router rip
redistribute ospf 1 metric 1

router ospf 1
redistribute rip metric 1 subnets

 Task 7: Basic redistribution between OSPF to EIGRP (All subnets will be redistribute and
exclude R6 for Redistribution).

R3

router eigrp 100


redistribute ospf 1 metric 1 1 1 1 1

router ospf 1
redistribute eigrp 100 metric 1 subnets

 Task 8: All the Loopback will be manual summarize.

R9

interface FastEthernet0/0
ip summary-address rip 9.9.0.0 255.255.248.0

R10

interface Serial0/0
ip summary-address eigrp 100 10.10.0.0 255.255.248.0
Lab 7: Redistribution
interface Serial0/1
ip summary-address eigrp 100 10.10.0.0 255.255.248.0

R11

interface Serial0/0
ip summary-address eigrp 100 11.11.0.0 255.255.248.0

interface Serial0/1
ip summary-address eigrp 100 11.11.0.0 255.255.248.0
Lab 21: OSPF Filtering & Summarization

Task

Figure 1 Topology

1. Configure IP Address as per given in topology.


2. Configure OSPF According to the topology and provide Router-ID as Router Name (like 1.1.1.1 for
R1).
3. Communicate OSPF Area 100 to OSPF Area 0.
4. Make sure R1 not received R12 loopback. Do possible Configuration.
5. Make sure OSPF Area 40 using Totally Stub for LSA Filtering.
6. Make sure R12 not received R10 loopback. Use prefix list for this task.
7. Area 10 not received R7 loopback. Use filter list to complete this task.
8. Make sure R1 Redistribute EIGRP as External type 1.
9. OSPF Area 100 send R12 loopback using manual summarization.
10. Make sure R1 loopback 3 is not advertise in OSPF domain.
Lab 21: OSPF Filtering & Summarization

Solution
 Task 2: Configure OSPF According to the topology and provide Router-ID as Router Name (like
1.1.1.1 for R1).

R1

router ospf 1
router-id 1.1.1.1
network 24.45.99.0 0.0.0.255 area 0
network 25.0.0.0 0.0.0.255 area 0
network 158.52.64.0 0.0.0.255 area 0

R2

router ospf 1
router-id 2.2.2.2
network 15.24.0.0 0.0.0.255 area 10
network 25.0.0.0 0.0.0.255 area 0
network 84.122.34.0 0.0.0.255 area 0
network 99.54.66.0 0.0.0.255 area 0
network 199.50.200.0 0.0.0.255 area 10

R3

router ospf 1
network 25.0.0.0 0.0.0.255 area 0
network 74.175.65.0 0.0.0.255 area 40
network 84.122.34.0 0.0.0.255 area 0
network 158.52.64.0 0.0.0.255 area 0

R4

router ospf 1
router-id 4.4.4.4
network 24.45.99.0 0.0.0.255 area 0
network 25.0.0.0 0.0.0.255 area 0
network 99.54.66.0 0.0.0.255 area 0
network 100.0.0.0 0.0.0.255 area 87
Lab 21: OSPF Filtering & Summarization

R5

router ospf 1
router-id 5.5.5.5
network 145.33.54.0 0.0.0.255 area 10
network 199.50.200.0 0.0.0.255 area 10

R6

router ospf 1
router-id 6.6.6.6
network 15.24.0.0 0.0.0.255 area 10
network 33.42.21.0 0.0.0.255 area 10

R7

router ospf 1
router-id 7.7.7.7
network 7.7.1.1 0.0.0.0 area 40
network 7.7.2.1 0.0.0.0 area 40
network 7.7.3.1 0.0.0.0 area 40
network 7.7.4.1 0.0.0.0 area 40
network 74.175.65.0 0.0.0.255 area 40

R8

router ospf 1
router-id 8.8.8.8
area 100 range 12.12.0.0 255.255.248.0
network 100.0.0.0 0.0.0.255 area 87
network 201.114.25.0 0.0.0.255 area 100

R9

router ospf 1
router-id 9.9.9.9
network 9.9.1.1 0.0.0.0 area 10
network 9.9.2.1 0.0.0.0 area 10
network 9.9.3.1 0.0.0.0 area 10
network 9.9.4.1 0.0.0.0 area 10
network 145.33.54.0 0.0.0.255 area 10
Lab 21: OSPF Filtering & Summarization

R10

router ospf 1
router-id 10.10.10.10
network 10.10.1.0 0.0.0.255 area 10
network 10.10.2.0 0.0.0.255 area 10
network 10.10.3.0 0.0.0.255 area 10
network 10.10.4.0 0.0.0.255 area 10
network 33.42.21.0 0.0.0.255 area 10

R11

router ospf 1
router-id 11.11.11.11
network 11.11.11.1 0.0.0.0 area 40
network 11.11.12.1 0.0.0.0 area 40
network 11.11.13.1 0.0.0.0 area 40
network 11.11.14.1 0.0.0.0 area 40
network 74.175.65.0 0.0.0.255 area 40

R12

router ospf 1
router-id 12.12.12.12
network 12.12.1.1 0.0.0.0 area 100
network 12.12.2.1 0.0.0.0 area 100
network 12.12.3.1 0.0.0.0 area 100
network 12.12.4.1 0.0.0.0 area 100
network 201.114.25.0 0.0.0.255 area 100

 Task 3: Communicate OSPF Area 100 to OSPF Area 0.

R4

router ospf 1
area 87 virtual-link 8.8.8.8

R8

router ospf 1
area 87 virtual-link 4.4.4.4
Lab 21: OSPF Filtering & Summarization

 Task 4: Make sure R1 not received R12 loopback. Do possible Configuration.

R1

access-list 10 deny 12.12.1.0 0.0.0.255


access-list 10 deny 12.12.2.0 0.0.0.255
access-list 10 deny 12.12.3.0 0.0.0.255
access-list 10 deny 12.12.4.0 0.0.0.255
access-list 10 permit any

router ospf 1
distribute-list 10 in FastEthernet0/0
exit

 Task 5: Make sure OSPF Area 40 using Totally Stub for LSA Filtering.

R3

router ospf 1
area 40 stub no-summary
exit

R7

router ospf 1
area 40 stub
exit

R11

router ospf 1
area 40 stub
exit

 Task 6: Make sure R12 not received R10 loopback. Use prefix list for this task.

R12

ip prefix-list R10loop seq 5 deny 10.10.0.0/16 ge 24 le 24


ip prefix-list R10loop seq 10 permit 0.0.0.0/0 le 32

router ospf 1
distribute-list prefix R10loop in FastEthernet0/0
exit
Lab 21: OSPF Filtering & Summarization

 Task 7: Area 10 not received R7 loopback. Use filter list to complete this task.

R2

ip prefix-list R7loop seq 5 deny 7.7.0.0/16 ge 24 le 24


ip prefix-list R7loop seq 10 permit 0.0.0.0/0 le 32

router ospf 1
area 10 filter-list prefix R7loop in
exit

 Task 8: Make sure R1 Redistribute Eigrp as External type 1.

R1

router ospf 1
redistribute eigrp 100 metric 1 metric-type 1 subnets
exit

 Task 9: OSPF Area 100 send R12 loopback using manual summarization.

R8

router ospf 1
area 100 range 12.12.0.0 255.255.248.0
exit

 Task 10: Make sure R1 loopback 3 is not advertise in ospf domain.

R1

router ospf 1
summary-address 100.100.3.0 255.255.255.0 not-advertise
exit
LAB 13: HSRP (Hot Standby Router Protocol)

Task

1. Configure IP Addresses as per given in topology.


2. Configure Web_Server and NTP Server as per given in topology.
3. Configure ISP as a NTP Client.
4. Configure Eigrp as per given in topology.
5. Configure MLS1 and MLS2 for HSRP. Make sure Virtual IP for HSRP is 192.168.200.254.
6. Make sure Authentication on HSRP is MD5 use 4%ghT) as a password.
7. Make sure MLS1 is always Active.
8. Make sure MLS1 and MLS2 track fastethernet 0/0.
9. Make sure PC1, PC2 and PC6 send their traffic to MLS2 and PC3, PC4 and PC5 send traffic from
MLS1 with secure communication. Use Virtual IP is 192.168.200.253 and use authentication MD5
use 4%ghT).
10. Make sure ZBF send internal traffic via NATTING. Use PAT for this senerio.
11. Make sure all Pc's setup clock via NTP Server.
12. Make sure all PC's ping netwaxlab.com and blog.eincop.com.
LAB 13: HSRP (Hot Standby Router Protocol)

Solution
 Task 2: Configure Web_Server and NTP Server as per given in topology.

Server

no ip routing
ip default-gateway 169.112.87.1

Web_Server

ip dns server
ip host netwaxlab.com 100.100.100.100
ip host blog.eincop.com 101.101.101.101

NTP

Server# set clock (you need to set clock with this command)
Server(config)# ntp master

 Task 3: Configure ISP as a NTP Client.

Server(config)# ntp server 169.112.87.200

 Task 4: Configure Eigrp as per given in topology.

ZBF

router eigrp 100


redistribute static
network 192.168.1.0
no auto-summary
exit

HQ

router eigrp 100


network 10.0.0.0 0.0.0.255
network 20.0.0.0 0.0.0.255
network 192.168.1.0
no auto-summary
exit

(NOTE: Make sure you need to use "ip routing" command to enable routing on Multi Layer Switch)
LAB 13: HSRP (Hot Standby Router Protocol)

MLS1

ip routing

router eigrp 100


network 10.0.0.0 0.0.0.255
network 192.168.200.0
no auto-summary
exit

MLS2

router eigrp 100


network 20.0.0.0 0.0.0.255
network 192.168.200.0
no auto-summary
exit

 Task 5: Configure MLS1 and MLS2 for HSRP. Make sure Virtual IP for HSRP is 192.168.200.254.

MLS1

interface f0/1
standby 1 ip 192.168.200.254
standby 1 priority 200
exit

MLS2

interface f0/1
standby 1 ip 192.168.200.254
exit

 Task 6: Make sure Authentication on HSRP is MD5 use 4%ghT) as a password.

MLS1

interface f0/1
standby 1 authentication md5 key-string 4%ghT)

MLS2

interface f0/1
standby 1 authentication md5 key-string 4%ghT)
LAB 13: HSRP (Hot Standby Router Protocol)

 Task 7: Make sure MLS1 is always Active after recover the link.

MLS1

interface f0/1
standby 1 preempt
exit

 Task 8: Make sure MLS1 and MLS2 track fastethernet 0/0.

MLS1

interface f0/1
standby 1 track f0/0
exit

MLS2

interface f0/1
standby 1 track f0/0
exit

 Task 9: Make sure PC1, PC2 and PC6 send their traffic to MLS2 and PC3, PC4 and PC5 send
traffic from MLS1 with secure communication. Use Virtual IP is 192.168.200.253 and use
authentication MD5 use 4%ghT).

(NOTE: Load Balancing Concept in HSRP)

MLS1

interface f0/1
standby 2 ip 192.168.200.253
standby 2 authentication md5 key-string 4%ghT)
standby 2 track FastEthernet0/0
exit

MLS2

standby 2 ip 192.168.200.253
standby 2 priority 200
standby 2 preempt
standby 2 authentication md5 key-string 4%ghT)
standby 2 track FastEthernet0/0
LAB 13: HSRP (Hot Standby Router Protocol)

(NOTE: Configure PC1, PC2 and PC6 default gateway is 192.168.200.253 and PC3, PC4 and PC5 default
gateway is 192.168.200.254.)

 Task 10: Make sure ZBF send internal traffic via NATTING. Use PAT for this scenario.

ZBF

ip access-list extended NAT


permit ip 192.168.1.0 0.0.0.255 any
permit ip 10.0.0.0 0.0.0.255 any
permit ip 20.0.0.0 0.0.0.255 any
permit ip 192.168.200.0 0.0.0.255 any
exit

interface f0/1
ip nat inside
exit

interface f0/0
ip nat outside
exit

ip nat inside source list NAT interface FastEthernet0/0 overload

verify it using "sh ip nat translations" command.

 Task 11: Make sure all Pc's setup clock via NTP Server.

(NOTE: you need to use clock setting in your pc and provide NTP server ip address. It will sync and show
the time)

 Task 12: Make sure all PC's ping netwaxlab.com and blog.eincop.com.

(NOTE: first you need to ping 169.112.87.200, If it will response then you need to configure you dns
using the same ip).

Now generate ping for netwaxlab.com and blog.eincop.com.

Make sure you need to provide static route in ISP to 100,100.100.100 and 101.101.101.101.
LAB 13: HSRP (Hot Standby Router Protocol)

Task

1. Configure IP Addresses as per given in topology.


2. Configure Web_Server and NTP Server as per given in topology.
3. Configure ISP as a NTP Client.
4. Configure Eigrp as per given in topology.
5. Configure MLS1 and MLS2 for HSRP. Make sure Virtual IP for HSRP is 192.168.200.254.
6. Make sure Authentication on HSRP is MD5 use 4%ghT) as a password.
7. Make sure MLS1 is always Active.
8. Make sure MLS1 and MLS2 track fastethernet 0/0.
9. Make sure PC1, PC2 and PC6 send their traffic to MLS2 and PC3, PC4 and PC5 send traffic from
MLS1 with secure communication. Use Virtual IP is 192.168.200.253 and use authentication MD5
use 4%ghT).
10. Make sure ZBF send internal traffic via NATTING. Use PAT for this senerio.
11. Make sure all Pc's setup clock via NTP Server.
12. Make sure all PC's ping netwaxlab.com and blog.eincop.com.
LAB 13: HSRP (Hot Standby Router Protocol)

Solution
 Task 2: Configure Web_Server and NTP Server as per given in topology.

Server

no ip routing
ip default-gateway 169.112.87.1

Web_Server

ip dns server
ip host netwaxlab.com 100.100.100.100
ip host blog.eincop.com 101.101.101.101

NTP

Server# set clock (you need to set clock with this command)
Server(config)# ntp master

 Task 3: Configure ISP as a NTP Client.

Server(config)# ntp server 169.112.87.200

 Task 4: Configure Eigrp as per given in topology.

ZBF

router eigrp 100


redistribute static
network 192.168.1.0
no auto-summary
exit

HQ

router eigrp 100


network 10.0.0.0 0.0.0.255
network 20.0.0.0 0.0.0.255
network 192.168.1.0
no auto-summary
exit

(NOTE: Make sure you need to use "ip routing" command to enable routing on Multi Layer Switch)
LAB 13: HSRP (Hot Standby Router Protocol)

MLS1

ip routing

router eigrp 100


network 10.0.0.0 0.0.0.255
network 192.168.200.0
no auto-summary
exit

MLS2

router eigrp 100


network 20.0.0.0 0.0.0.255
network 192.168.200.0
no auto-summary
exit

 Task 5: Configure MLS1 and MLS2 for HSRP. Make sure Virtual IP for HSRP is 192.168.200.254.

MLS1

interface f0/1
standby 1 ip 192.168.200.254
standby 1 priority 200
exit

MLS2

interface f0/1
standby 1 ip 192.168.200.254
exit

 Task 6: Make sure Authentication on HSRP is MD5 use 4%ghT) as a password.

MLS1

interface f0/1
standby 1 authentication md5 key-string 4%ghT)

MLS2

interface f0/1
standby 1 authentication md5 key-string 4%ghT)
LAB 13: HSRP (Hot Standby Router Protocol)

 Task 7: Make sure MLS1 is always Active after recover the link.

MLS1

interface f0/1
standby 1 preempt
exit

 Task 8: Make sure MLS1 and MLS2 track fastethernet 0/0.

MLS1

interface f0/1
standby 1 track f0/0
exit

MLS2

interface f0/1
standby 1 track f0/0
exit

 Task 9: Make sure PC1, PC2 and PC6 send their traffic to MLS2 and PC3, PC4 and PC5 send
traffic from MLS1 with secure communication. Use Virtual IP is 192.168.200.253 and use
authentication MD5 use 4%ghT).

(NOTE: Load Balancing Concept in HSRP)

MLS1

interface f0/1
standby 2 ip 192.168.200.253
standby 2 authentication md5 key-string 4%ghT)
standby 2 track FastEthernet0/0
exit

MLS2

standby 2 ip 192.168.200.253
standby 2 priority 200
standby 2 preempt
standby 2 authentication md5 key-string 4%ghT)
standby 2 track FastEthernet0/0
LAB 13: HSRP (Hot Standby Router Protocol)

(NOTE: Configure PC1, PC2 and PC6 default gateway is 192.168.200.253 and PC3, PC4 and PC5 default
gateway is 192.168.200.254.)

 Task 10: Make sure ZBF send internal traffic via NATTING. Use PAT for this scenario.

ZBF

ip access-list extended NAT


permit ip 192.168.1.0 0.0.0.255 any
permit ip 10.0.0.0 0.0.0.255 any
permit ip 20.0.0.0 0.0.0.255 any
permit ip 192.168.200.0 0.0.0.255 any
exit

interface f0/1
ip nat inside
exit

interface f0/0
ip nat outside
exit

ip nat inside source list NAT interface FastEthernet0/0 overload

verify it using "sh ip nat translations" command.

 Task 11: Make sure all Pc's setup clock via NTP Server.

(NOTE: you need to use clock setting in your pc and provide NTP server ip address. It will sync and show
the time)

 Task 12: Make sure all PC's ping netwaxlab.com and blog.eincop.com.

(NOTE: first you need to ping 169.112.87.200, If it will response then you need to configure you dns
using the same ip).

Now generate ping for netwaxlab.com and blog.eincop.com.

Make sure you need to provide static route in ISP to 100,100.100.100 and 101.101.101.101.
Lab 20: NATing
Task

Figure 1 Topology

1. Configure IP Addresses as per given in topology.


2. Make sure EIGRP as 100 running over internal network.
3. On R2, Make sure R3 loopback will be Nating dynamically and the range is 114.52.8.3-114.52.8.6.
4. Network 10.0.23.0, 10.0.24.0, 10.0.47.0, 10.0.37.0 will be PAT.
5. R7 loopback will be statically NAT with IP's 114.52.8.10, 114.52.8.11, 114.52.8.12, 114.52.8.13.
6. R4 loopback's will be Nat. Use single ip 114.52.8.100 to accomplish this task.
7. On R1, Network 10.0.45.0, 10.0.15.0, 10.0.56.0 will be PAT.
8. R5 loopbacks will be dynamically Nating, The Range for Nating are 113.24.55.101 -
113.24.55.104.
9. R6 loopback will be Nat. Use single ip 113.24.55.254 to accomplish this task.
10. Make sure all networks and loopbacks ping netwaxlab.com and blog.eincop.com.
Lab 20: NATing
Solution
 Task 2: Make sure EIGRP as 100 running over internal network.

R1

router eigrp 100


redistribute static metric 1 1 1 1 1
network 10.0.15.0 0.0.0.255
network 10.0.56.0 0.0.0.255
no auto-summary

R2

router eigrp 100


redistribute static metric 1 1 1 1 1
network 10.0.23.0 0.0.0.255
network 10.0.24.0 0.0.0.255
no auto-summary

R3

router eigrp 100


network 3.3.1.0 0.0.0.255
network 3.3.2.0 0.0.0.255
network 3.3.3.0 0.0.0.255
network 3.3.4.0 0.0.0.255
network 10.0.23.0 0.0.0.255
network 10.0.37.0 0.0.0.255
no auto-summary

R4

router eigrp 100


network 4.4.1.0 0.0.0.255
network 4.4.2.0 0.0.0.255
network 4.4.3.0 0.0.0.255
network 4.4.4.0 0.0.0.255
network 10.0.24.0 0.0.0.255
network 10.0.45.0 0.0.0.255
network 10.0.47.0 0.0.0.255
no auto-summary
Lab 20: NATing
R5

router eigrp 100


network 5.5.1.0 0.0.0.255
network 5.5.2.0 0.0.0.255
network 5.5.3.0 0.0.0.255
network 5.5.4.0 0.0.0.255
network 10.0.15.0 0.0.0.255
network 10.0.45.0 0.0.0.255
no auto-summary

R6

router eigrp 100


network 6.6.1.0 0.0.0.255
network 6.6.2.0 0.0.0.255
network 6.6.3.0 0.0.0.255
network 6.6.4.0 0.0.0.255
network 10.0.56.0 0.0.0.255
no auto-summary

R7

router eigrp 100


network 7.7.1.0 0.0.0.255
network 7.7.2.0 0.0.0.255
network 7.7.3.0 0.0.0.255
network 7.7.4.0 0.0.0.255
network 10.0.37.0 0.0.0.255
network 10.0.47.0 0.0.0.255
no auto-summary

During NAT, You need to use commands on R1 and R2

R1 & R2

interface f0/0
ip nat outside
exit

int se0/0
ip nat inside
exit
Lab 20: NATing
int se0/1
ip nat inside
exit

 Task 3: On R2, Make sure R3 loopback will be Nating dynamically and the range is 114.52.8.3 -
114.52.8.6.

R2

ip access-list extended NAT


permit ip 3.3.1.0 0.0.0.255 any
permit ip 3.3.2.0 0.0.0.255 any
permit ip 3.3.3.0 0.0.0.255 any
permit ip 3.3.4.0 0.0.0.255 any
exit

ip nat pool R3 114.52.8.3 114.52.8.6 netmask 255.255.255.0


ip nat inside source list NAT pool R3

 Task 4: Network 10.0.23.0, 10.0.24.0, 10.0.47.0, 10.0.37.0 will be PAT.

R2

ip access-list extended PAT


permit ip 10.0.23.0 0.0.0.255 any
permit ip 10.0.37.0 0.0.0.255 any
permit ip 10.0.47.0 0.0.0.255 any
permit ip 10.0.24.0 0.0.0.255 any
exit

ip nat inside source list PAT interface FastEthernet0/0 overload

 Task 5: R7 loopback will be statically NAT with IP's 114.52.8.10, 114.52.8.11, 114.52.8.12,
114.52.8.13.

R2

ip nat inside source static 7.7.1.1 114.52.8.10


ip nat inside source static 7.7.2.1 114.52.8.11
ip nat inside source static 7.7.3.1 114.52.8.12
ip nat inside source static 7.7.4.1 114.52.8.13
Lab 20: NATing
 Task 6: R4 loopback's will be Nat. Use single ip 114.52.8.100 to accomplish this task.

R2

ip access-list extended R4loopback


permit ip 4.4.1.0 0.0.0.255 any
permit ip 4.4.2.0 0.0.0.255 any
permit ip 4.4.3.0 0.0.0.255 any
permit ip 4.4.4.0 0.0.0.255 any
exit

ip nat pool R4loop 114.52.8.100 114.52.8.100 netmask 255.255.255.0


ip nat inside source list R4loopback pool R4loop overload

 Task 7: On R1, Network 10.0.45.0, 10.0.15.0, 10.0.56.0 will be PAT.

R1

ip access-list extended PAT


permit ip 10.0.45.0 0.0.0.255 any
permit ip 10.0.15.0 0.0.0.255 any
permit ip 10.0.56.0 0.0.0.255 any
exit

ip nat inside source list PAT interface FastEthernet0/0 overload

 Task 8: R5 loopbacks will be dynamically Nating, The Range for Nating are 113.24.55.101 -
113.24.55.104.

R1

ip access-list extended R5
permit ip 5.5.1.0 0.0.0.255 any
permit ip 5.5.2.0 0.0.0.255 any
permit ip 5.5.3.0 0.0.0.255 any
permit ip 5.5.4.0 0.0.0.255 any
exit

ip nat pool R5 113.24.55.101 113.24.55.104 netmask 255.255.255.0


ip nat inside source list R5 pool R5
Lab 20: NATing
 Task 9: R6 loopback will be Nat. Use single ip 113.24.55.254 to accomplish this task.

R1

ip access-list extended R6
permit ip 6.6.1.0 0.0.0.255 any
permit ip 6.6.2.0 0.0.0.255 any
permit ip 6.6.3.0 0.0.0.255 any
permit ip 6.6.4.0 0.0.0.255 any
exit

ip nat pool R6 113.24.55.254 113.24.55.254 netmask 255.255.255.0


ip nat inside source list R6 pool R6 overload

 Task 10: Make sure all networks and loopbacks ping netwaxlab.com and blog.eincop.com.

On All Routers

ip domain-lookup
ip name-server 66.1.38.2
Lab 19: VRRP (Virtual Router Redundancy Protocol)

Task

Figure 1 Topology

1. Configure IP Address as per given in toplogy.


2. Configure DNS Server on Server as per given in topology and Make sure ISP ping all the DNS.
3. Configure Routing Protocol in between HQ, R1 and R2.
4. Configure VRRP between R1 and R2. Use Virtual IP 10.0.0.254 for VRRP.
5. Make sure R1 is Master for VRRP. Do possible configuration.
6. Make sure VRRP use MD5 authentication with password "netwaxlab@109".
7. Configure VRRP Load Balancing using group number. Use Virtual IP 10.0.0.193. Make sure R2 is
master.
8. Make sure Authentication is enable for VRRP Load Balancing use key-string as
"Blog.Eincop.com@109".
9. Make sure Tracking is enable in VRRP.
10. Configure PC1 and PC4 send traffic via 10.0.0.254 and rest of all PC's send traffic via 10.0.0.193.
Lab 19: VRRP (Virtual Router Redundancy Protocol)

Solution
 Task 2: Configure DNS Server on Server as per given in topology and Make sure ISP ping all the
DNS.

DNS

interface Loopback1
ip address 100.100.100.100 255.255.255.255

interface Loopback2
ip address 100.100.100.101 255.255.255.255

ip dns server
ip host netwaxlab.com 100.100.100.100
ip host blog.eincop.com 100.100.100.101

ISP

ip route 100.100.100.100 255.255.255.255 88.25.34.199


ip route 100.100.100.101 255.255.255.255 88.25.34.199

 Task 3: Configure Routing Protocol in between HQ, R1 and R2.

HQ

router eigrp 100


redistribute static metric 1 1 1 1 1
network 192.168.10.0
network 192.168.20.0
no auto-summary
exit

R1

router eigrp 100


network 10.0.0.0 0.0.0.255
network 192.168.20.0
no auto-summary
exit
Lab 19: VRRP (Virtual Router Redundancy Protocol)

R2

router eigrp 100


network 10.0.0.0 0.0.0.255
network 192.168.10.0
no auto-summary
exit

 Task 4: Configure VRRP between R1 and R2. Use Virtual IP 10.0.0.254 for VRRP.

R1

interface FastEthernet0/1
vrrp 1 ip 10.0.0.254
exit

R2

interface FastEthernet0/1
vrrp 1 ip 10.0.0.254
exit

 Task 5: Make sure R1 is Master for VRRP. Do possible configuration.

R1

interface FastEthernet0/1
vrrp 1 priority 110
exit

 Task 6: Make sure VRRP use MD5 authentication with password "netwaxlab@109".

R1

interface FastEthernet0/1
vrrp 1 authentication md5 key-string netwaxlab@109
exit

R2

interface FastEthernet0/1
vrrp 1 authentication md5 key-string netwaxlab@109
exit
Lab 19: VRRP (Virtual Router Redundancy Protocol)

 Task 7: Configure VRRP Load Balancing using group number. Use Virtual IP 10.0.0.193. Make
sure R2 is master.

R1

interface FastEthernet0/1
vrrp 2 ip 10.0.0.193
exit

R2

interface FastEthernet0/1
vrrp 2 ip 10.0.0.193
vrrp 2 priority 110
exit

 Task 8: Make sure Authentication is enable for VRRP Load Balancing use key-string as
"Blog.Eincop.com@109".

R1

interface FastEthernet0/1
vrrp 2 authentication md5 key-string Blog.Eincop.com@109
exit

R2

interface FastEthernet0/1
vrrp 2 authentication md5 key-string Blog.Eincop.com@109
exit

 Task 9: Make sure Tracking is enable in VRRP.

R1

track 1 ip route 192.168.20.0 255.255.255.0 reachability

interface FastEthernet0/1
vrrp 1 track 1 decrement 20
exit
Lab 19: VRRP (Virtual Router Redundancy Protocol)

R2

track 1 ip route 192.168.10.0 255.255.255.0 reachability

interface FastEthernet0/1
vrrp 2 track 1 decrement 20
exit

 Task 10: Configure PC1 and PC4 send traffic via 10.0.0.254 and rest of all PC's send traffic via
10.0.0.193.

(Note: Use your PC interface and configure default gateway as per given in task.)
Lab 9: Access-List

Task

1. Configure IP Address as per given in topology.


2. Configure Inter-Vlan routing between Vlan 10 and Vlan 20 on R4 and R5 routers.
3. Configure Eigrp on all the routers.
4. Configure DNS on Server. Use 100.100.100.100 for netwaxlab.com and 101.101.101.101 for
blog.eincop.com. Redirect all the routers for DNS for address resolution.
5. Enable Telnet on R4 and R5. Ensure that only R2 access R4 and R5 telnet. (Using Standard Access-
list and maintain Eigrp neighborship).
6. Enable SSH on R1 and ensure that only R5 access R1 SSH.
7. Ensure that Vlan 10 not access Vlan 20 over the network but locally they can communicate each
other.
8. Vlan 20 only access website netwaxlab.com
9. Vlan 10 only access website blog.eincop.com
10. R1 not able to access websites.
11. R1 not communicate 192.168.110.1 and 10.145.120.1.
12. R2 not able to ping on R5 but able to access telnet on R5.
Lab 9: Access-List

Solution
 Task 2: Configure Inter-Vlan routing between Vlan 10 and Vlan 20 on R4 and R5 routers.

R4

interface FastEthernet0/0
no shut
exit

interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.110.4 255.255.255.0

interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.120.4 255.255.255.0

interface Serial0/0
ip address 55.117.118.4 255.255.255.0
no shut
exit

R5

interface FastEthernet0/0
no shut
exit

interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 10.144.110.5 255.255.255.0

interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 10.145.120.5 255.255.255.0

interface Serial0/0
ip address 97.110.0.5 255.255.255.0
no shut
exit
Lab 9: Access-List
 Task3: Configure Eigrp on all the routers.

R1

router eigrp 100


network 66.34.74.0 0.0.0.255
no auto-summary

R2

router eigrp 100


redistribute static
network 52.34.114.0 0.0.0.255
network 81.98.67.0 0.0.0.255
no auto-summary

R3

router eigrp 100


network 55.117.118.0 0.0.0.255
network 66.34.74.0 0.0.0.255
network 81.98.67.0 0.0.0.255
network 97.110.0.0 0.0.0.255
no auto-summary

R4

router eigrp 100


network 55.117.118.0 0.0.0.255
network 192.168.110.0
network 192.168.120.0
no auto-summary

R5

router eigrp 100


network 10.144.110.0 0.0.0.255
network 10.145.120.0 0.0.0.255
network 97.110.0.0 0.0.0.255
no auto-summary
Lab 9: Access-List
 Task 4: Configure DNS on Server. Use 100.100.100.100 for netwaxlab.com and 101.101.101.101
for blog.eincop.com. Redirect all the routers for DNS for address resolution.

(Note: Configure DNS on each pc with ip address 52.34.114.200)

Server

ip dns server
ip host netwaxlab.com 100.100.100.100
ip host blog.eincop.com 101.101.101.101

Configure this command on all routers

ip domain lookup
ip name-server 52.34.114.200

 Task 5: Enable Telnet on R4 and R5. Ensure that only R2 access R4 and R5 telnet. (Using
Standard Access-list and maintain Eigrp neighborship).

Enable Telnet on R4 and R5

R4

enable secret cisco


line vty 0 4
login local
exit

username cisco password cisco

access-list 10 permit 81.98.67.2


access-list 10 deny any

line vty 0 4
access-class 10 in
exit

R5

enable secret cisco


line vty 0 4
login local
exit
Lab 9: Access-List
username cisco password cisco

access-list 10 permit 81.98.67.2


access-list 10 deny any

line vty 0 4
access-class 10 in
exit

 Task 6: Enable SSH on R1 and ensure that only R5 access R1 SSH.

R1

ip domain name R1
crypto key generate rsa
1024

access-list 10 permit 97.110.0.5

line vty 0 4
login local
transport input ssh
access-class 10 in
exit

username cisco password cisco

 Task 7: Ensure that Vlan 10 not access Vlan 20 over the network but locally they can
communicate each other.

R3

ip access-list extended Routes


deny ip 192.168.110.0 0.0.0.255 10.145.120.0 0.0.0.255
deny ip 10.144.110.0 0.0.0.255 192.168.120.0 0.0.0.255
permit ip any any
exit

interface serial0/3
ip access-group Routes in
exit
Lab 9: Access-List
interface serial0/2
ip access-group Routes in
exit

 Task 8: Vlan 20 only access netwaxlab.com website.

R2

ip access-list extended website


deny ip 192.168.120.0 0.0.0.255 host 101.101.101.101
deny ip 10.145.120.0 0.0.0.255 host 101.101.101.101
permit ip any any
exit

interface serial0/0
ip access-group website in
exit

 Task 9: Vlan 10 only access blog.eincop.com website.

R2

ip access-list extended website


deny ip 192.168.110.0 0.0.0.255 host 100.100.100.100
deny ip 10.144.110.0 0.0.0.255 host 100.100.100.100
permit ip any any
exit

interface serial0/0
ip access-group website in
exit

 Task 10: R1 not able to access websites.

R2

ip access-list extended website


deny ip 66.34.74.0 0.0.0.255 host 100.100.100.100
deny ip 66.34.74.0 0.0.0.255 host 101.101.101.101
permit ip any any
exit

interface serial0/0
ip access-group website in
Lab 9: Access-List
exit

 Task 11: R1 not communicate 192.168.110.1 and 10.145.120.1

R3

ip access-list extended Routes


deny ip host 66.34.74.1 host 192.168.110.1
deny ip host 66.34.74.1 host 10.145.120.1
permit ip any any
exit

interface serial0/0
ip access-group Routes in
exit

 Task 12: R2 not able to ping on R5 but able to access telnet on R5.

ip access-list extended ping


permit eigrp any any
deny icmp host 81.98.67.2 host 97.110.0.5
permit ip any any
exit

interface serial0/0
ip access-group ping in
exit
LAB 11: BGP

Task

Figure 1 Topology

1. Configure IP Addresses as per given in topology.


2. Configure IBGP neighborship as per given in topology. Advertise loopback 1 and loopback 2 in
IBGP.
3. Configure Internal BGP neighbor as per given in topology.
4. Make sure Loopback 3 and loopback 4 introduce in BGP network.
5. R3 to R7 receives all the loopback network information in BGP table. (Verify after completion of
this task).
6. Configuration Sub-AS's in BGP AS 300. Make sure R10 and R12 make neighborship with R8 and
R11.
7. Make sure R1 and R2 advertise all the loopbacks in BGP.
8. Configure EBGP neighborship as per given in topology. Make sure EBGP neighborship is configure
using loopback 1 only.
9. Make sure all routers ping loopback addresses. (Do possible Configuration)
10. On R2, Configure R14 as a best path for Network 3.3.3.0 and R8 as a best path for Network
3.3.4.0.
11. Configure weight as 1440 on R8 to make R7 as a best path for BGP routes.
12. Make sure R7 Receives metric 10000 for Network 2.2.1.0 from R3.
LAB 11: BGP
Solution
 Tasks 2: Configure IBGP neighborship as per given in topology. Advertise loopback 1 and
loopback 2 in IBGP.

R3

router eigrp 100


network 3.3.1.0 0.0.0.255
network 3.3.2.0 0.0.0.255
network 10.0.34.0 0.0.0.255
network 10.0.37.0 0.0.0.255
no auto-summary

R4

router eigrp 100


network 4.4.1.0 0.0.0.255
network 4.4.2.0 0.0.0.255
network 10.0.34.0 0.0.0.255
network 10.0.45.0 0.0.0.255
network 10.0.46.0 0.0.0.255
no auto-summary

R5

router eigrp 100


network 5.5.1.0 0.0.0.255
network 5.5.2.0 0.0.0.255
network 10.0.45.0 0.0.0.255
network 10.0.56.0 0.0.0.255
network 10.0.57.0 0.0.0.255
no auto-summary

R6

router eigrp 100


network 6.6.1.0 0.0.0.255
network 6.6.2.0 0.0.0.255
network 10.0.46.0 0.0.0.255
network 10.0.56.0 0.0.0.255
network 10.0.67.0 0.0.0.255
no auto-summary
LAB 11: BGP
R7

router eigrp 100


network 7.7.1.0 0.0.0.255
network 7.7.2.0 0.0.0.255
network 10.0.37.0 0.0.0.255
network 10.0.57.0 0.0.0.255
network 10.0.67.0 0.0.0.255
auto-summary

R8

router ospf 1
network 8.8.1.0 0.0.0.255 area 0
network 8.8.2.0 0.0.0.255 area 0
network 10.0.80.0 0.0.0.255 area 0
network 10.0.89.0 0.0.0.255 area 0

R9

router ospf 1
network 9.9.1.0 0.0.0.255 area 0
network 9.9.2.0 0.0.0.255 area 0
network 10.0.89.0 0.0.0.255 area 0

R10

router ospf 1
network 10.0.80.0 0.0.0.255 area 0
network 10.0.110.0 0.0.0.255 area 0
network 10.10.1.0 0.0.0.255 area 0
network 10.10.2.0 0.0.0.255 area 0

R11

router ospf 1
network 10.0.110.0 0.0.0.255 area 0
network 10.0.112.0 0.0.0.255 area 0
network 11.11.1.0 0.0.0.255 area 0
network 11.11.2.0 0.0.0.255 area 0
LAB 11: BGP
R12

router ospf 1
network 10.0.112.0 0.0.0.255 area 0
network 12.12.1.0 0.0.0.255 area 0
network 12.12.2.0 0.0.0.255 area 0

R13

router eigrp 200


network 10.0.134.0 0.0.0.255
network 13.13.1.0 0.0.0.255
network 13.13.2.0 0.0.0.255
no auto-summary

R14

router eigrp 200


network 10.0.134.0 0.0.0.255
network 14.14.1.0 0.0.0.255
network 14.14.2.0 0.0.0.255
no auto-summary

 Task 3: Configure Internal BGP neighbor as per given in topology. (Task 6 also complete)

R3

router bgp 1100


neighbor 10.0.34.4 remote-as 1100
neighbor 10.0.37.7 remote-as 1100

R4

router bgp 1100


neighbor 10.0.34.3 remote-as 1100
neighbor 10.0.45.5 remote-as 1100
neighbor 10.0.46.6 remote-as 1100

R5

router bgp 1100


neighbor 10.0.45.4 remote-as 1100
neighbor 10.0.56.6 remote-as 1100
neighbor 10.0.57.7 remote-as 1100
LAB 11: BGP
R6

router bgp 1100


neighbor 10.0.46.4 remote-as 1100
neighbor 10.0.56.5 remote-as 1100
neighbor 10.0.67.7 remote-as 1100

R7

router bgp 1100


neighbor 10.0.37.3 remote-as 1100
neighbor 10.0.57.5 remote-as 1100
neighbor 10.0.67.6 remote-as 1100

R8

router bgp 300


bgp confederation identifier 300
bgp confederation peers 600
neighbor 10.0.80.10 remote-as 600
neighbor 10.0.89.9 remote-as 300

R9

router bgp 300


neighbor 10.0.89.8 remote-as 300

R10

router bgp 600


bgp confederation identifier 300
bgp confederation peers 300
neighbor 10.0.80.8 remote-as 300
neighbor 10.0.110.11 remote-as 300

R11

router bgp 300


bgp confederation identifier 300
bgp confederation peers 600 700
neighbor 10.0.110.10 remote-as 600
neighbor 10.0.112.12 remote-as 700
LAB 11: BGP
R12

router bgp 700


bgp confederation identifier 300
bgp confederation peers 300
neighbor 10.0.112.11 remote-as 300

R13

router bgp 60
neighbor 10.0.134.14 remote-as 60

R14

router bgp 60
neighbor 10.0.134.13 remote-as 60

 Task 4: Make sure Loopback 3 and loopback 4 introduce in BGP network.

R3

router bgp 1100


network 3.3.3.0 mask 255.255.255.0
network 3.3.4.0 mask 255.255.255.0

R4

router bgp 1100


network 4.4.3.0 mask 255.255.255.0
network 4.4.4.0 mask 255.255.255.0

R5

router bgp 1100


network 5.5.3.0 mask 255.255.255.0
network 5.5.4.0 mask 255.255.255.0

R6

router bgp 1100


network 6.6.3.0 mask 255.255.255.0
network 6.6.4.0 mask 255.255.255.0
LAB 11: BGP
R7

router bgp 1100


network 7.7.3.0 mask 255.255.255.0
network 7.7.4.0 mask 255.255.255.0

R8

router bgp 300


network 8.8.3.0 mask 255.255.255.0
network 8.8.4.0 mask 255.255.255.0

R9

router bgp 300


network 9.9.3.0 mask 255.255.255.0
network 9.9.4.0 mask 255.255.255.0

R10

router bgp 600


network 10.10.3.0 mask 255.255.255.0
network 10.10.4.0 mask 255.255.255.0

R11

router bgp 300


network 11.11.3.0 mask 255.255.255.0
network 11.11.4.0 mask 255.255.255.0

R12

router bgp 700


network 12.12.3.0 mask 255.255.255.0
network 12.12.4.0 mask 255.255.255.0

R13

router bgp 60
network 13.13.3.0 mask 255.255.255.0
network 13.13.4.0 mask 255.255.255.0
LAB 11: BGP
R14

router bgp 60
network 14.14.3.0 mask 255.255.255.0
network 14.14.4.0 mask 255.255.255.0

 Task 5: R3 to R7 receives all the loopback network information in bgp table. (verify after
completion of this task).

R4

router bgp 1100


neighbor 10.0.34.3 route-reflector-client
neighbor 10.0.45.5 route-reflector-client
neighbor 10.0.46.6 route-reflector-client

R6

router bgp 1100


neighbor 10.0.67.7 route-reflector-client

 Task 6: Task 6 also complete in Task 3.


 Task 7: Make sure R1 and R2 advertise all the loopbacks in BGP.

R1

router bgp 100


network 1.1.1.0 mask 255.255.255.0
network 1.1.2.0 mask 255.255.255.0
network 1.1.3.0 mask 255.255.255.0
network 1.1.4.0 mask 255.255.255.0

R2

router bgp 200


network 2.2.1.0 mask 255.255.255.0
network 2.2.2.0 mask 255.255.255.0
network 2.2.3.0 mask 255.255.255.0
network 2.2.4.0 mask 255.255.255.0
LAB 11: BGP

 Task 8: Configure EBGP Neighborship as per given in topology. Make sure EBGP neighborship is
configure using loopback 1 only.

R1

ip route 2.2.1.0 255.255.255.0 10.0.12.2


ip route 3.3.1.0 255.255.255.0 10.0.13.3

router bgp 100


neighbor 2.2.1.1 remote-as 200
neighbor 2.2.1.1 ebgp-multihop 2
neighbor 2.2.1.1 update-source Loopback1
neighbor 3.3.1.1 remote-as 1100
neighbor 3.3.1.1 ebgp-multihop 2
neighbor 3.3.1.1 update-source Loopback1
neighbor 10.0.12.2 remote-as 200
neighbor 10.0.13.3 remote-as 1100

R2

ip route 1.1.1.0 255.255.255.0 10.0.12.1


ip route 8.8.1.0 255.255.255.0 10.0.28.8
ip route 14.14.1.0 255.255.255.0 10.0.124.14

router bgp 200


neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 ebgp-multihop 2
neighbor 1.1.1.1 update-source Loopback1
neighbor 8.8.1.1 remote-as 300
neighbor 8.8.1.1 ebgp-multihop 2
neighbor 8.8.1.1 update-source Loopback1
neighbor 10.0.12.1 remote-as 100
neighbor 10.0.28.8 remote-as 300
neighbor 10.0.124.14 remote-as 60
neighbor 14.14.1.1 remote-as 60
neighbor 14.14.1.1 ebgp-multihop 2
neighbor 14.14.1.1 update-source Loopback1
LAB 11: BGP
R3

router bgp 1100


neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 ebgp-multihop 2
neighbor 1.1.1.1 update-source Loopback1
neighbor 10.0.13.1 remote-as 100

R5

router bgp 1100


neighbor 10.0.53.13 remote-as 60
neighbor 13.13.1.1 remote-as 60
neighbor 13.13.1.1 ebgp-multihop 2
neighbor 13.13.1.1 update-source Loopback1

R7

router bgp 1100


neighbor 8.8.1.1 remote-as 300
neighbor 8.8.1.1 ebgp-multihop 2
neighbor 8.8.1.1 update-source Loopback1
neighbor 10.0.78.8 remote-as 300

R8

router bgp 300


neighbor 2.2.1.1 remote-as 200
neighbor 2.2.1.1 ebgp-multihop 2
neighbor 2.2.1.1 update-source Loopback1
neighbor 7.7.1.1 remote-as 1100
neighbor 7.7.1.1 ebgp-multihop 2
neighbor 7.7.1.1 update-source Loopback1
neighbor 10.0.28.2 remote-as 200
neighbor 10.0.78.7 remote-as 1100

R11

router bgp 300


neighbor 10.0.114.14 remote-as 60
neighbor 14.14.1.1 remote-as 60
neighbor 14.14.1.1 ebgp-multihop 2
neighbor 14.14.1.1 update-source Loopback1
LAB 11: BGP
R13

router bgp 60
neighbor 5.5.1.1 remote-as 1100
neighbor 5.5.1.1 ebgp-multihop 2
neighbor 5.5.1.1 update-source Loopback1
neighbor 10.0.53.5 remote-as 1100

R14

router bgp 60
neighbor 2.2.1.1 remote-as 200
neighbor 2.2.1.1 ebgp-multihop 2
neighbor 2.2.1.1 update-source Loopback1
neighbor 10.0.114.11 remote-as 300
neighbor 10.0.124.2 remote-as 200
neighbor 11.11.1.1 remote-as 300
neighbor 11.11.1.1 ebgp-multihop 2
neighbor 11.11.1.1 update-source Loopback1

 Task 9: Make sure all routers ping loopback addresses. (Do possible Configuration)

R3

router bgp 1100


neighbor 10.0.34.4 next-hop-self
neighbor 10.0.37.7 next-hop-self

R5

router bgp 1100


neighbor 10.0.45.4 next-hop-self
neighbor 10.0.56.6 next-hop-self
neighbor 10.0.57.7 next-hop-self

R8

router bgp 300


neighbor 10.0.80.10 next-hop-self
neighbor 10.0.89.9 next-hop-self
LAB 11: BGP
R11

router bgp 300


neighbor 10.0.110.10 next-hop-self
neighbor 10.0.112.12 next-hop-self

R13

router bgp 60
neighbor 10.0.134.14 next-hop-self

R14

router bgp 60
neighbor 10.0.134.13 next-hop-self

(Note: verify using ping command with source address like:


R3# ping 1.1.1.1 source l3)

 Task 10: On R2, Configure R14 as a best path for Network 3.3.3.0 and R8 as a best path for
Network 3.3.4.0.

R2

access-list 10 permit 3.3.3.0 0.0.0.255


access-list 20 permit 3.3.4.0 0.0.0.255

route-map Local permit 10


match ip address 10
set local-preference 500
exit

route-map Local permit 20


exit

route-map R8 permit 21
match ip address 20
set local-preference 600
exit

route-map R8 permit 30
exit
LAB 11: BGP
router bgp 200
neighbor 14.14.1.1 route-map Local in
neighbor 8.8.1.1 route-map R8 in

 Task 11: Configure weight as 1440 on R8 to make R7 as a best path for BGP routes.

R8

router bgp 300


neighbor 10.0.78.7 weight 1440

 Task 12: Make sure R7 Receives metric 10000 for Network 2.2.1.0 from R3.

R7

access-list 10 permit 2.2.1.0 0.0.0.255

route-map Filter permit 10


match ip address 10
set metric 10000
exit

route-map Filter permit 20


exit

router bgp 1100


neighbor 10.0.37.3 route-map Filter in
Lab 29: EIGRP-II
Task

Figure 1 Topology

1. Configure IP address as per given in topology.


2. Configure Eigrp as per given in topology and also introduce all the loopback in Eigrp.
3. Change Hello and Hold timer in Eigrp 200 to 2 and 6 respectively.
4. Use MD5 authentication between R5 and R4. Use keystring as N3TW@x.
5. Use Metric weight in eigrp 100 as 0 1 0 1 1 0.
6. Make sure all routers receive all the routes.
7. Manual Route summarization on R5 and R7 for loopbacks.
8. Make sure that R5 receive R7 loopback route from Se1/0.
Lab 29: EIGRP-II
Solution
Task 2: Configure Eigrp as per given in topology and also introduce all the loopback in Eigrp.

R1

router eigrp 100


network 10.0.0.0 0.0.0.255
no auto-summary
exit

R2

router eigrp 100


network 24.0.0.0 0.0.0.255
network 32.0.17.0 0.0.0.255
no auto-summary
exit

router eigrp 200


network 78.54.10.0 0.0.0.255
no auto-summary
exit

R3

router eigrp 100


network 10.0.0.0 0.0.0.255
network 32.0.17.0 0.0.0.255
network 151.45.8.0 0.0.0.255
no auto-summary
exit

R4

router eigrp 100


network 24.0.0.0 0.0.0.255
network 45.0.151.0 0.0.0.255
no auto-summary
exit
Lab 29: EIGRP-II
R5

router eigrp 100


network 5.5.1.0 0.0.0.255
network 5.5.2.0 0.0.0.255
network 5.5.3.0 0.0.0.255
network 5.5.4.0 0.0.0.255
network 10.0.0.0 0.0.0.255
network 45.0.151.0 0.0.0.255
no auto-summary
exit

R6

router eigrp 100


network 151.45.8.0 0.0.0.255
no auto-summary
exit

router eigrp 200


network 192.168.5.0
no auto-summary
exit

R7

router eigrp 200


network 7.7.1.0 0.0.0.255
network 7.7.2.0 0.0.0.255
network 7.7.3.0 0.0.0.255
network 7.7.4.0 0.0.0.255
network 78.54.10.0 0.0.0.255
network 192.168.5.0
no auto-summary
exit

Task 3: Change Hello and Hold timer in Eigrp 200 to 2 and 6 respectively.

R2

interface FastEthernet0/1
ip hello-interval eigrp 200 2
ip hold-time eigrp 200 6
Lab 29: EIGRP-II

exit

R6

interface FastEthernet0/1
ip hello-interval eigrp 200 2
ip hold-time eigrp 200 6
exit

R7

interface FastEthernet0/0
ip hello-interval eigrp 200 2
ip hold-time eigrp 200 6
exit

interface FastEthernet0/1
ip hello-interval eigrp 200 2
ip hold-time eigrp 200 6
exit

Task 4: Use MD5 authentication between R5 and R4. Use keystring as N3TW@x.

R4

key chain R4andR5


key 1
key-string N3TW@x
exit
exit

interface Serial1/0
ip authentication mode eigrp 100 md5
ip authentication key-chain eigrp 100 R4andR5
exit

R5

key chain R4andR5


key 1
key-string N3TW@x
exit
exit
Lab 29: EIGRP-II
interface Serial1/0
ip authentication mode eigrp 100 md5
ip authentication key-chain eigrp 100 R4andR5
exit

Task 5: Use Metric weight in eigrp 100 as 0 1 0 1 1 0.

On Router R1 to R6

router eigrp 100


metric weights 0 1 0 1 1 0
no auto-summary
exit

Task 6: Make sure all routers receive all the routes.

R2

router eigrp 100


redistribute eigrp 200 metric 128000 100 255 255 1500
exit

router eigrp 200


redistribute eigrp 100 metric 128000 100 255 255 1500
exit

R6

router eigrp 100


redistribute eigrp 200 metric 1 1 1 1 1
exit

router eigrp 200


redistribute eigrp 100 metric 1 1 1 1 1
exit

Task 7: Manual Route summarization on R5 and R7 for loopbacks.

R5

interface Serial1/0
ip summary-address eigrp 100 5.5.0.0 255.255.248.0
exit
Lab 29: EIGRP-II
R7

interface FastEthernet0/0
ip summary-address eigrp 200 7.7.0.0 255.255.248.0
exit

Task 8: Make sure that R5 receive R7 loopback route from Se1/0.

R5

access-list 1 permit 7.7.0.0 0.0.3.255

router eigrp 100


offset-list 1 in 2221056 FastEthernet0/0
exit
Lab 26: BGP-II
Task

Figure 1 Topology

1. Configure IP Address as per given in topology. Make sure all routers have four loopbacks (e.g.
on R1 L1 1.1.1.1/24 L2 1.1.2.1/24.)
2. Configure IBGP as per given in topology and advertise first two loopbacks in IBGP Domain.
3. Configure HSRP on R5 and R6. Use Virtual IP as 192.168.20.254 and MD5 authentication key
as "N3tW@x!ab".
4. Configure Server as per given in topology. Make sure Routers who participate in BGP 100 will
ping netwaxlab and blog.eincop.com
5. Configure BGP as per given in topology. Also Configure Sub BGP in BGP 1000.
6. Make sure Loopback which is participating in BGP domains will communicate each other’s.
7. Make sure OSPF Area 0 authenticate with MD5 using "N3tW@x!ab" key.
8. Configure BGP authentication between R4 and R6 using "N3tW@x!ab" key.
9. On R9, R14 is the best path for networks 8.8.1.0, 8.8.2.0, 8.8.3.0 and 8.8.4.0.
10. R11 receives all the routes from R8. Expect their own BGP domain.
Lab 26: BGP-II
Solution
 Task 2: Configure IBGP as per given in topology and advertise first two loopbacks in IBGP
Domain.

R1

router ospf 1
router-id 1.1.1.1
network 1.1.1.0 0.0.0.255 area 0
network 1.1.2.0 0.0.0.255 area 0
network 10.0.13.0 0.0.0.255 area 0
network 10.0.14.0 0.0.0.255 area 0
exit

R2

router ospf 1
router-id 2.2.2.2
network 2.2.1.0 0.0.0.255 area 0
network 2.2.2.0 0.0.0.255 area 0
network 10.0.23.0 0.0.0.255 area 0
network 10.0.24.0 0.0.0.255 area 0
exit

R3

router ospf 1
router-id 3.3.3.3
network 3.3.1.0 0.0.0.255 area 0
network 3.3.2.0 0.0.0.255 area 0
network 10.0.13.0 0.0.0.255 area 0
network 10.0.23.0 0.0.0.255 area 0
exit

R4

router ospf 1
router-id 4.4.4.4
network 4.4.1.0 0.0.0.255 area 0
network 4.4.2.0 0.0.0.255 area 0
network 10.0.14.0 0.0.0.255 area 0
network 10.0.24.0 0.0.0.255 area 0
Lab 26: BGP-II
network 20.0.45.0 0.0.0.255 area 1
network 20.0.46.0 0.0.0.255 area 1
exit

R5

router ospf 1
router-id 5.5.5.5
network 5.5.1.0 0.0.0.255 area 1
network 5.5.2.0 0.0.0.255 area 1
network 20.0.45.0 0.0.0.255 area 1
network 192.168.20.0 0.0.0.255 area 1
exit

R6

router ospf 1
router-id 6.6.6.6
network 6.6.1.0 0.0.0.255 area 1
network 6.6.2.0 0.0.0.255 area 1
network 20.0.46.0 0.0.0.255 area 1
network 192.168.20.0 0.0.0.255 area 1
exit

R11

router eigrp 100


network 10.0.112.0 0.0.0.255
network 10.0.113.0 0.0.0.255
network 11.11.1.0 0.0.0.255
network 11.11.2.0 0.0.0.255
no auto-summary

R12

router eigrp 100


network 10.0.112.0 0.0.0.255
network 10.0.114.0 0.0.0.255
network 12.12.1.0 0.0.0.255
network 12.12.2.0 0.0.0.255
no auto-summary
Lab 26: BGP-II
R13

router eigrp 100


network 10.0.113.0 0.0.0.255
network 13.13.1.0 0.0.0.255
network 13.13.2.0 0.0.0.255
no auto-summary

R14

router eigrp 100


network 10.0.114.0 0.0.0.255
network 14.14.1.0 0.0.0.255
network 14.14.2.0 0.0.0.255
no auto-summary

 Task 3: Configure HSRP on R5 and R6. Use Virtual IP as 192.168.20.254 and MD5 authentication
key as "N3tW@x!ab".

R5

int f0/0
standby 1 ip 192.168.20.254
standby 1 priority 101
standby 1 preempt
standby 1 authentication md5 key-string N3tW@x!ab
exit

R6

int f1/0
standby 1 ip 192.168.20.254
standby 1 priority 99
standby 1 preempt
standby 1 authentication md5 key-string N3tW@x!ab
exit
Lab 26: BGP-II
 Task 4: Configure Server as per given in topology. Make sure Routers who participate in BGP
100 will ping netwaxlab and blog.eincop.com

R6

int l1
ip add 99.99.99.100 255.255.255.0

int l2
ip add 99.99.98.11 255.255.255.0

R4, R5 and R6

ip domain lookup
ip name-server 192.168.20.200

 Task 5: Configure BGP as per given in topology. Also Configure Sub BGP in BGP 1000. (Task 6
will also complete in this task).

R1

router bgp 100


no synchronization
bgp log-neighbor-changes
network 1.1.3.0 mask 255.255.255.0
network 1.1.4.0 mask 255.255.255.0
neighbor 10.0.13.3 remote-as 100
neighbor 10.0.14.4 remote-as 100
neighbor 10.0.14.4 route-reflector-client
neighbor 10.0.14.4 next-hop-self
no auto-summary

R2

router bgp 100


no synchronization
bgp log-neighbor-changes
network 2.2.3.0 mask 255.255.255.0
network 2.2.4.0 mask 255.255.255.0
neighbor 10.0.23.3 remote-as 100
neighbor 10.0.24.4 remote-as 100
neighbor 10.0.24.4 route-reflector-client
neighbor 10.0.24.4 next-hop-self
no auto-summary
Lab 26: BGP-II
R3

router bgp 100


no synchronization
bgp log-neighbor-changes
network 3.3.3.0 mask 255.255.255.0
network 3.3.4.0 mask 255.255.255.0
neighbor 7.7.1.1 remote-as 200
neighbor 7.7.1.1 ebgp-multihop 2
neighbor 7.7.1.1 update-source Loopback1
neighbor 8.8.1.1 remote-as 1422
neighbor 8.8.1.1 ebgp-multihop 2
neighbor 8.8.1.1 update-source Loopback1
neighbor 10.0.13.1 remote-as 100
neighbor 10.0.13.1 next-hop-self
neighbor 10.0.23.2 remote-as 100
neighbor 10.0.23.2 route-reflector-client
neighbor 10.0.23.2 next-hop-self
neighbor 10.0.37.7 remote-as 200
neighbor 10.0.38.8 remote-as 1422
no auto-summary

R4

router bgp 100


no synchronization
bgp log-neighbor-changes
network 4.4.3.0 mask 255.255.255.0
network 4.4.4.0 mask 255.255.255.0
neighbor 10.0.14.1 remote-as 100
neighbor 10.0.14.1 route-reflector-client
neighbor 10.0.14.1 next-hop-self
neighbor 10.0.24.2 remote-as 100
neighbor 10.0.24.2 route-reflector-client
neighbor 10.0.24.2 next-hop-self
neighbor 20.0.45.5 remote-as 100
neighbor 20.0.45.5 route-reflector-client
neighbor 20.0.45.5 next-hop-self
neighbor 20.0.46.6 remote-as 100
neighbor 20.0.46.6 route-reflector-client
neighbor 20.0.46.6 next-hop-self
Lab 26: BGP-II
no auto-summary

R5

router bgp 100


no synchronization
bgp log-neighbor-changes
network 5.5.3.0 mask 255.255.255.0
network 5.5.4.0 mask 255.255.255.0
network 192.168.20.0
neighbor 20.0.45.4 remote-as 100
no auto-summary

R6

router bgp 100


no synchronization
bgp log-neighbor-changes
network 6.6.3.0 mask 255.255.255.0
network 6.6.4.0 mask 255.255.255.0
network 99.99.98.0 mask 255.255.255.0
network 99.99.99.0 mask 255.255.255.0
network 192.168.20.0
neighbor 9.9.1.1 remote-as 1330
neighbor 9.9.1.1 ebgp-multihop 2
neighbor 9.9.1.1 update-source Loopback1
neighbor 10.0.69.9 remote-as 1330
neighbor 10.10.1.1 remote-as 400
neighbor 10.10.1.1 ebgp-multihop 2
neighbor 10.10.1.1 update-source Loopback1
neighbor 20.0.46.4 remote-as 100
neighbor 20.0.46.4 next-hop-self
no auto-summary

R7

router bgp 200


no synchronization
bgp log-neighbor-changes
network 7.7.1.0 mask 255.255.255.0
network 7.7.2.0 mask 255.255.255.0
network 7.7.3.0 mask 255.255.255.0
Lab 26: BGP-II
network 7.7.4.0 mask 255.255.255.0
network 10.0.0.0 mask 255.255.255.0
network 20.0.0.0 mask 255.255.255.0
neighbor 3.3.1.1 remote-as 100
neighbor 3.3.1.1 ebgp-multihop 2
neighbor 3.3.1.1 update-source Loopback1
neighbor 10.0.37.3 remote-as 100
no auto-summary

R8

router bgp 1422


no synchronization
bgp log-neighbor-changes
network 8.8.1.0 mask 255.255.255.0
network 8.8.2.0 mask 255.255.255.0
network 8.8.3.0 mask 255.255.255.0
network 8.8.4.0 mask 255.255.255.0
network 192.168.4.0
neighbor 3.3.1.1 remote-as 100
neighbor 3.3.1.1 ebgp-multihop 2
neighbor 3.3.1.1 update-source Loopback1
neighbor 10.0.38.3 remote-as 100
neighbor 10.0.81.11 remote-as 1000
neighbor 11.11.1.1 remote-as 1000
neighbor 11.11.1.1 ebgp-multihop 2
neighbor 11.11.1.1 update-source Loopback1
no auto-summary

R9

router bgp 1330


no synchronization
bgp log-neighbor-changes
network 9.9.1.0 mask 255.255.255.0
network 9.9.2.0 mask 255.255.255.0
network 9.9.3.0 mask 255.255.255.0
network 9.9.4.0 mask 255.255.255.0
neighbor 6.6.1.1 remote-as 100
neighbor 6.6.1.1 ebgp-multihop 2
neighbor 6.6.1.1 update-source Loopback1
neighbor 10.0.69.6 remote-as 100
Lab 26: BGP-II
neighbor 10.0.149.14 remote-as 1000
neighbor 14.14.1.1 remote-as 1000
neighbor 14.14.1.1 ebgp-multihop 2
neighbor 14.14.1.1 update-source Loopback1
no auto-summary

R10

router bgp 400


no synchronization
bgp log-neighbor-changes
network 10.10.1.0 mask 255.255.255.0
network 10.10.2.0 mask 255.255.255.0
network 10.10.3.0 mask 255.255.255.0
network 10.10.4.0 mask 255.255.255.0
neighbor 6.6.1.1 remote-as 100
neighbor 6.6.1.1 ebgp-multihop 2
neighbor 6.6.1.1 update-source Loopback1
neighbor 10.0.60.0 remote-as 100
no auto-summary

R11

router bgp 1000


no synchronization
bgp log-neighbor-changes
bgp confederation identifier 1000
bgp confederation peers 230
network 11.11.3.0 mask 255.255.255.0
network 11.11.4.0 mask 255.255.255.0
neighbor 8.8.1.1 remote-as 1422
neighbor 8.8.1.1 ebgp-multihop 2
neighbor 8.8.1.1 update-source Loopback1
neighbor 10.0.81.8 remote-as 1422
neighbor 10.0.112.12 remote-as 1000
neighbor 10.0.112.12 next-hop-self
neighbor 10.0.113.13 remote-as 230
neighbor 10.0.113.13 next-hop-self
no auto-summary
Lab 26: BGP-II
R12

router bgp 1000


no synchronization
bgp log-neighbor-changes
bgp confederation identifier 1000
bgp confederation peers 260
network 12.12.3.0 mask 255.255.255.0
network 12.12.4.0 mask 255.255.255.0
neighbor 10.0.112.11 remote-as 1000
neighbor 10.0.112.11 next-hop-self
neighbor 10.0.114.14 remote-as 260
neighbor 10.0.114.14 next-hop-self
no auto-summary

R13

router bgp 230


no synchronization
bgp log-neighbor-changes
bgp confederation identifier 1000
bgp confederation peers 1000
network 13.13.3.0 mask 255.255.255.0
network 13.13.4.0 mask 255.255.255.0
neighbor 10.0.113.11 remote-as 1000
no auto-summary

R14

router bgp 260


no synchronization
bgp log-neighbor-changes
bgp confederation identifier 1000
bgp confederation peers 1000
network 14.14.3.0 mask 255.255.255.0
network 14.14.4.0 mask 255.255.255.0
neighbor 9.9.1.1 remote-as 1330
neighbor 9.9.1.1 ebgp-multihop 2
neighbor 9.9.1.1 update-source Loopback1
neighbor 10.0.114.12 remote-as 1000
neighbor 10.0.114.12 next-hop-self
neighbor 10.0.149.9 remote-as 1330
Lab 26: BGP-II
no auto-summary

 Task 6: Already completed in above task.


 Task 7: Make sure OSPF Area 0 authenticate with MD5 using "N3tW@x!ab" key.

R1

router ospf 1
area 0 authentication
exit

int se0/0
ip ospf authentication message-digest
ip ospf message-digest-key 10 md5 N3tW@x!ab
exit

int se0/1
ip ospf authentication message-digest
ip ospf message-digest-key 10 md5 N3tW@x!ab
exit

R2

router ospf 1
area 0 authentication
exit

int se0/0
ip ospf authentication message-digest
ip ospf message-digest-key 10 md5 N3tW@x!ab
exit

int se0/1
ip ospf authentication message-digest
ip ospf message-digest-key 10 md5 N3tW@x!ab
exit

R3

router ospf 1
area 0 authentication
exit
Lab 26: BGP-II
int se0/0
ip ospf authentication message-digest
ip ospf message-digest-key 10 md5 N3tW@x!ab
exit

int se0/1
ip ospf authentication message-digest
ip ospf message-digest-key 10 md5 N3tW@x!ab
exit

R4

router ospf 1
area 0 authentication
exit

int se0/0
ip ospf authentication message-digest
ip ospf message-digest-key 10 md5 N3tW@x!ab
exit

int se0/1
ip ospf authentication message-digest
ip ospf message-digest-key 10 md5 N3tW@x!ab
exit

 Task 8: Configure BGP authentication between R4 and R6 using "N3tW@x!ab" key.

R4

router bgp 100


neighbor 20.0.46.6 password N3tW@x!ab
exit

R6

router bgp 100


neighbor 20.0.46.4 password N3tW@x!ab
exit
Lab 26: BGP-II
 Task 9: On R9, R14 is the best path for networks 8.8.1.0, 8.8.2.0, 8.8.3.0 and 8.8.4.0.

R9

access-list 10 permit 8.8.1.0 0.0.0.255


access-list 10 permit 8.8.2.0 0.0.0.255
access-list 10 permit 8.8.3.0 0.0.0.255
access-list 10 permit 8.8.4.0 0.0.0.255

route-map R8 permit 10
match ip address 10
set local-preference 500
exit

route-map R8 permit 20
exit

router bgp 1330


neighbor 10.0.149.14 route-map R8 in
exit

 Task 10: R11 receives all the routes from R8. Expect their own BGP domain.

R11

access-list 10 permit 9.9.1.0 0.0.0.255


access-list 10 permit 9.9.2.0 0.0.0.255
access-list 10 permit 9.9.3.0 0.0.0.255
access-list 10 permit 9.9.4.0 0.0.0.255

route-map R9 permit 10
match ip address 10
set weight 1500
exit

route-map R9 permit 20
exit

router bgp 1000


neighbor 10.0.81.8 route-map R9 in
exit
Lab 24: IPv6
Task

Figure 1 Topology

1. Configure IP address as per given in topology.


2. Configure Routing as per given in topology.
3. Enable tunneling between IPV6 and IPV4.
4. Configure EIGRP 111 over R4 and R5 tunnel.
5. Configure Rip over R2 and R6 tunnel.
6. Make sure all routers receive all routes.
Lab 24: IPv6
Solution
 Task 2: Configure Routing as per given in topology.

On all Routers

ipv6 unicast-routing

R1

ipv6 router eigrp 100


router-id 1.1.1.1
no shut
exit

int se0/0
ipv6 eigrp 100
exit

int se0/1
ipv6 eigrp 100
exit

R2

ipv6 router eigrp 100


router-id 2.2.2.2
no shut
exit

int se0/0
ipv6 eigrp 100
exit

int se0/1
ipv6 eigrp 100
exit

router rip
ver 2
network 21.115.68.0
no auto-summary
Lab 24: IPv6
R3

ipv6 router eigrp 100


router-id 3.3.3.3
no shut
exit

int se0/0
ipv6 eigrp 100
exit

int se0/1
ipv6 eigrp 100
exit

R4

ipv6 router eigrp 100


router-id 4.4.4.4
no shut
exit

int se0/0
ipv6 eigrp 100
exit

int se0/1
ipv6 eigrp 100
exit

R5

ipv6 router ospf 1


router-id 5.5.5.5
no shut
exit

int se0/0
ipv6 ospf 1 area 0
exit
Lab 24: IPv6
int se0/1
ipv6 ospf 1 area 0
exit

R6

ipv6 router ospf 1


router-id 6.6.6.6
no shut
exit

int se0/0
ipv6 ospf 1 area 0
exit

int se0/1
ipv6 ospf 1 area 0
exit

router rip
ver 2
network 21.115.68.0
network 84.224.30.0
no auto-summary
exit

R7

ipv6 router ospf 1


router-id 7.7.7.7
no shut
exit

int se0/0
ipv6 ospf 1 area 0
exit

int se0/1
ipv6 ospf 1 area 0
exit
Lab 24: IPv6
int f0/0
ipv6 ospf 1 area 1
exit

R8

router rip
ver 2
network 21.115.68.0
network 84.224.30.0
no auto-summary
exit

R9

ipv6 router ospf 1


router-id 9.9.9.9
no shut
exit

int f0/0
ipv6 ospf 1 area 1
exit

 Task 3: Enable tunneling between IPV6 and IPV4.

R2

int t0
no ip address
ipv6 address fec0::11/124
tunnel source f0/0
tunnel destination 84.224.30.6
tunnel mode ipv6ip
exit

R6

int t0
no ip address
ipv6 address fec0::12/124
tunnel source f0/0
tunnel destination 21.115.68.2
tunnel mode ipv6ip
Lab 24: IPv6
R4

int t0
no ip address
ipv6 address fec0::1/124
tunnel source f0/0
tunnel destination 114.25.33.4
tunnel mode ipv6ip
exit

R5

int t0
no ip address
ipv6 address fec0::2/124
tunnel source f0/0
tunnel destination 114.25.33.5
tunnel mode ipv6ip
exit

 Task 4: Configure EIGRP 111 over R4 and R5 tunnel.

R4

ipv6 router eigrp 111


router-id 4.4.4.4
no shut
exit

int t0
ipv6 eigrp 111
exit

R5

ipv6 router eigrp 111


router-id 5.5.5.5
no shut
exit

int t0
ipv6 eigrp 111
exit
Lab 24: IPv6
 Task 5: Configure Rip over R2 and R6 tunnel.

R2

ipv6 router rip netwaxlab


exit

int t0
ipv6 rip netwaxlab enable
exit

R6

ipv6 router rip netwaxlab


exit

int t0
ipv6 rip netwaxlab enable
exit

 Task 6: Make sure all routers receive all routes.

R4

ipv6 router eigrp 100


redistribute eigrp 111 metric 1 1 1 1 1
exit

ipv6 router eigrp 111


redistribute eigrp 100 metric 1 1 1 1 1
exit

R5

ipv6 router eigrp 111


redistribute ospf 1 metric 1 1 1 1 1
exit

ipv6 router ospf 1


redistribute eigrp 111 metric 1
exit
Lab 24: IPv6
R2

ipv6 router eigrp 100


redistribute rip netwaxlab metric 1 1 1 1 1
exit

ipv6 router rip netwaxlab


redistribute eigrp 100 metric 1
exit

R6

ipv6 router ospf 1


redistribute rip netwaxlab metric 1
exit

ipv6 router rip netwaxlab


redistribute ospf 1 metric 1
exit
Lab 31: Access List-II
Task

Figure 1 Topology

1. Configure IP Address as per given in topology.


2. Configure Eigrp 100 over this topology. Make sure all Routers received all the routes.
3. Configure PAT on R1 and R2
4. Configure Telnet on R1 and SSH on R4.
5. Make sure R6 Access Telnet and R2 access SSH.
6. R3 not received 10.0.45.0 Route in routing table.
7. On R6, Make R5 as a best path for 10.0.13.0.
8. R5 and R4 not able to ping 100.100.0.0 network.
9. Make sure R3 only access "show ip int bri" command on R1 using Telnet.
10. R4 not able to ping R1 interfaces. But loopback address can be ping.
Lab 31: Access List-II
Solution
Task 2: Configure Eigrp 100 over this topology. Make sure all Routers received all the routes.

R1

router eigrp 100


redistribute static
network 10.0.13.0 0.0.0.255
no auto-summary
exit

R2

router eigrp 100


redistribute static
network 10.0.23.0 0.0.0.255
network 10.0.26.0 0.0.0.255
no auto-summary
exit

R3

router eigrp 100


network 10.0.13.0 0.0.0.255
network 10.0.23.0 0.0.0.255
network 10.0.34.0 0.0.0.255
network 10.0.35.0 0.0.0.255
no auto-summary
exit

R4

router eigrp 100


network 10.0.34.0 0.0.0.255
network 10.0.45.0 0.0.0.255
network 200.200.201.0
network 200.200.202.0
network 200.200.203.0
network 200.200.204.0
no auto-summary
exit
Lab 31: Access List-II
R5

router eigrp 100


network 10.0.35.0 0.0.0.255
network 10.0.45.0 0.0.0.255
network 10.0.56.0 0.0.0.255
no auto-summary
exit

R6

router eigrp 100


network 10.0.26.0 0.0.0.255
network 10.0.56.0 0.0.0.255
network 192.168.1.0
network 192.168.2.0
no auto-summary
exit

Task 3: Configure PAT on R1 and R3.

R1

ip access-list extended NAT


permit ip 10.0.13.0 0.0.0.255 any
permit ip 10.0.23.0 0.0.0.255 any
permit ip 10.0.34.0 0.0.0.255 any
permit ip 10.0.35.0 0.0.0.255 any
permit ip 10.0.45.0 0.0.0.255 any
permit ip 10.0.56.0 0.0.0.255 any
permit ip 10.0.26.0 0.0.0.255 any
permit ip 192.168.1.0 0.0.0.255 any
permit ip 192.168.2.0 0.0.0.255 any
permit ip 200.200.200.0 0.0.0.255 any
permit ip 200.200.201.0 0.0.0.255 any
permit ip 200.200.202.0 0.0.0.255 any
permit ip 200.200.203.0 0.0.0.255 any
permit ip 200.200.204.0 0.0.0.255 any
exit

ip nat inside source list NAT interface FastEthernet0/0 overload


Lab 31: Access List-II
R2

ip access-list extended NAT


permit ip 10.0.13.0 0.0.0.255 any
permit ip 10.0.23.0 0.0.0.255 any
permit ip 10.0.34.0 0.0.0.255 any
permit ip 10.0.35.0 0.0.0.255 any
permit ip 10.0.45.0 0.0.0.255 any
permit ip 10.0.56.0 0.0.0.255 any
permit ip 10.0.26.0 0.0.0.255 any
permit ip 192.168.1.0 0.0.0.255 any
permit ip 192.168.2.0 0.0.0.255 any
permit ip 200.200.200.0 0.0.0.255 any
permit ip 200.200.201.0 0.0.0.255 any
permit ip 200.200.202.0 0.0.0.255 any
permit ip 200.200.203.0 0.0.0.255 any
permit ip 200.200.204.0 0.0.0.255 any
exit

ip nat inside source list NAT interface FastEthernet0/0 overload

Task 4: Configure Telnet on R1 and SSH on R4.

R1

username cisco password 0 netwax

line vty 0 4
login local
exit

enable secret cisco

R4

username cisco password 0 netwax

enable secret cisco

ip domain name www.netwaxlab.com

crypto key generate rsa modulus 1024

line vty 0 4
transport input ssh
login local
Lab 31: Access List-II
Task 5: Make sure R6 Access Telnet and R2 access SSH.

R1

access-list 10 permit 10.0.26.6


access-list 10 permit 10.0.56.6
access-list 10 deny any

line vty 0 4
access-class 10 in
exit

R4

access-list 10 permit 10.0.26.2


access-list 10 permit 10.0.23.2
access-list 10 deny any

line vty 0 4
access-class 10 in
exit

Task 6: R3 not received 10.0.45.0 Route in routing table.

R3

access-list 10 deny 10.0.45.0 0.0.0.255


access-list 10 permit any

router eigrp 100


distribute-list 10 in
exit

router eigrp 100


distribute-list 10 in
exit

Task 7: On R6, Make R5 as a best path for 10.0.13.0.

R6

access-list 10 permit 10.0.13.0 0.0.0.255

router eigrp 100


offset-list 10 in 2195456 Serial1/1
exit
Lab 31: Access List-II
Task 8: R5 and R4 not able to ping 100.100.0.0 network.

R3

ip access-list extended R4
deny ip host 10.0.34.4 100.100.0.0 0.0.255.255
deny ip host 10.0.45.4 100.100.0.0 0.0.255.255
deny ip host 10.0.35.5 100.100.0.0 0.0.255.255
deny ip host 10.0.45.5 100.100.0.0 0.0.255.255
deny ip host 10.0.56.5 100.100.0.0 0.0.255.255
permit ip any any
exit

int se1/1
ip access-group R4 in
exit

int se1/0
ip access-group R4 in
exit

Task 9: Make sure R3 only access "show ip int bri" command on R1 using Telnet.

R1

Username Cisco view R3 password Netwax


aaa new-model
exit

enable view

config t
parser view R3
secret netwax@
commands exec include show ip int bri
exit

access-list 11 permit 10.0.13.3


access-list 11 deny any

int f0/1
ip access-group 11 in
exit
Lab 31: Access List-II
Verify:

R3

telnet 10.0.13.1
Username: Cisco
Password: Netwax

R1>en
Password: netwax@

Task 10: R4 not able to ping R1 interfaces. But loopback address can be ping.

R3

access-list 101 deny icmp host 10.0.34.4 host 10.0.13.1


access-list 101 deny icmp host 10.0.45.4 host 10.0.13.1
access-list 101 permit icmp any any
access-list 101 permit eigrp any any

int se1/1
ip access-group 101 in
exit
Lab 31: Access List-II
Task

Figure 1 Topology

1. Configure IP Address as per given in topology.


2. Configure Eigrp 100 over this topology. Make sure all Routers received all the routes.
3. Configure PAT on R1 and R2
4. Configure Telnet on R1 and SSH on R4.
5. Make sure R6 Access Telnet and R2 access SSH.
6. R3 not received 10.0.45.0 Route in routing table.
7. On R6, Make R5 as a best path for 10.0.13.0.
8. R5 and R4 not able to ping 100.100.0.0 network.
9. Make sure R3 only access "show ip int bri" command on R1 using Telnet.
10. R4 not able to ping R1 interfaces. But loopback address can be ping.
Lab 31: Access List-II
Solution
Task 2: Configure Eigrp 100 over this topology. Make sure all Routers received all the routes.

R1

router eigrp 100


redistribute static
network 10.0.13.0 0.0.0.255
no auto-summary
exit

R2

router eigrp 100


redistribute static
network 10.0.23.0 0.0.0.255
network 10.0.26.0 0.0.0.255
no auto-summary
exit

R3

router eigrp 100


network 10.0.13.0 0.0.0.255
network 10.0.23.0 0.0.0.255
network 10.0.34.0 0.0.0.255
network 10.0.35.0 0.0.0.255
no auto-summary
exit

R4

router eigrp 100


network 10.0.34.0 0.0.0.255
network 10.0.45.0 0.0.0.255
network 200.200.201.0
network 200.200.202.0
network 200.200.203.0
network 200.200.204.0
no auto-summary
exit
Lab 31: Access List-II
R5

router eigrp 100


network 10.0.35.0 0.0.0.255
network 10.0.45.0 0.0.0.255
network 10.0.56.0 0.0.0.255
no auto-summary
exit

R6

router eigrp 100


network 10.0.26.0 0.0.0.255
network 10.0.56.0 0.0.0.255
network 192.168.1.0
network 192.168.2.0
no auto-summary
exit

Task 3: Configure PAT on R1 and R3.

R1

ip access-list extended NAT


permit ip 10.0.13.0 0.0.0.255 any
permit ip 10.0.23.0 0.0.0.255 any
permit ip 10.0.34.0 0.0.0.255 any
permit ip 10.0.35.0 0.0.0.255 any
permit ip 10.0.45.0 0.0.0.255 any
permit ip 10.0.56.0 0.0.0.255 any
permit ip 10.0.26.0 0.0.0.255 any
permit ip 192.168.1.0 0.0.0.255 any
permit ip 192.168.2.0 0.0.0.255 any
permit ip 200.200.200.0 0.0.0.255 any
permit ip 200.200.201.0 0.0.0.255 any
permit ip 200.200.202.0 0.0.0.255 any
permit ip 200.200.203.0 0.0.0.255 any
permit ip 200.200.204.0 0.0.0.255 any
exit

ip nat inside source list NAT interface FastEthernet0/0 overload


Lab 31: Access List-II
R2

ip access-list extended NAT


permit ip 10.0.13.0 0.0.0.255 any
permit ip 10.0.23.0 0.0.0.255 any
permit ip 10.0.34.0 0.0.0.255 any
permit ip 10.0.35.0 0.0.0.255 any
permit ip 10.0.45.0 0.0.0.255 any
permit ip 10.0.56.0 0.0.0.255 any
permit ip 10.0.26.0 0.0.0.255 any
permit ip 192.168.1.0 0.0.0.255 any
permit ip 192.168.2.0 0.0.0.255 any
permit ip 200.200.200.0 0.0.0.255 any
permit ip 200.200.201.0 0.0.0.255 any
permit ip 200.200.202.0 0.0.0.255 any
permit ip 200.200.203.0 0.0.0.255 any
permit ip 200.200.204.0 0.0.0.255 any
exit

ip nat inside source list NAT interface FastEthernet0/0 overload

Task 4: Configure Telnet on R1 and SSH on R4.

R1

username cisco password 0 netwax

line vty 0 4
login local
exit

enable secret cisco

R4

username cisco password 0 netwax

enable secret cisco

ip domain name www.netwaxlab.com

crypto key generate rsa modulus 1024

line vty 0 4
transport input ssh
login local
Lab 31: Access List-II
Task 5: Make sure R6 Access Telnet and R2 access SSH.

R1

access-list 10 permit 10.0.26.6


access-list 10 permit 10.0.56.6
access-list 10 deny any

line vty 0 4
access-class 10 in
exit

R4

access-list 10 permit 10.0.26.2


access-list 10 permit 10.0.23.2
access-list 10 deny any

line vty 0 4
access-class 10 in
exit

Task 6: R3 not received 10.0.45.0 Route in routing table.

R3

access-list 10 deny 10.0.45.0 0.0.0.255


access-list 10 permit any

router eigrp 100


distribute-list 10 in
exit

router eigrp 100


distribute-list 10 in
exit

Task 7: On R6, Make R5 as a best path for 10.0.13.0.

R6

access-list 10 permit 10.0.13.0 0.0.0.255

router eigrp 100


offset-list 10 in 2195456 Serial1/1
exit
Lab 31: Access List-II
Task 8: R5 and R4 not able to ping 100.100.0.0 network.

R3

ip access-list extended R4
deny ip host 10.0.34.4 100.100.0.0 0.0.255.255
deny ip host 10.0.45.4 100.100.0.0 0.0.255.255
deny ip host 10.0.35.5 100.100.0.0 0.0.255.255
deny ip host 10.0.45.5 100.100.0.0 0.0.255.255
deny ip host 10.0.56.5 100.100.0.0 0.0.255.255
permit ip any any
exit

int se1/1
ip access-group R4 in
exit

int se1/0
ip access-group R4 in
exit

Task 9: Make sure R3 only access "show ip int bri" command on R1 using Telnet.

R1

Username Cisco view R3 password Netwax


aaa new-model
exit

enable view

config t
parser view R3
secret netwax@
commands exec include show ip int bri
exit

access-list 11 permit 10.0.13.3


access-list 11 deny any

int f0/1
ip access-group 11 in
exit
Lab 31: Access List-II
Verify:

R3

telnet 10.0.13.1
Username: Cisco
Password: Netwax

R1>en
Password: netwax@

Task 10: R4 not able to ping R1 interfaces. But loopback address can be ping.

R3

access-list 101 deny icmp host 10.0.34.4 host 10.0.13.1


access-list 101 deny icmp host 10.0.45.4 host 10.0.13.1
access-list 101 permit icmp any any
access-list 101 permit eigrp any any

int se1/1
ip access-group 101 in
exit
Lab 23: IPv6
Task

Figure 1 Topology

1. Configure IP Address as per given in topology.


2. Configure R2, R3 and R4 link local address eg. fe80::2 for R2.
3. Configure Frame-Relay over IPV6.
4. R7 receive ip address from R3. Do possible configuration.
5. Configure Routing as per given in topology.
Lab 23: IPv6

 Task 2: Configure R2, R3 and R4 link local address eg. fe80::2 for R2.

R2

interface serial 0/0


ipv6 address fe80::2 link-local
exit

R3

interface serial 0/0


ipv6 address fe80::3 link-local
exit

R4

interface serial 0/0


ipv6 address fe80::4 link-local
exit

 Task 3: Configure Frame-Relay over IPV6.

FR DLCI Assign

1 203 2 302
1 204 3 402
2 304 3 403

R2

interface Serial0/0
encapsulation frame-relay
ipv6 address 2001:23::2/64
frame-relay map ipv6 2001:23::3 203 broadcast
frame-relay map ipv6 2001:23::4 204 broadcast
frame-relay map ipv6 fe80::3 203
frame-relay map ipv6 fe80::4 204

R3

interface Serial0/0
encapsulation frame-relay
ipv6 address 2001:23::3/64
frame-relay map ipv6 2001:23::2 302 broadcast
frame-relay map ipv6 2001:23::4 304 broadcast
Lab 23: IPv6
frame-relay map ipv6 fe80::2 302
frame-relay map ipv6 fe80::4 304

R4

interface Serial0/0
encapsulation frame-relay
ipv6 address 2001:23::4/64
frame-relay map ipv6 2001:23::3 403 broadcast
frame-relay map ipv6 2001:23::2 402 broadcast
frame-relay map ipv6 fe80::3 403
frame-relay map ipv6 fe80::2 402

 Task 4: R7 receive ip address from R3. Do possible configuration.

R3

int f0/0
ipv6 address 2001:5::/64 eui-64
ipv6 nd prefix 2001:5::/64
exit

R7

int f0/0
ipv6 address autoconfig
exit

 Task 5: Configure Routing as per given in topology.

on all Routers

ipv6 unicast-routing

R1

ipv6 router rip Netwaxlab


exit

int f0/0
ipv6 rip Netwaxlab enable
exit
Lab 23: IPv6
R2

ipv6 router rip Netwaxlab


exit

int f0/0
ipv6 rip Netwaxlab enable
exit

ipv6 router ospf 1


router-id 2.2.2.2
exit

int se0/0
ipv6 ospf 1 area 0
ipv6 ospf neighbor fe80::3
ipv6 ospf neighbor fe80::4
exit

R3

ipv6 router ospf 1


router-id 3.3.3.3
exit

int se0/0
ipv6 ospf 1 area 0
ipv6 ospf neighbor fe80::2
ipv6 ospf neighbor fe80::4
exit

int f0/1
ipv6 ospf 1 area 1
exit

R4

ipv6 router ospf 1


router-id 4.4.4.4
exit
Lab 23: IPv6
int se0/0
ipv6 ospf 1 area 0
ipv6 ospf neighbor fe80::2
ipv6 ospf neighbor fe80::3
exit

int f0/0
ipv6 ospf 1 area 1
exit

R6

ipv6 router ospf 1


router-id 6.6.6.6
exit

int f0/1
ipv6 ospf 1 area 1
exit

int f0/0
ipv6 ospf 1 area 1
exit

R8

ipv6 router ospf 1


router-id 8.8.8.8
exit

int f0/1
ipv6 ospf 1 area 1
exit

int f0/0
ipv6 ospf 1 area 1
exit
Lab 22: Role Based CLI
Task

Figure 1 Topology

1. Configure IP Address as per given in topology.


2. Configure RIP and EIGRP as per given in topology.
3. Make Sure PAT is enable on R2 and R3 for inside networks.
4. Configure Site-2-Site VPN between R2 and R3. PC5 Communicate R12, R13 and R14 from VPN
tunnel and Pc4 to R11 in VPN tunnel. Make sure Use isakmp key is netwaxlab.
5. Configure SSH on R14 and Telnet R11, R12 and R13. Use Enable secret password as eincop and
Local username as cisco and password as netwaxlab.
6. PC5 access R13 with full permission. But PC5 only access all show command on R14.
7. PC5 access R12 some commands like sh ip int brief, sh ip protocol, ping, sh run and sh ip
interface.
8. PC4 only access show history command on R11.
Lab 22: Role Based CLI
Solution
 Task 2: Configure RIP and EIGRP as per given in topology.

R2

router rip
version 2
network 10.0.0.0
default-information originate
no auto-summary
exit

R3

router eigrp 100


redistribute static metric 1 1 1 1 1
network 10.0.30.0 0.0.0.255
network 10.0.31.0 0.0.0.255
no auto-summary
exit

R4

router rip
version 2
network 10.0.0.0
network 192.168.1.0
network 192.168.2.0
no auto-summary
exit

R5

router rip
version 2
network 10.0.0.0
network 192.168.3.0
network 192.168.4.0
no auto-summary
exit
Lab 22: Role Based CLI
R10

router eigrp 100


network 10.0.30.0 0.0.0.255
network 192.168.5.0
no auto-summary
exit

R11

router eigrp 100


network 10.0.31.0 0.0.0.255
no auto-summary
exit

R12

router rip
version 2
network 192.168.1.0
no auto-summary

R13

router rip
version 2
network 192.168.2.0
no auto-summary

R14

router rip
version 2
network 192.168.3.0
no auto-summary

 Task 3: Make Sure PAT is enable on R2 and R3 for inside networks.

R2

ip access-list extended NAT


permit ip 10.0.24.0 0.0.0.255 any
permit ip 10.0.25.0 0.0.0.255 any
permit ip 192.168.1.0 0.0.0.255 any
permit ip 192.168.2.0 0.0.0.255 any
Lab 22: Role Based CLI
permit ip 192.168.3.0 0.0.0.255 any
permit ip 192.168.4.0 0.0.0.255 any
exit

int f0/0
ip nat outside
exit

int se0/0
ip nat inside
exit

int se0/1
ip nat inside
exit

ip nat inside source list NAT interface FastEthernet0/0 overload

R3

ip access-list extended NAT


permit ip 10.0.31.0 0.0.0.255 any
permit ip 10.0.30.0 0.0.0.255 any
permit ip 192.168.5.0 0.0.0.255 any
exit

int f0/0
ip nat outside
exit

int se0/0
ip nat inside
exit

int se0/1
ip nat inside
exit

ip nat inside source list NAT interface FastEthernet0/0 overload


Lab 22: Role Based CLI
 Task 4: Configure Site-2-Site VPN between R2 and R3. PC5 Communicate R12, R13 and R14
from VPN tunnel and Pc4 to R11 in VPN tunnel. Make sure Use isakmp key is netwaxlab.

R2

crypto isakmp policy 10


encr 3des
authentication pre-share
group 2
lifetime 1800
exit

crypto isakmp key netwaxlab address 21.55.47.3

crypto ipsec transform-set tset esp-3des esp-sha-hmac


exit

ip access-list extended VPN


permit ip host 192.168.1.100 host 192.168.5.100
permit ip host 192.168.2.100 host 192.168.5.100
permit ip host 192.168.3.100 host 192.168.5.100
permit ip host 192.168.4.100 host 10.0.31.11
exit

ip access-list extended NAT


deny ip host 192.168.1.100 host 192.168.5.100
deny ip host 192.168.2.100 host 192.168.5.100
deny ip host 192.168.3.100 host 192.168.5.100
deny ip host 192.168.4.100 host 10.0.31.11
exit

crypto map CMAP 10 ipsec-isakmp


set peer 21.55.47.3
set transform-set tset
match address VPN
exit

int f0/0
crypto map CMAP
exit
Lab 22: Role Based CLI
R3

crypto isakmp policy 10


encr 3des
authentication pre-share
group 2
lifetime 1800
exit

crypto isakmp key netwaxlab address 44.9.21.2

crypto ipsec transform-set tset esp-3des esp-sha-hmac


exit

ip access-list extended VPN


permit ip host 10.0.31.11 host 192.168.4.100
permit ip host 192.168.5.100 host 192.168.3.100
permit ip host 192.168.5.100 host 192.168.2.100
permit ip host 192.168.5.100 host 192.168.1.100
exit

ip access-list extended NAT


deny ip host 10.0.31.11 host 192.168.4.100
deny ip host 192.168.5.100 host 192.168.1.100
deny ip host 192.168.5.100 host 192.168.2.100
deny ip host 192.168.5.100 host 192.168.3.100
exit

crypto map CMAP 10 ipsec-isakmp


set peer 44.9.21.2
set transform-set tset
match address VPN
exit

int f0/0
crypto map CMAP
exit
Lab 22: Role Based CLI
 Task 5: Configure SSH on R14 and Telnet R11, R12 and R13. Use Enable secret password as
eincop and Local username as cisco and password as netwaxlab.

R11

enable secret eincop


username cisco password netwaxlab

line vty 0 4
login local
exit

R12

enable secret eincop


username cisco password netwaxlab

line vty 0 4
login local
exit

R13

enable secret eincop


username cisco password netwaxlab

line vty 0 4
login local
exit

R14

ip domain-name netwaxlab.com

username cisco password netwaxlab

crypto key generate rsa modulus 1024

line vty 0 4
transport input ssh
login local
exit
Lab 22: Role Based CLI
 Task 6: PC5 access R13 with full permission. But PC5 only access all show command on R14.

R14

aaa new-model
enable secret netwaxlab
enable view

config t
parser view R14
secret netwaxlab
command exec include all show
exit

 Task 7: PC5 access R12 some commands like sh ip int brief, sh ip protocol, ping, sh run and sh ip
interface.

R12

aaa new-model
enable secret netwaxlab
enable view

config t
parser view R14
secret netwaxlab
command exec include sh ip int bri
command exec include sh ip int
command exec include sh ip protocol
command exec include ping
exit

 Task 8: PC4 only access show history command on R11.

aaa new-model
enable secret netwaxlab
enable view

config t
parser view R14
secret netwaxlab
command exec include show history
exit
Lab 29: EIGRP-III
Task

Figure 1 Topology

1. Configure IP address as per given in topology.


2. Configure Eigrp as per given in topology and also introduce all the loopback in Eigrp.
3. Change Hello and Hold timer in Eigrp 200 to 2 and 6 respectively.
4. Use MD5 authentication between R5 and R4. Use keystring as N3TW@x.
5. Use Metric weight in eigrp 100 as 0 1 0 1 1 0.
6. Make sure all routers receive all the routes.
7. Manual Route summarization on R5 and R7 for loopbacks.
8. Make sure that R5 receive R7 loopback route from Se1/0.
Lab 29: EIGRP-III
Solution
Task 2: Configure Eigrp as per given in topology and also introduce all the loopback in Eigrp.

R1

router eigrp 100


network 10.0.0.0 0.0.0.255
no auto-summary
exit

R2

router eigrp 100


network 24.0.0.0 0.0.0.255
network 32.0.17.0 0.0.0.255
no auto-summary
exit

router eigrp 200


network 78.54.10.0 0.0.0.255
no auto-summary
exit

R3

router eigrp 100


network 10.0.0.0 0.0.0.255
network 32.0.17.0 0.0.0.255
network 151.45.8.0 0.0.0.255
no auto-summary
exit

R4

router eigrp 100


network 24.0.0.0 0.0.0.255
network 45.0.151.0 0.0.0.255
no auto-summary
exit
Lab 29: EIGRP-III
R5

router eigrp 100


network 5.5.1.0 0.0.0.255
network 5.5.2.0 0.0.0.255
network 5.5.3.0 0.0.0.255
network 5.5.4.0 0.0.0.255
network 10.0.0.0 0.0.0.255
network 45.0.151.0 0.0.0.255
no auto-summary
exit

R6

router eigrp 100


network 151.45.8.0 0.0.0.255
no auto-summary
exit

router eigrp 200


network 192.168.5.0
no auto-summary
exit

R7

router eigrp 200


network 7.7.1.0 0.0.0.255
network 7.7.2.0 0.0.0.255
network 7.7.3.0 0.0.0.255
network 7.7.4.0 0.0.0.255
network 78.54.10.0 0.0.0.255
network 192.168.5.0
no auto-summary
exit

Task 3: Change Hello and Hold timer in Eigrp 200 to 2 and 6 respectively.

R2

interface FastEthernet0/1
ip hello-interval eigrp 200 2
ip hold-time eigrp 200 6
Lab 29: EIGRP-III

exit

R6

interface FastEthernet0/1
ip hello-interval eigrp 200 2
ip hold-time eigrp 200 6
exit

R7

interface FastEthernet0/0
ip hello-interval eigrp 200 2
ip hold-time eigrp 200 6
exit

interface FastEthernet0/1
ip hello-interval eigrp 200 2
ip hold-time eigrp 200 6
exit

Task 4: Use MD5 authentication between R5 and R4. Use keystring as N3TW@x.

R4

key chain R4andR5


key 1
key-string N3TW@x
exit
exit

interface Serial1/0
ip authentication mode eigrp 100 md5
ip authentication key-chain eigrp 100 R4andR5
exit

R5

key chain R4andR5


key 1
key-string N3TW@x
exit
exit
Lab 29: EIGRP-III
interface Serial1/0
ip authentication mode eigrp 100 md5
ip authentication key-chain eigrp 100 R4andR5
exit

Task 5: Use Metric weight in eigrp 100 as 0 1 0 1 1 0.

On Router R1 to R6

router eigrp 100


metric weights 0 1 0 1 1 0
no auto-summary
exit

Task 6: Make sure all routers receive all the routes.

R2

router eigrp 100


redistribute eigrp 200 metric 128000 100 255 255 1500
exit

router eigrp 200


redistribute eigrp 100 metric 128000 100 255 255 1500
exit

R6

router eigrp 100


redistribute eigrp 200 metric 1 1 1 1 1
exit

router eigrp 200


redistribute eigrp 100 metric 1 1 1 1 1
exit

Task 7: Manual Route summarization on R5 and R7 for loopbacks.

R5

interface Serial1/0
ip summary-address eigrp 100 5.5.0.0 255.255.248.0
exit
Lab 29: EIGRP-III
R7

interface FastEthernet0/0
ip summary-address eigrp 200 7.7.0.0 255.255.248.0
exit

Task 8: Make sure that R5 receive R7 loopback route from Se1/0.

R5

access-list 1 permit 7.7.0.0 0.0.3.255

router eigrp 100


offset-list 1 in 2221056 FastEthernet0/0
exit
Lab 29: EIGRP-III
Task

Figure 1 Topology

1. Configure IP address as per given in topology.


2. Configure Eigrp as per given in topology and also introduce all the loopback in Eigrp.
3. Change Hello and Hold timer in Eigrp 200 to 2 and 6 respectively.
4. Use MD5 authentication between R5 and R4. Use keystring as N3TW@x.
5. Use Metric weight in eigrp 100 as 0 1 0 1 1 0.
6. Make sure all routers receive all the routes.
7. Manual Route summarization on R5 and R7 for loopbacks.
8. Make sure that R5 receive R7 loopback route from Se1/0.
Lab 29: EIGRP-III
Solution
Task 2: Configure Eigrp as per given in topology and also introduce all the loopback in Eigrp.

R1

router eigrp 100


network 10.0.0.0 0.0.0.255
no auto-summary
exit

R2

router eigrp 100


network 24.0.0.0 0.0.0.255
network 32.0.17.0 0.0.0.255
no auto-summary
exit

router eigrp 200


network 78.54.10.0 0.0.0.255
no auto-summary
exit

R3

router eigrp 100


network 10.0.0.0 0.0.0.255
network 32.0.17.0 0.0.0.255
network 151.45.8.0 0.0.0.255
no auto-summary
exit

R4

router eigrp 100


network 24.0.0.0 0.0.0.255
network 45.0.151.0 0.0.0.255
no auto-summary
exit
Lab 29: EIGRP-III
R5

router eigrp 100


network 5.5.1.0 0.0.0.255
network 5.5.2.0 0.0.0.255
network 5.5.3.0 0.0.0.255
network 5.5.4.0 0.0.0.255
network 10.0.0.0 0.0.0.255
network 45.0.151.0 0.0.0.255
no auto-summary
exit

R6

router eigrp 100


network 151.45.8.0 0.0.0.255
no auto-summary
exit

router eigrp 200


network 192.168.5.0
no auto-summary
exit

R7

router eigrp 200


network 7.7.1.0 0.0.0.255
network 7.7.2.0 0.0.0.255
network 7.7.3.0 0.0.0.255
network 7.7.4.0 0.0.0.255
network 78.54.10.0 0.0.0.255
network 192.168.5.0
no auto-summary
exit

Task 3: Change Hello and Hold timer in Eigrp 200 to 2 and 6 respectively.

R2

interface FastEthernet0/1
ip hello-interval eigrp 200 2
ip hold-time eigrp 200 6
Lab 29: EIGRP-III

exit

R6

interface FastEthernet0/1
ip hello-interval eigrp 200 2
ip hold-time eigrp 200 6
exit

R7

interface FastEthernet0/0
ip hello-interval eigrp 200 2
ip hold-time eigrp 200 6
exit

interface FastEthernet0/1
ip hello-interval eigrp 200 2
ip hold-time eigrp 200 6
exit

Task 4: Use MD5 authentication between R5 and R4. Use keystring as N3TW@x.

R4

key chain R4andR5


key 1
key-string N3TW@x
exit
exit

interface Serial1/0
ip authentication mode eigrp 100 md5
ip authentication key-chain eigrp 100 R4andR5
exit

R5

key chain R4andR5


key 1
key-string N3TW@x
exit
exit
Lab 29: EIGRP-III
interface Serial1/0
ip authentication mode eigrp 100 md5
ip authentication key-chain eigrp 100 R4andR5
exit

Task 5: Use Metric weight in eigrp 100 as 0 1 0 1 1 0.

On Router R1 to R6

router eigrp 100


metric weights 0 1 0 1 1 0
no auto-summary
exit

Task 6: Make sure all routers receive all the routes.

R2

router eigrp 100


redistribute eigrp 200 metric 128000 100 255 255 1500
exit

router eigrp 200


redistribute eigrp 100 metric 128000 100 255 255 1500
exit

R6

router eigrp 100


redistribute eigrp 200 metric 1 1 1 1 1
exit

router eigrp 200


redistribute eigrp 100 metric 1 1 1 1 1
exit

Task 7: Manual Route summarization on R5 and R7 for loopbacks.

R5

interface Serial1/0
ip summary-address eigrp 100 5.5.0.0 255.255.248.0
exit
Lab 29: EIGRP-III
R7

interface FastEthernet0/0
ip summary-address eigrp 200 7.7.0.0 255.255.248.0
exit

Task 8: Make sure that R5 receive R7 loopback route from Se1/0.

R5

access-list 1 permit 7.7.0.0 0.0.3.255

router eigrp 100


offset-list 1 in 2221056 FastEthernet0/0
exit
Lab 29: EIGRP-III
Task

Figure 1 Topology

1. Configure IP address as per given in topology.


2. Configure Eigrp as per given in topology and also introduce all the loopback in Eigrp.
3. Change Hello and Hold timer in Eigrp 200 to 2 and 6 respectively.
4. Use MD5 authentication between R5 and R4. Use keystring as N3TW@x.
5. Use Metric weight in eigrp 100 as 0 1 0 1 1 0.
6. Make sure all routers receive all the routes.
7. Manual Route summarization on R5 and R7 for loopbacks.
8. Make sure that R5 receive R7 loopback route from Se1/0.
Lab 29: EIGRP-III
Solution
Task 2: Configure Eigrp as per given in topology and also introduce all the loopback in Eigrp.

R1

router eigrp 100


network 10.0.0.0 0.0.0.255
no auto-summary
exit

R2

router eigrp 100


network 24.0.0.0 0.0.0.255
network 32.0.17.0 0.0.0.255
no auto-summary
exit

router eigrp 200


network 78.54.10.0 0.0.0.255
no auto-summary
exit

R3

router eigrp 100


network 10.0.0.0 0.0.0.255
network 32.0.17.0 0.0.0.255
network 151.45.8.0 0.0.0.255
no auto-summary
exit

R4

router eigrp 100


network 24.0.0.0 0.0.0.255
network 45.0.151.0 0.0.0.255
no auto-summary
exit
Lab 29: EIGRP-III
R5

router eigrp 100


network 5.5.1.0 0.0.0.255
network 5.5.2.0 0.0.0.255
network 5.5.3.0 0.0.0.255
network 5.5.4.0 0.0.0.255
network 10.0.0.0 0.0.0.255
network 45.0.151.0 0.0.0.255
no auto-summary
exit

R6

router eigrp 100


network 151.45.8.0 0.0.0.255
no auto-summary
exit

router eigrp 200


network 192.168.5.0
no auto-summary
exit

R7

router eigrp 200


network 7.7.1.0 0.0.0.255
network 7.7.2.0 0.0.0.255
network 7.7.3.0 0.0.0.255
network 7.7.4.0 0.0.0.255
network 78.54.10.0 0.0.0.255
network 192.168.5.0
no auto-summary
exit

Task 3: Change Hello and Hold timer in Eigrp 200 to 2 and 6 respectively.

R2

interface FastEthernet0/1
ip hello-interval eigrp 200 2
ip hold-time eigrp 200 6
Lab 29: EIGRP-III

exit

R6

interface FastEthernet0/1
ip hello-interval eigrp 200 2
ip hold-time eigrp 200 6
exit

R7

interface FastEthernet0/0
ip hello-interval eigrp 200 2
ip hold-time eigrp 200 6
exit

interface FastEthernet0/1
ip hello-interval eigrp 200 2
ip hold-time eigrp 200 6
exit

Task 4: Use MD5 authentication between R5 and R4. Use keystring as N3TW@x.

R4

key chain R4andR5


key 1
key-string N3TW@x
exit
exit

interface Serial1/0
ip authentication mode eigrp 100 md5
ip authentication key-chain eigrp 100 R4andR5
exit

R5

key chain R4andR5


key 1
key-string N3TW@x
exit
exit
Lab 29: EIGRP-III
interface Serial1/0
ip authentication mode eigrp 100 md5
ip authentication key-chain eigrp 100 R4andR5
exit

Task 5: Use Metric weight in eigrp 100 as 0 1 0 1 1 0.

On Router R1 to R6

router eigrp 100


metric weights 0 1 0 1 1 0
no auto-summary
exit

Task 6: Make sure all routers receive all the routes.

R2

router eigrp 100


redistribute eigrp 200 metric 128000 100 255 255 1500
exit

router eigrp 200


redistribute eigrp 100 metric 128000 100 255 255 1500
exit

R6

router eigrp 100


redistribute eigrp 200 metric 1 1 1 1 1
exit

router eigrp 200


redistribute eigrp 100 metric 1 1 1 1 1
exit

Task 7: Manual Route summarization on R5 and R7 for loopbacks.

R5

interface Serial1/0
ip summary-address eigrp 100 5.5.0.0 255.255.248.0
exit
Lab 29: EIGRP-III
R7

interface FastEthernet0/0
ip summary-address eigrp 200 7.7.0.0 255.255.248.0
exit

Task 8: Make sure that R5 receive R7 loopback route from Se1/0.

R5

access-list 1 permit 7.7.0.0 0.0.3.255

router eigrp 100


offset-list 1 in 2221056 FastEthernet0/0
exit
Lab 28: OSPF-III

Task

Figure 1 Topology

1. Configure IP Address as per given in topology.


2. Configure OSPF Routing Protocol as per given in topology.
3. Configure OSPF area 3 without using network command. (Do possible configuration)
4. Make sure all routers receive all routes.
5. Configure PAT on R1 and R11.
6. Change Hello and hold interval to 15 and 60 respectively in Area 10.
7. Best path selection, R9 reach 54.0.0.2 via R6.
8. OSPF Area 1 used MD5 Authentication using password "N3tW@xL@b".
9. R1 Advertise all loopbacks on R4 with single route.
10. Make sure Area 3 Routers not received others area routes in their routing table. (Do possible
configuration)
Lab 28: OSPF-III

Solution

 Task 2: Configure OSPF Routing Protocol as per given in topology.

R1

router ospf 1
router-id 1.1.1.1
exit

int se0/0
ip ospf 1 area 3
exit

int f1/0
ip ospf 1 area 3
exit

int se0/1
ip ospf 1 area 3
exit

R2

router ospf 1
router-id 2.2.2.2
exit

int se0/0
ip ospf 1 area 3
exit

int f0/0
ip ospf 1 area 3
exit

int se0/1
ip ospf 1 area 3
exit
Lab 28: OSPF-III

R3

router ospf 1
router-id 3.3.3.3
exit

int se0/0
ip ospf 1 area 3
exit

int f0/0
ip ospf 1 area 3
exit

int se0/1
ip ospf 1 area 3
exit

R4

router ospf 1
router-id 4.4.4.4
exit

int se0/0
ip ospf 1 area 3
exit

int f0/0
ip ospf 1 area 3
exit

int se0/1
ip ospf 1 area 3
exit

int l1
ip ospf 1 area 3
exit

int l2
Lab 28: OSPF-III

ip ospf 1 area 3
exit

int l3
ip ospf 1 area 3
exit

int l4
ip ospf 1 area 3
exit

R5

router ospf 1
router-id 5.5.5.5
log-adjacency-changes
area 1 authentication message-digest
network 54.32.78.0 0.0.0.255 area 1
exit

R6

router ospf 1
router-id 6.6.6.6
log-adjacency-changes
area 1 authentication message-digest
network 54.32.78.0 0.0.0.255 area 1
network 114.204.65.0 0.0.0.255 area 1
exit

R7

router ospf 1
router-id 7.7.7.7
log-adjacency-changes
area 1 authentication message-digest
area 1 virtual-link 9.9.9.9
network 45.0.84.0 0.0.0.255 area 0
network 54.32.78.0 0.0.0.255 area 1
exit
Lab 28: OSPF-III

R8

router ospf 1
router-id 8.8.8.8
log-adjacency-changes
area 10 virtual-link 1.1.1.1
network 34.11.78.0 0.0.0.255 area 10
network 45.21.88.0 0.0.0.255 area 4
network 60.4.100.0 0.0.0.255 area 4
network 100.251.0.0 0.0.0.255 area 4
exit

R9

router ospf 1
router-id 9.9.9.9
log-adjacency-changes
area 1 authentication message-digest
area 1 virtual-link 7.7.7.7
network 60.4.100.0 0.0.0.255 area 4
network 100.0.0.0 0.0.0.255 area 4
network 114.204.65.0 0.0.0.255 area 1
exit

R10

router ospf 1
router-id 10.10.10.10
log-adjacency-changes
network 100.0.0.0 0.0.0.255 area 4
network 100.251.0.0 0.0.0.255 area 4
exit

R11

router ospf 1
router-id 11.11.11.11
log-adjacency-changes
network 45.21.88.0 0.0.0.255 area 4
default-information originate
Lab 28: OSPF-III

 Task 3: Complete in Task 2.


 Task 4: Make sure all routers receive all routes.

R1

router ospf 1
area 10 virtual-link 8.8.8.8
exit

R8

router ospf 1
area 10 virtual-link 1.1.1.1
exit

R7

router ospf 1
area 10 virtual-link 9.9.9.9
exit

R9

router ospf 1
area 10 virtual-link 7.7.7.7
exit

 Task 5: Configure PAT on R1 and R11.

R1

ip access-list extended NAT


permit ip 10.0.13.0 0.0.0.255 any
permit ip 10.0.34.0 0.0.0.255 any
permit ip 10.0.24.0 0.0.0.255 any
permit ip 10.0.12.0 0.0.0.255 any
permit ip 192.168.1.0 0.0.0.255 any
permit ip 45.0.84.0 0.0.0.255 any
permit ip 34.11.78.0 0.0.0.255 any
permit ip 54.32.78.0 0.0.0.255 any
permit ip 114.204.65.0 0.0.0.255 any
permit ip 60.4.100.0 0.0.0.255 any
permit ip 100.0.0.0 0.0.0.255 any
permit ip 100.251.0.0 0.0.0.255 any
Lab 28: OSPF-III

permit ip 42.21.88.0 0.0.0.255 any


permit ip 4.4.1.0 0.0.0.255 any
permit ip 4.4.2.0 0.0.0.255 any
permit ip 4.4.3.0 0.0.0.255 any
permit ip 4.4.4.0 0.0.0.255 any
exit

int f0/0
ip nat outside
exit

int f0/1
ip nat inside
exit

int se0/0
ip nat inside
exit

int f1/0
ip nat inside
exit

int se0/2
ip nat inside
exit

int se0/1
ip nat inside
exit

ip nat inside source list NAT interface f0/0 overload

R11

ip access-list extended NAT


permit ip 45.21.88.0 0.0.0.255 any
permit ip 100.251.0.0 0.0.0.255 any
permit ip 60.4.100.0 0.0.0.255 any
permit ip 100.0.0.0 0.0.0.255 any
permit ip 114.204.65.0 0.0.0.255 any
Lab 28: OSPF-III

permit ip 54.32.78.0 0.0.0.255 any


permit ip 34.11.78.0 0.0.0.255 any
permit ip 45.0.84.0 0.0.0.255 any
permit ip 10.0.13.0 0.0.0.255 any
permit ip 10.0.34.0 0.0.0.255 any
permit ip 10.0.24.0 0.0.0.255 any
permit ip 10.0.12.0 0.0.0.255 any
permit ip 192.168.1.0 0.0.0.255 any
permit ip 4.4.1.0 0.0.0.255 any
permit ip 4.4.2.0 0.0.0.255 any
permit ip 4.4.3.0 0.0.0.255 any
permit ip 4.4.4.0 0.0.0.255 any
exit

int f0/0
ip nat outside
exit

int f0/1
ip nat inside
exit

ip nat inside source list NAT interface f0/0 overload

 Task 6: Change Hello and hold interval to 15 and 60 respectively in Area 10.

R1

int se0/2
ip ospf hello-interval 15
ip ospf dead-interval 60
exit

R8

int se0/0
ip ospf hello-interval 15
ip ospf dead-interval 60
exit
Lab 28: OSPF-III

 Task 7: Best path selection, R9 reach 54.0.0.2 via R6.

R9

int f0/0
ip ospf cost 100
exit

 Task 8: OSPF Area 1 used MD5 Authentication using password "N3tW@xL@b".

R5

router ospf 1
area 1 authentication message-digest
exit

int f0/0
ip ospf message-digest-key 1 md5 N3tW@xL@b
exit

R6

router ospf 1
area 1 authentication message-digest
exit

int f0/0
ip ospf message-digest-key 1 md5 N3tW@xL@b
exit

R7

router ospf 1
area 1 authentication message-digest
exit

int f0/0
ip ospf message-digest-key 1 md5 N3tW@xL@b
exit
Lab 28: OSPF-III

R9

router ospf 1
area 1 authentication message-digest
exit

int s0/0
ip ospf message-digest-key 1 md5 N3tW@xL@b
exit

 Task 9: R1 Advertise all loopbacks on R4 with single route.

R1

router ospf 1
area 3 range 4.4.0.0 255.255.248.0
exit

 Task 10: Make sure Area 3 Routers not received others area routes in their routing table. (Do
possible configuration)

R1

router ospf 1
area 3 stub no-summary
exit

R2

router ospf 1
area 3 stub no-summary
exit

R3

router ospf 1
area 3 stub no-summary
exit

R4

router ospf 1
area 3 stub no-summary
exit

(Note: Verify using "sh ip route".)

You might also like