You are on page 1of 7

ESCUELA SUPERIOR POLITCNICA DE CHIMBORAZO

FACULTAD DE INFORMTICA Y ELECTRNICA

ESCUELA DE INGENIERA ELECTRNICA EN TELECOMUNICACIONES Y REDES

CONMUTACION Y RUTEO II

CONFIGURACION EN GNS3 DEL PROTOCOLO PBR Y IP SLA

1. DATOS GENERALES:

NOMBRES: CODIGO(S):

Paul Mayanza Balla 718

FECHA DE REALIZACIN: FECHA DE ENTREGA:

30/10/2017 8/11/2017
2. OBJETIVO(S):

2.1. GENERAL

Configurar y Proporcionar una mejor comprensin del Protocol (PBR) y


(IP SLA)

2.2. ESPECFCOS

Configurar el escenario utilizando el protocolo PBR Y IP SLA


Analizar los resultados obtenidos mediante los comando ping y
tracerout.

3. METODOLOGA

Para la implementacin del siguiente escenario en gns3 se utilizo polticas de


encaminamiento con PBR y IP SLA y el protocolo de enrutamiento OSPF.
4. EQUIPOS Y MATERIALES

HARDWARE: SOFTWARE: Computador GNS3

5. MARCO TEORICO:

PBR (Policy-Based Routing):

El Policy-Based Routing proporciona un mecanismo para expresar y


implementar la expedicin/la encaminamiento de los paquetes de datos
basados en las directivas definidas por los administradores de la red.
El Policy-Based Routing se aplica a los paquetes entrantes y utiliza los mapa
del ruta para definir las directivas. De acuerdo con los criterios definidos en los
mapa del ruta, los paquetes se remiten/se rutean al salto siguiente apropiado.
Este documento proporciona una configuracin de muestra para el Policy-
Based Routing con el IPv6.

SLA IP:

Los SLA IP de Cisco IOS envan datos a travs de la red para medir el
rendimiento entre mltiples ubicaciones de red o en mltiples rutas de red.
Simula los datos de red y los servicios IP y recopila informacin de rendimiento
de la red en tiempo real. Los SLA IP de Cisco IOS generan y analizan el trfico
entre dispositivos Cisco IOS o desde un dispositivo Cisco IOS a un dispositivo
IP remoto, como un servidor de aplicaciones de red. Las mediciones
proporcionadas por las diversas operaciones de SLA IP de Cisco IOS se
pueden utilizar para la resolucin de problemas, el anlisis de problemas y el
diseo de topologas de red.

Dependiendo de la operacin especfica de los SLA IP de Cisco IOS, se


monitorean varias estadsticas de rendimiento de la red dentro del dispositivo
Cisco y se almacenan tanto en la interfaz de lnea de comando (CLI) como en
las MIBs del Protocolo simple de administracin de redes (SNMP). Los
paquetes de SLA de IP tienen opciones configurables de IP y capa de
aplicacin como direccin IP de origen y destino, protocolo de datagrama de
usuario (UDP) / TCP, un tipo de byte de servicio (ToS) (incluyendo punto de
cdigo de servicios diferenciados [DSCP] y bits de prefijo de IP) ), La instancia
de enrutamiento / reenvo (VRF) de red privada virtual (VPN) y la direccin web
de la URL.

Debido a que los SLA IP de Cisco son independientes del transporte de Capa
2, puede configurar operaciones de extremo a extremo en redes diferentes
para reflejar mejor las mtricas que un usuario final pueda experimentar. Los
SLA de IP recopilan un subconjunto nico de estas mtricas de rendimiento:
Demora (tanto de ida como de ida)

Jitter (direccional)

Prdida de paquetes (direccional)

Secuencia de paquetes (ordenamiento de paquetes)

Ruta (por salto)

Conectividad (direccional)

Tiempo de descarga del servidor o del sitio web

Debido a que los SLA IP de Cisco IOS tienen acceso a SNMP, tambin pueden
ser utilizados por aplicaciones de monitoreo de rendimiento como CiscoWorks
Internetwork Performance Monitor (IPM) y otros productos de administracin de
desempeo de socios de Cisco.

Configuraciones

En este ejemplo, con la encaminamiento normal, todos los paquetes a partir de


la red el 2001:1:1:7::/64 a Internet tomarn la trayectoria con las interfaces
Ethernet 0/0 del Router (va la subred 2001:1:1:3b::/64) esto es lograra
implementando PBR en el router IOU 2. Ademas se va implementar IP SLA
para monitorar la red 2001:1:1:3b::10, representado como el servidor 1, si el
ICMP-ECHO deja de enviar mensajes al servidor automticamente tomara otro
camino como es la red 2001:1:1:2d::/64, asi esta topologa ser una red
redundante gracias a estos protocolos.

Diagrama de la Red

Configuraciones

Router IOU1

track 1 ip sla 10 reachability


delay down 5 up 1
!
interface Ethernet0/0
no ip address
ipv6 address 2001:1:1:2A::1/64
ipv6 ospf 10 area 0
ipv6 policy route-map ipv6
!
interface Ethernet0/1
no ip address
shutdown
!
interface Ethernet0/2
no ip address
shutdown
!
interface Ethernet0/3
no ip address
shutdown
!
interface Ethernet1/0
no ip address
ipv6 address 2001:1:1:2D::1/64
ipv6 ospf 10 area 0
!
interface Ethernet1/1
no ip address
ipv6 address 2001:1:1:7::1/64
ipv6 ospf 10 area 0
ip sla 10
icmp-echo 2001:1:1:3B::10
frequency 5
ip sla schedule 10 life forever start-time now
ipv6 route ::/64 2001:1:1:2D::2 5
ipv6 router ospf 10
router-id 1.1.1.1
log-adjacency-changes
route-map ipv6 permit 7
match ipv6 address internal
set ipv6 next-hop 2001:1:1:2A::2
ipv6 access-list internal
permit ipv6 2001:1:1:7::/64 any
!

Configuraciones de la WAN

Router IOU2

interface Ethernet0/0
no ip address
ipv6 address 2001:1:1:2A::2/64
ipv6 ospf 10 area 0
!
interface Ethernet0/1
no ip address
ipv6 address 2001:1:1:3B::1/64
ipv6 ospf 10 area 0
ipv6 router ospf 10
router-id 2.2.2.2
log-adjacency-changes

Configuraciones del Router Internet


interface Ethernet0/0
no ip address
ipv6 address 2001:1:1:11::2/64
ipv6 ospf 10 area 0
!
interface Ethernet0/1
no ip address
ipv6 address 2001:1:1:6::1/64
ipv6 ospf 10 area 0
interface Serial2/0
no ip address
ipv6 address 2001:1:1:8::2/64
ipv6 ospf 10 area 0
serial restart-delay 0
ipv6 router ospf 10
router-id 6.6.6.6
log-adjacency-changes
!
!

Verificaciones

Comando ping desde la Vpc-1 (2001:1:1:7::10/64) local hasta el Internet

Comando tracer desde la Vpc-1 (2001:1:1:7::10/64) local hasta el Internet

Se muestra que el trafico de la red LAN se direccin por la ruta de mtrica ma


corta (2001:1:1:3b::/64) dicha ruta esta trabajando en la ISP 1

Comando tracer desde la Vpc-1 (2001:1:1:7::10/64) local hasta el Internet

Si la ISP 1 cae entonces el trafico de la LAN se redireccin por la IPS 2, como


se muestra en la siguiente imagen.
CONCLUSIONES Y RECOMENDACIONES:

La operacin de eco ICMP mide el tiempo de respuesta de extremo a


extremo entre un dispositivo Cisco y cualquier dispositivo que use IP. El
tiempo de respuesta se calcula midiendo el tiempo transcurrido entre el
envo de un mensaje de solicitud de eco ICMP al destino y la recepcin
de una respuesta de eco ICMP.
Muchos clientes usan SLA basados en IP, operaciones basadas en
ICMP, pruebas internas de ping o sondeos dedicados basados en ping
para las mediciones del tiempo de respuesta entre el dispositivo SLA IP
de origen y el dispositivo IP de destino.

6. Bibliografia
https://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst4500/1
2-2/44sg/configuration/guide/Wrappe
https://www.cisco.com/c/es_mx/support/docs/ip/border-gateway-
protocol-bgp/10116-36.html