You are on page 1of 21

Advanced Routing and Switching Field Engineer.

Here is a very simple of example of a MPLS network I created after attending the ARSFE course. It was
created in a GNS3 emulation environment and consists of four routers. Two CEs and two PEs. BGP is run
on the user network and OSPF is run on the PE-PE network. Additional P Routers can be inserted
between the PE Routers . These additional P Routers simply run MPLS and OSPF. Please note if the user
uses the same AS on both CEs then the as-override keyword is required.

Here are the configurations which are followed by various routing displays.

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

hostname cea

boot-start-marker
boot-end-marker

no aaa new-model

memory-size iomem 5

ip cef

interface FastEthernet0/0

ip address 10.0.0.1 255.255.255.0

duplex auto

speed auto

interface Serial0/0

ip address 10.0.1.2 255.255.255.0

clock rate 2000000

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

interface Serial0/1

no ip address
shutdown

clock rate 2000000

router bgp 65001

no synchronization

bgp log-neighbor-changes

network 10.0.0.0

redistribute connected

neighbor 10.0.1.1 remote-as 65000

no auto-summary

ip http server

no ip http secure-server

control-plane

line con 0

line aux 0

line vty 0 4

login

!
end

cea#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/24 is subnetted, 4 subnets

C 10.0.0.0 is directly connected, FastEthernet0/0

C 10.0.1.0 is directly connected, Serial0/0

B 10.0.6.0 [20/0] via 10.0.1.1, 00:01:07

B 10.0.5.0 [20/0] via 10.0.1.1, 00:01:07

cea#show ip int brief

Interface IP-Address OK? Method Status Prot

ocol

FastEthernet0/0 10.0.0.1 YES manual up up

Serial0/0 10.0.1.2 YES manual up up


FastEthernet0/1 unassigned YES unset administratively down down

Serial0/1 unassigned YES unset administratively down down

cea#show ip bgp summary

BGP router identifier 10.0.0.1, local AS number 65001

BGP table version is 5, main routing table version 5

4 network entries using 468 bytes of memory

4 path entries using 208 bytes of memory

3/2 BGP path/bestpath attribute entries using 372 bytes of memory

1 BGP AS-PATH entries using 24 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP using 1072 total bytes of memory

BGP activity 4/0 prefixes, 4/0 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

10.0.1.1 4 65000 7 7 5 0 0 00:02:57 2

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!
hostname PEA

boot-start-marker

boot-end-marker

no aaa new-model

memory-size iomem 5

ip cef

ip vrf cisco

rd 100:100

route-target export 100:100

route-target import 100:100

interface Loopback0

ip address 1.1.1.1 255.255.255.255

interface FastEthernet0/0

no ip address

shutdown

duplex auto
speed auto

interface Serial0/0

ip vrf forwarding cisco

ip address 10.0.1.1 255.255.255.0

clock rate 2000000

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

interface Serial0/1

ip address 10.0.4.2 255.255.255.0

mpls label protocol ldp

mpls ip

clock rate 2000000

router ospf 1

log-adjacency-changes

network 1.1.1.1 0.0.0.0 area 0

network 10.0.4.2 0.0.0.0 area 0

router bgp 65000


no synchronization

bgp log-neighbor-changes

neighbor 2.2.2.2 remote-as 65000

neighbor 2.2.2.2 update-source Loopback0

no auto-summary

address-family vpnv4

neighbor 2.2.2.2 activate

neighbor 2.2.2.2 send-community both

neighbor 2.2.2.2 next-hop-self

exit-address-family

address-family ipv4 vrf cisco

neighbor 10.0.1.2 remote-as 65001

neighbor 10.0.1.2 activate

neighbor 10.0.1.2 as-override

no synchronization

exit-address-family

ip http server

no ip http secure-server

!
!

control-plane

line con 0

line aux 0

line vty 0 4

login

end

PEA#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is not set


1.0.0.0/32 is subnetted, 1 subnets

C 1.1.1.1 is directly connected, Loopback0

2.0.0.0/32 is subnetted, 1 subnets

O 2.2.2.2 [110/65] via 10.0.4.1, 00:06:41, Serial0/1

10.0.0.0/24 is subnetted, 1 subnets

C 10.0.4.0 is directly connected, Serial0/1

PEA#show ip int brief

Interface IP-Address OK? Method Status Prot

ocol

FastEthernet0/0 unassigned YES unset administratively down down

Serial0/0 10.0.1.1 YES manual up up

FastEthernet0/1 unassigned YES unset administratively down down

Serial0/1 10.0.4.2 YES manual up up

Loopback0 1.1.1.1 YES manual up up

PEA#show ip bgp summary

BGP router identifier 1.1.1.1, local AS number 65000

BGP table version is 5, main routing table version 5

2 network entries using 234 bytes of memory

2 path entries using 104 bytes of memory

5/1 BGP path/bestpath attribute entries using 620 bytes of memory


1 BGP AS-PATH entries using 24 bytes of memory

1 BGP extended community entries using 24 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP using 1006 total bytes of memory

BGP activity 6/0 prefixes, 6/0 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

2.2.2.2 4 65000 11 10 5 0 0 00:06:43 2

PEA#show ip ospf nei

Neighbor ID Pri State Dead Time Address Interface

2.2.2.2 0 FULL/ - 00:00:30 10.0.4.1 Serial0/1

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

hostname PEB

boot-start-marker

boot-end-marker

!
no aaa new-model

memory-size iomem 5

ip cef

ip vrf cisco

rd 100:100

route-target export 100:100

route-target import 100:100

interface Loopback0

ip address 2.2.2.2 255.255.255.255

interface FastEthernet0/0

no ip address

shutdown

duplex auto

speed auto

interface Serial0/0

ip vrf forwarding cisco

ip address 10.0.5.2 255.255.255.0


clock rate 2000000

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

interface Serial0/1

ip address 10.0.4.1 255.255.255.0

mpls label protocol ldp

mpls ip

clock rate 2000000

router ospf 1

log-adjacency-changes

network 2.2.2.2 0.0.0.0 area 0

network 10.0.4.1 0.0.0.0 area 0

router bgp 65000

no synchronization

bgp log-neighbor-changes

redistribute connected

neighbor 1.1.1.1 remote-as 65000

neighbor 1.1.1.1 update-source Loopback0


no auto-summary

address-family vpnv4

neighbor 1.1.1.1 activate

neighbor 1.1.1.1 send-community both

neighbor 1.1.1.1 next-hop-self

exit-address-family

address-family ipv4 vrf cisco

neighbor 10.0.5.1 remote-as 65001

neighbor 10.0.5.1 activate

neighbor 10.0.5.1 as-override

no synchronization

exit-address-family

ip http server

no ip http secure-server

control-plane
!

line con 0

line aux 0

line vty 0 4

login

end

PEB#show ip route connect

PEB#show ip route connected

2.0.0.0/32 is subnetted, 1 subnets

C 2.2.2.2 is directly connected, Loopback0

10.0.0.0/24 is subnetted, 1 subnets

C 10.0.4.0 is directly connected, Serial0/1

PEB#show ip int brief

Interface IP-Address OK? Method Status Prot

ocol

FastEthernet0/0 unassigned YES unset administratively down down

Serial0/0 10.0.5.2 YES manual up up

FastEthernet0/1 unassigned YES unset administratively down down


Serial0/1 10.0.4.1 YES manual up up

Loopback0 2.2.2.2 YES manual up up

PEB#show ip bgp summ

PEB#show ip bgp summary

BGP router identifier 2.2.2.2, local AS number 65000

BGP table version is 3, main routing table version 3

2 network entries using 234 bytes of memory

2 path entries using 104 bytes of memory

5/1 BGP path/bestpath attribute entries using 620 bytes of memory

1 BGP AS-PATH entries using 24 bytes of memory

1 BGP extended community entries using 24 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP using 1006 total bytes of memory

BGP activity 6/0 prefixes, 6/0 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

1.1.1.1 4 65000 14 15 3 0 0 00:10:19 0

PEB#show ip ospf nei

PEB#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface


1.1.1.1 0 FULL/ - 00:00:38 10.0.4.2 Serial0/1

PEB#

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

hostname CEB

boot-start-marker

boot-end-marker

no aaa new-model

memory-size iomem 5

ip cef

interface FastEthernet0/0

ip address 10.0.6.2 255.255.255.0

duplex auto

speed auto

!
interface Serial0/0

ip address 10.0.5.1 255.255.255.0

clock rate 2000000

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

interface Serial0/1

no ip address

shutdown

clock rate 2000000

router bgp 65001

no synchronization

bgp log-neighbor-changes

network 10.0.0.0

redistribute connected

neighbor 10.0.5.2 remote-as 65000

no auto-summary

ip http server

no ip http secure-server
control-plane

line con 0

line aux 0

line vty 0 4

login

end

CEB#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/24 is subnetted, 4 subnets

B 10.0.0.0 [20/0] via 10.0.5.2, 00:10:20

B 10.0.1.0 [20/0] via 10.0.5.2, 00:10:20


C 10.0.6.0 is directly connected, FastEthernet0/0

C 10.0.5.0 is directly connected, Serial0/0

CEB#show ip int brief

Interface IP-Address OK? Method Status Prot

ocol

FastEthernet0/0 10.0.6.2 YES manual up up

Serial0/0 10.0.5.1 YES manual up up

FastEthernet0/1 unassigned YES NVRAM administratively down down

Serial0/1 unassigned YES unset administratively down down

CEB#show ip bgp summary

BGP router identifier 10.0.6.2, local AS number 65001

BGP table version is 5, main routing table version 5

4 network entries using 468 bytes of memory

4 path entries using 208 bytes of memory

3/2 BGP path/bestpath attribute entries using 372 bytes of memory

1 BGP AS-PATH entries using 24 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP using 1072 total bytes of memory

BGP activity 4/0 prefixes, 5/1 paths, scan interval 60 secs


Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

10.0.5.2 4 65000 15 15 5 0 0 00:11:26 2

You might also like