You are on page 1of 4

ERASE-RELOAD-COPY

#erase startup-config
#reload
#copy run start
#copy startup-config fttp
NAME
(config)#hostname Branch
BANNER
(config)#banner motd #......#
(config)#banner login #.......#
SERCURE AND PASSWORD COMBINE
(config)#enable secret class
(config)#line console 0
(config-line)#password cisco
(config-line)#login
(config-line)#line vty 0 4
(config-line)#password cisco
(config-line)#login
(config-line)#service password-encryption
(config-line)#exit
SSH ACCESS ONLY
(config)#username netadmin password cisco
(config)#ip domain-name abc.com
(config)#crypto key generate rsa
1024
(config)#ip ssh version 2
(config)#line vty 0 4
(config-line)#login local
(config-line)#transport input telnet ssh
IP ADDRESS FOR SWITCH
(config)#interface vlan1
(config-if)#ip address 10.1.1.2 255.255.255.0
(config-if)#no shut
(config-if)#exit
(config-if)#ip default-gateway 10.1.1.1
IP ADDRESS FOR ROUTER
(config)#interface s0/0
(config-if)#ip address 192.168.1.1 255.255.255.0
(config-if)#clock rate 64000 (DCE only)
(config-if)#bandwidth 64

(config-if)#no shut
STATIC ROUTE
(config)#ip route 10.2.2.0 255.255.255.0 10.0.12.2
(config)#ip route 10.2.2.0 255.255.255.0 s0/0
DEFAULT ROUTE
(config)#ip route 0.0.0.0 0.0.0.0 s0/0
RIP COMBINE
(config)#router rip
(config-router)#ver 2
(config-router)#network 10.0.0.0
(config-router)#default-information originate
(config-router)#exit
DHCP
(config)#ip dhcp pool SAIGON
(dhcp-config)#network 192.168.1.0 255.255.255.0
(dhcp-config)#default-router 192.168.1.1
(dhcp-config)#dns-server 8.8.8.8
(dhcp-config)#domain-name abc.com
(dhcp-config)#ip dhcp excluded-address 192.168.1.1 192.168.1.100
PASSWORD FOR CONSOLE: cisco
(config)#line console 0
(config-line)#login
(config-line)#password cisco
PASSWORD FOR TELNET: sanjose
(config)#line vty 0 4
(config-line)#login
(config-line)#password sanjose
PASSWORD FOR PRIVILEGE: class
(config)#enable password class
PASSWORD FOR SECRET: sanfran
(config)#enable secret sanfran
ENCRYPTO PASSWORD
(config)#service password-encryption
(config)#no service password-encryption
TIME OUT FOR CONSOLE
(config)#line console 0

(config-line)#exec-timeout 5 0 (5m0s)
PREVENT RESOLVING NAME
(config)#no ip domain-lookup
IP HOST
(config)#ip host VT 10.0.12.2 10.2.2.2
RIP PASSIVE
(config)#router rip
(config-router)#passive-interface serial 0/0
(config-router)#end
RIP NO PASSIVE
(config)#router rip
(config-router)#no passive-interface serial 0/0
(config-router)#end
RIP ORIGINATE
(config)#router rip
(config-router)#default-information originate
DEBUG
#debug ip rip
#debug ip rip events
#undebug all
LOOPBACK
(config)#interface loopback0
(config-if)#ip address 172.16.1.1 255.255.255.0
(config-if)#exit
PPP
(config-if)#encapsualaion ppp (#no encapsualation ppp)
SMD
(config)#ip http server
(config)#ip http sercure-server
(config)#ip http authentication local
(config)#username netadmin privillage 15 password cisco
(config)#line vty 0 4
(config)#login local
(config)#tranport input telnet ssh
SHOW COMMAND
#show version

#show sessions
#show hosts
#show clock
#show controllers (look up DCE or DTE)
#show controllers [interface]
#show users (#clear line [line number])
#show ssh
#show history
#show arp
#show ip arp
#show flash
#show running-config
#show interface
#show ip interface brief
#show interface [e0/0 (s0/0]
#show ip route
#show dhcp lease
#show ip dhcp binding
#show ip nat translation (clear ip nat translation)
#show ip protocols
#show cdp [neighbors, interface]
#traceroute 192.168.1.4

You might also like