You are on page 1of 4

==============================================

==============================
ERS 5500 Switch Configuration Template
ports 1-46 Edge ports, ports 47-48 Uplink ports
==============================================
===============================
! Enter configuration mode
5520-1>enable
5520-1#configure terminal
! Set the SNMP information
5520-1(config)#snmp-server name "5520-1"
5520-1(config)#snmp-server location "Company Location"
5520-1(config)#snmp-server contact "Network Infrastructure Team"
! configure username/password
cli password switch telnet local
username "RW" "password123" rw
! Create VLANs
5520-1(config)#vlan
5520-1(config)#vlan
5520-1(config)#vlan
5520-1(config)#vlan

configcontrol automatic
create 99 name voice type port
create 200 name data type port
create 260 name core type port

! Add ports to the created VLANs and remove them from VLAN 1
5520-1(config)#vlan members add 200 1-48
5520-1(config)#vlan members add 99 1-48
5520-1(config)#vlan members add 260 47-48
5520-1(config)#vlan members remove 1 all
! configure edge ports and trunk ports
5520-1(config)#vlan ports 1-46 tagging unTagPvidOnly
5520-1(config)#vlan ports 47-48 tagging tagAll
! Create MLT "port-channel" on the ports going to the core
mlt 2 name "lk to Core" enable member 47-48
! configure PVIDs "native VLANs on the ports"
5520-1(config)#vlan ports 1-46 pvid 200
5520-1(config)#vlan ports 47-48 pvid 260
! Enable IP Routing and assign SVIs
5520-1(config)#ip routing
5520-1(config)#interface vlan 99
5520-1(config-if)#ip address 10.1.80.1 255.255.255.0

5520-1(config-if)#exit
5520-1(config)#interface vlan 200
5520-1(config-if)#ip address 10.1.90.1 255.255.255.0
5520-1(config-if)#exit
5520-1(config)#interface vlan 260
5520-1(config-if)#ip address 10.1.4.2 255.255.255.252
5520-1(config-if)#exit
! Add static routes
5520-1(config)#ip route 0.0.0.0 0.0.0.0 10.1.4.1 1
! Add DHCP relay agents
5520-1(config)#interface vlan 99
5520-1(config-if)#ip dhcp-relay mode dhcp
5520-1(config)#interface vlan 200
5520-1(config-if)#ip dhcp-relay mode dhcp
5520-1(config-if)#exit
5520-1(config)#ip dhcp-relay fwd-path 10.1.80.1 172.30.30.50 enable
5520-1(config)#ip dhcp-relay fwd-path 10.1.90.1 172.30.30.50 enable
! Enable or disable STP Fast-Start
5520-1(config)#interface fastEthernet all
5520-1(config-if)#spanning-tree port 1-46 learning fast
5520-1(config-if)#exit
5520-1(config)#mlt spanning-tree 2 stp 1 learning disable
! Enable BPDU filter "dont enable on uplink ports connecting
switches together"
5520-1(config)#interface fastEthernet all
5520-1(config-if)# spanning-tree bpdu-filtering port 1-46 timeout 0
5520-1(config-if)#spanning-tree bpdu-filtering port 1-46 enable
5520-1(config-if)#exit
! Enable Broadcast and Multicast Rate Limiting on Edge ports
5520-1(config)#interface fastEthernet all
5520-1(config-if)# rate-limit port 1-46 both 10
5520-1(config-if)# exit
! Enable IP Anti-Spoofing "Optional"
! Enable IP DHCP Snooping for voice and data VLAN
5520-1(config)#ip dhcp-snooping vlan 99
5520-1(config)#ip dhcp-snooping vlan 200
5520-1(config)#ip dhcp-snooping enable
! Enable IP Arp Inspection for voice and data VLAN
5520-1(config)#ip arp-inspection vlan 99

5520-1(config)#ip arp-inspection vlan 200


! Enable IP Source Guard
5520-1(config)#interface fastEthernet 1-46
5520-1(config-if)#ip verify source
5520-1(config-if)#exit
! Enable core port 24 as a trusted port
5520-1(config)#interface fastEthernet 47-48
5520-1(config-if)#ip dhcp-snooping trusted
5520-1(config-if)#ip arp-inspection trusted
5520-1(config-if)#exit
For more info please check this document
https://downloads.avaya.com/css/P8/documents/100099410
https://blog.michaelfmcnamara.com/2007/10/nortel-ers-5520-pwr-switch/

==============================================
==============================
ERS 3500 Switch Configuration Template
==============================================
===============================
enable
configure terminal
snmp-server name "Switch1"
cli password switch serial none
cli password switch telnet local
username "RW" "password123" rw
ip address switch 10.50.145.8
ip address netmask 255.255.255.0
ip default-gateway 10.50.145.254
telnet-access enable
snmp-server enable
web-server enable
vlan configcontrol flexible
vlan create 90 name "Data-VLAN" type port
vlan mgmt 90
vlan
vlan
vlan
vlan

ports 1-24 tagging unTagPvidOnly


ports 25-26 tagging tagAll
members add 90 all
ports 1-26 pvid 90

interface FastEthernet ALL


spanning-tree port 1-26 learning fast
spanning-tree bpdu-filtering port 1-24 enable timeout 0
rate-limit port 1-24 both 10
exit
==============================================
===============================
ERS 5500 Switch Configuration Template
==============================================
===============================
enable
configure terminal
snmp-server name "Switch1"
cli password switch serial none
cli password switch telnet local
username "RW" "password123" rw
ip address switch 10.50.145.1
ip address netmask 255.255.255.0
ip default-gateway 10.50.145.254
vlan
vlan
vlan
vlan
vlan
vlan

configcontrol flexible
ports 1-24 tagging tagAll
create 90 name "Data-VLAN" type port
mgmt 90
members add 90 all
ports 1-26 pvid 90

interface FastEthernet ALL


spanning-tree port 1-12 learning fast
rate-limit port 1-24 both 10

You might also like