You are on page 1of 15

LOAD BALANCER

Balanceo de carga significa divide el total del trabajo que un Sistema


o computadora tiene que hacer entre 2 o ms sistemas o
computadoras. As pues esta divisin de carga permite realizar el
mismo trabajo en una porcin de tiempo ms reducida o lo que es lo
mismo permite realizar ms carga de trabajo en el mismo tiempo
total

TOPOLOGIA DE LA RED

La imagen de arriba muestra una red SLB (Server Load Balancer) con los
componentes sgts:

1 Bloque de servidor para permitir acceso nombrado SERVER


2 Servidores reales en el bloque del servidor SERVER con la
direccin IP 33.33.33.5 y 33.33.33.6
1 Servidor Virtual para permitir acceso nombrado VSERVER

CASO DE ESTUDIO
Como se aprecia en la topologa tenemos una red que est configurada
previamente con enrutamiento EIGRP, bsicamente el router con el nombre
de LoadBalancer su trabajo es distribuir las conecciones entrantes del
mundo exterior a los servidore, toda esta distribucin depende casi del

algoritmo que usa el balanceo de carga (LOAD BALANCER) en este caso


hemos utilizado el algoritmo ROUND ROBIN a respeto a los dems, como el
peso, basado en el que se asigna un cierto peso a un servidor para
asegurarse de que se ocupa mas solicitudes comparar al servidor con
menos peso , lo que tiene sentido si el servidor con peso superior es un gran
servidor, a comparar al servidor con menos peso.

OBJETIVO GENERAL
Como objetivo general de este proyecto es demostrar que se pueden
balancear lar cargas o los paquetes se distribuyen equitativamente en los
enlaces disponibles sin importar la capacidad independiente de cada uno

OBJETIVO ESPECIFICO
Balancear los paquetes distribuyendo disponibles para la conexin

CONFIGURACIONES
ROUTER 1
R1#show run
Building configuration...
Current configuration : 1224 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef

!
multilink bundle-name authenticated
!
!
!
memory-size iomem 0
archive
log config
hidekeys
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
duplex half
!
interface FastEthernet1/0
no ip address
shutdown
duplex half
!
interface FastEthernet2/0
no ip address
shutdown
duplex half
!
router eigrp 1
network 1.1.1.1 0.0.0.0
network 12.12.12.1 0.0.0.0
auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!

!
control-plane
!
!
!
mgcp fax t38 ecm
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
end
ROUTER 2
R2#show run
Building configuration...
Current configuration : 1264 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model

ip source-route
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
memory-size iomem 0
archive
log config
hidekeys
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.0
!
interface FastEthernet0/0
ip address 12.12.12.2 255.255.255.0
duplex half
!
interface FastEthernet1/0
ip address 23.23.23.2 255.255.255.0
duplex half
!
interface FastEthernet2/0
no ip address
shutdown
duplex half
!
router eigrp 1
network 2.2.2.2 0.0.0.0
network 12.12.12.2 0.0.0.0
network 23.23.23.0 0.0.0.255
auto-summary

!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
mgcp fax t38 ecm
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
End

ROUTER 3
LoadBalancer#show run
Building configuration...
Current configuration : 1598 bytes
!

upgrade fpd auto


version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname LoadBalancer
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
no ip icmp rate-limit unreachable
ip cef
ip slb serverfarm SERVER
real 33.33.33.5
weight 1
maxconns 2
inservice
real 33.33.33.6
weight 1
maxconns 2
inservice
!
ip slb vserver VSERVER
virtual 100.100.100.100 tcp telnet
serverfarm SERVER
inservice
!
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
memory-size iomem 0
archive
log config
hidekeys
!
!
!

!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
ip address 3.3.3.3 255.255.255.0
!
interface Loopback1
ip address 100.100.100.100 255.255.255.255
!
interface FastEthernet0/0
ip address 23.23.23.3 255.255.255.0
duplex half
!
interface FastEthernet1/0
ip address 33.33.33.3 255.255.255.0
duplex half
!
interface FastEthernet2/0
no ip address
shutdown
duplex half
!
router eigrp 1
network 3.3.3.3 0.0.0.0
network 23.23.23.3 0.0.0.0
network 33.33.33.3 0.0.0.0
network 100.100.100.100 0.0.0.0
auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!

mgcp fax t38 ecm


!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
no login
!
End

ROUTER 5
R5#show run
Building configuration...
Current configuration : 1324 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!

hostname R5
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
memory-size iomem 0
archive
log config
hidekeys
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
ip address 5.5.5.5 255.255.255.0
!
interface Loopback1
ip address 100.100.100.100 255.255.255.255
!
interface FastEthernet0/0
ip address 33.33.33.5 255.255.255.0
duplex half
!
interface FastEthernet1/0
no ip address
shutdown
duplex half
!

interface FastEthernet2/0
no ip address
shutdown
duplex half
!
router eigrp 1
network 5.5.5.5 0.0.0.0
network 33.33.33.5 0.0.0.0
network 100.100.100.100 0.0.0.0
auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
mgcp fax t38 ecm
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
no login
!

End

ROUTER 6
R6#show run
Building configuration...
Current configuration : 1324 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R6
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
memory-size iomem 0
archive
log config
hidekeys
!
!
!
!
!
ip tcp synwait-time 5
!

!
!
!
interface Loopback0
ip address 6.6.6.6 255.255.255.0
!
interface Loopback1
ip address 100.100.100.100 255.255.255.255
!
interface FastEthernet0/0
ip address 33.33.33.6 255.255.255.0
duplex half
!
interface FastEthernet1/0
no ip address
shutdown
duplex half
!
interface FastEthernet2/0
no ip address
shutdown
duplex half
!
router eigrp 1
network 6.6.6.6 0.0.0.0
network 33.33.33.6 0.0.0.0
network 100.100.100.100 0.0.0.0
auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!
!
control-plane
!
!
!
mgcp fax t38 ecm
!
!
!
!
gatekeeper
shutdown

!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
no login
!
end

VERIFICANDO

Como se puede ver en la imagen nuestras conexiones telnet estn


recibiendo balanceo de carga entre ambos servidor

Ya que no hay ninguna conexin activa el recuento de conexin es 0.


Iniciaremos una conexin

CONCLUSION
Al finalizar el proyecto se espera demostrar que se pueden balancear lar
cargas o los paquetes se distribuyen equitativamente en los enlaces
disponibles

You might also like