You are on page 1of 37

PROGRAMA DE EDUCAO CONTINUADA A DISTNCIA

Portal Educao

CURSO DE

MICROSOFT OFFICE EXCEL 2010


AVANADO

Aluno:
EaD - Educao a Distncia Portal Educao
AN02FREV001/REV 4.0

CURSO DE

MICROSOFT OFFICE EXCEL 2010


AVANADO

MDULO I

Ateno: O material deste mdulo est disponvel apenas como parmetro de estudos para este
Programa de Educao Continuada. proibida qualquer forma de comercializao ou distribuio
do mesmo sem a autorizao expressa do Portal Educao. Os crditos do contedo aqui contido
so dados aos seus respectivos autores descritos nas Referncias Bibliogrficas.

AN02FREV001/REV 4.0

SUMRIO

MDULO I
1 INTRODUO
2 OBJETIVOS
3 O EXCEL 2010 E AS FUNES
4 CONSTRUINDO A PLANILHA FOLHA DE PAGAMENTO
4.1 OS AJUSTES DAS TABELAS DE PESQUISA E DE OUTROS CAMPOS
4.2 CLCULO DOS DEMAIS CAMPOS
4.2.1 Funo Lgica De Conjuno E( )
4.2.2 Funo Lgica De Conjuno OU( )
4.2.3 Funo Lgica De Negao No ( )
5 OUTRAS OPERAES COM FUNES
5.1 FUNO =ABS( )
5.2 FUNO =AGORA( )
5.3 FUNO =CONT.SE( )
5.4 FUNO =FATORIAL( )
5.5 FUNO =POTNCIA( )
5.6 FUNO =SOMA( )
6 ERROS OCORRIDOS NO USO DE FUNES
7 EXERCCIOS

MDULO II
8 OBJETIVOS
9 AS CARACTERSTICAS DE UMA BASE DE DADOS
9.1 A CLASSIFICAO DE REGISTROS
9.2 AS OPERAES DE BUSCA E TROCA
9.3 OS RELATRIOS DE UMA BASE DE DADOS
9.4 OS EXTRATOS DE UMA BASE DE DADOS
9.5 COMO UTILIZAR A PESQUISA DO TIPO E

AN02FREV001/REV 4.0

9.6 COMO UTILIZAR A PESQUISA DO TIPO OU


9.7 USO DE CAMPO CALCULADO NA EXTRAO DE DADOS
9.8 USO DE SUBTOTAIS
9.9 AS FUNES DE BASE DE DADOS
10 EXERCCIOS

MDULO III
11 OBJETIVOS
12 TRABALHANDO COM TABELAS DE GRFICOS DINMICOS
12.1 COMO ATUALIZAR UMA TABELA DINMICA
12.2 A ALTERAO DE ELEMENTOS
12.2.1 Alterao Da Exibio Dos Valores
12.2.2 Os Relatrios Baseados Em Detalhes De Valores
12.3 A UTILIZAO DE GRFICO DINMICO
13 EXERCCIOS
14 ANLISE DE DADOS
14.1 UTILIZAO DE CENRIOS
14.2 ATINGIR METAS
14.3 AUDITOR DE FRMULAS
14.4 GERENCIAR EXIBIES
15 IMPORTAO DE DADOS DA INTERNET
16 SOLVER
17 EXERCCIOS

MDULO IV
18 OBJETIVOS
19 APRESENTANDO AS MACROS E O AMBIENTE VBA
19.1 A ATIVAO DA GUIA DESENVOLVEDOR DO EXCEL 2010
19.2 OS ARQUIVOS DO EXCEL 2010
19.3 OS TIPOS DE MACRO
19.3.1 As Macros De Comando
19.3.2 As Macros De Funes Definidas Pelo Usurio

AN02FREV001/REV 4.0

19.3.3 As Macros De Sub-Rorina


19.4 A NECESSIDADE DE PLANEJAR UMA MACRO
19.5 ESTUDANDO O AMBIENTE VISUAL BASIC
19.5.1 A Construo De Uma Macro
19.6 CARACTERSTICAS TPICAS DE MACRO EM VBA
19.6.1 Linhas De Comentrios
19.6.2 Os Comandos Sub/End Sub
19.6.3 Nome Do Procedimento
19.6.4 Cdigo-Fonte Do Procedimento
19.7 EXECUTAR UMA MACRO
19.7.1 Macros De Endereo Absoluto E Relativo
19.7.2 Macro De Endereo Absoluto
19.7.3 Macro De Endereo Relativo
19.8 O AMBIENTE DO VISUAL BASIC
19.8.1 Caixa Objeto
19.8.2 Caixa Procedimento/Evento
19.8.3 Barra De Diviso
19.8.4 Barra Do Indicador De Margem
19.8.5 cone Exibir Procedimento
19.8.6 cone Exibir Mdulo Completo
20 EXERCCIOS
21 TCNICA DE PROGRAMAO NO EXCEL 2010
21.1 CONCEITOS BSICOS
21.1.1 Procedimentos
21.1.2 Instrues
21.1.3 Objetos
21.1.4 Propriedades
21.1.5 Mtodos
21.1.6 Funes
21.1.7 Valores de Uma Propriedade
21.1.8 Mltiplos Mtodos e Propriedades
21.1.9 Hierarquia das Propriedades
21.2 VARIVEIS, CONSTANTES E ARITIMTICAS

AN02FREV001/REV 4.0

21.3 TIPOS DE DADOS


21.4 ENTRADA DE DADOS
21.5 DESVIOS CONDICIONAIS
21.6 LAOS
21.7 DEPURAR MACROS
22 EXERCCIOS

MDULO V
23 OBJETIVOS
24 CARACTERSTICA FUNCIONAL
25 COMO DESENVOLVER FUNES COM O VB
25.1 A VERIFICAO DE FUNES
26 EXERCCIOS
27 AS MACROS COM O EXCEL 2010
27.1 DEFININDO A PLANILHA
27.2 OBSERVANDO REA DE RECEPO DOS DADOS
27.3 A MACRO PARA RECEPO DOS DADOS
27.4 A MACRO PARA TRANSPORTE DOS DADOS
27.5 A MACRO PARA CADASTRO DOS DADOS
27.6 A MACRO PARA ORDENAR DADOS
28 AS PRXIMAS NOVIDADES DA NOVA VERSO DO EXCEL 2013
REFERNCIAS BIBLIOGRFICAS

AN02FREV001/REV 4.0

Organizao
O Curso de Microsoft Office Excel 2010 Avanado est organizado em
diversos

nveis

de

aprendizagens,

proporcionando

ao

participante

um

aproveitamento terico/prtico mais dinmico.


Ao longo do contedo, sero apresentados diversos cones que orientar o
participante ao cumprimento de diversas tarefas fundamentais.

cone

Descrio
Aplicao de exerccio.

Observao ao que est sendo citado.

Praticar a teoria.

Ateno ao que est sendo citado.

AN02FREV001/REV 4.0

Mdulo 1
1 INTRODUO

O principal foco deste treinamento o estudo da parte avanada dos


recursos da planilha eletrnica Excel em sua verso 2010. No se pretende gastar
tempo com noes bsicas de Excel, mas sim ganhar tempo com os estudos de
novos e avanados recursos. Neste mdulo inicial, vamos tentar resgatar um pouco
sobre a utilizao de algumas funes de clculo, o seu emprego e demais
operaes com funes. Tenha a certeza de que voc aprender muito e que as
suas atividades com planilhas de clculos nunca mais sero as mesmas.

2 OBJETIVOS

Revisar algumas funes do Excel 2010.


Identificar a ajuda das funes do Excel 2010.
Construir a planilha de folha de pagamento.

AN02FREV001/REV 4.0

3 O EXCEL 2010 E AS FUNES

No h dvida de que o Excel 2010 uma poderosa ferramenta para a


realizao de clculos, sejam eles simples e aqueles mais sofisticados. As funes
do Excel 2010 so composies de
frmulas

predefinidas

para

realizao de clculos das mais


variadas

formas

com

extrema

facilidade.
As funes disponveis no
Excel 2010 so muito similares s funes embutidas e existentes nas calculadoras
cientficas para as mais diversas aplicaes. Podemos dividir as funes do Excel
2010 em subcategorias e assim classific-las:

Funes de suplemento e automao;

Funes de gerenciamento de banco de dados ou listas;

Funes de engenharia;

Funes de informaes;

Funes de pesquisa e referncia;

Funes estatsticas;

Funes cubo;

Funes de data e hora;

Funes financeiras;

Funes lgicas;

Funes matemticas e trigonomtricas;

Funes de textos e dados.

Uma funo tem um nome de identificao que pode ser digitado


com ou sem argumentos (parmetros).

AN02FREV001/REV 4.0

As funes sem argumentos so representadas por palavras seguidas dos


parnteses sem a meno de contedo como argumento dentro desses smbolos.
Exemplo de uma funo sem argumento:
=FUNO( )

As funes com argumento so acompanhadas de algum contedo escrito


dentro dos parnteses.
Exemplo de uma funo com argumento:
=FUNO( argumento1; argumento2; ....; argumentoN)

Os argumentos, assim como o nome de identificao de uma


funo, a serem fornecidos planilha podem ser digitados tanto
em caracteres maisculos como em caracteres minsculos.

Para a utilizao de funes no Excel 2010, necessrio observar as seguintes


regras:
Sempre que uma funo necessitar de argumentos, eles devem estar
mencionados dentro dos parnteses.

S pode ser utilizada uma nica funo por clula, a qual no pode ultrapassar
o limite de 256 caracteres.

No podem ser informados espaos em branco entre os argumentos.


Para separar os argumentos, deve ser utilizada uma vrgula (,), um ponto (.) ou
um ponto e vrgula (;), dependendo da configurao de regio e idioma do
sistema operacional. Normalmente se utiliza o ponto e vrgula (;) quando a
configurao do sistema est para o idioma portugus (Brasil).

AN02FREV001/REV 4.0

10

Os argumentos de uma funo podem ser fornecidos como


valores ou frmulas. As frmulas podem conter outras funes.
Uma funo que tem como argumento outra funo conhecida
como funo aninhada. S podem ser aninhadas at sete nveis de funes em uma
frmula.

Procedimentos prticos:
Para que voc possa obter maiores informaes e exemplos de uso das funes do
Excel 2010, pressione a tecla de funo <F1> (Ajuda) para que o modo ajuda do
Excel 2010 seja ativado. Abaixo da barra de ferramentas h um campo onde se
pode digitar o que se deseja pesquisar. Assim sendo, digite nesse campo a palavra
funes e em seguida d um clique com o ponteiro do mouse sobre o boto
Pesquisar. Observe o modelo:

AN02FREV001/REV 4.0

11

FIGURA 01 - AJUDA DO EXCEL COM PESQUISA SOBRE FUNES

FONTE: Arquivo pessoal do autor (Renato Nicodemos).

A partir deste ponto basta acionar os links (pontos de ligao) apresentados na tela.

Um link importante que pode ser inicialmente consultado e


estudado, principalmente por usurios mais antigos de outras
verses, O que h de novo: alteraes feitas em funes do
Excel.

AN02FREV001/REV 4.0

12

4 CONSTRUINDO A PLANILHA DE FOLHA DE PAGAMENTO

A planilha de folha de pagamento que ser desenvolvida uma simulao


que est muito longe de ser considerada para a implementao real em uma
empresa de qualquer porte, mesmo pequenas, mdias ou microempresas, pois no
esto sendo levados em considerao diversos fatores e condies contbeis e
legais. Assim sendo, para que essa planilha possa ser utilizada profissionalmente,
deve ser apreciada por um profissional da rea de contabilidade para as devidas
orientaes tcnicas.

Procedimentos prticos:
Passo 01: Execute o Excel 2010.
Passo 02: Posicione o cursor na clula A1 e digite o seguinte ttulo: Grupo
Simulao Ltda. Folha de Pagamento. Altere a largura dessa coluna para o
tamanho 23 e formate o texto em negrito e sublinhado.
Passo 03: Posicione o cursor na clula A3 e digite o texto: Salrio mnimo. No
efetue nenhuma formatao nessa clula.

Passo 04: Posicione o cursor na clula B3 e digite o valor fictcio de salrio mnimo
na casa de 724,00. Formate essa clula como nmero com duas casas decimais e
com separadores de milhares.

Passo 05: Coloque o cursor na clula A5 e digite o ttulo: Funcionrio. Aplique o


efeito de formatao negrito.
Passo 06: Posicione o cursor na clula B5 e digite o ttulo: Cd. (cdigo do
cargo). Altere a largura dessa coluna para o tamanho 7 e aplique o efeito negrito.

AN02FREV001/REV 4.0

13

Passo 07: Leve o cursor at a clula C5 e digite o ttulo: Cargo. Depois altere a
largura dessa coluna para o tamanho 21, deixando o formato do texto em negrito.
Passo 08: Leve o cursor at a clula D5 e digite o ttulo: Nr. Sal. (nmero de
salrios mnimos recebidos). Em seguida, altere a largura dessa coluna para o
tamanho 7, deixando o formato do texto em negrito.
Passo 09: Coloque o cursor na clula E5 e digite o ttulo: Sal. Bruto (salrio
bruto). Altere a largura dessa coluna para o tamanho 10 deixando o formato de texto
em negrito.
Passo 10: Posicione o cursor na clula F5 e digite o ttulo: INSS. A largura dessa
coluna deve ser definida com o tamanho 9, deixando o formato de texto em negrito.

D uma observada na montagem de sua planilha, ela deve estar similar ao modelo:

FIGURA 02 - TTULOS DE COLUNAS APLICADOS PARCIALMENTE

FONTE: Arquivo pessoal do autor (Renato Nicodemos).

Passo 11: Posicione o cursor na clula G5 e digite o ttulo: Dep. (nmero


de dependentes). Altere a largura dessa coluna para o tamanho 5 deixando o
formato de texto em negrito.
Passo 12: Leve o cursor at a clula H5 e digite o ttulo: Sal. Fam. (salrio
famlia). Altere a largura dessa coluna para o tamanho 10, deixando o formato do
texto em negrito.
AN02FREV001/REV 4.0

14

Passo 13: Posicione o cursor na clula I5 e digite o ttulo: IRRF (Imposto


de Renda Retido na Fonte). Altere a largura dessa coluna para o tamanho 9,
deixando o formato do texto em negrito.
Passo 14: Posicione o cursor na clula J5 e digite o ttulo: Tot. Desc.
(total de descontos). Altere a largura dessa coluna para o tamanho 10, deixando o
formato do texto em negrito.
Passo 15: Posicione o cursor na clula K5 e digite o ttulo: Sal. Lq.
(salrio lquido). Altere a largura dessa coluna para o tamanho 10, deixando o
formato do texto em negrito.

D uma observada na montagem de sua planilha, ela deve estar similar ao


modelo:

FIGURA 03 - TTULOS DAS COLUNAS FINALIZADOS

FONTE: Arquivo pessoal do autor (Renato Nicodemos).

Passo 16: Posicione o cursor na clula A22 e digite o ttulo: Total de


Salrios Pagos, deixando o formato do texto em negrito.
Passo 17: Posicione o cursor na clula A23 e digite o ttulo: Mdia de
Salrios Pagos, deixando o formato do texto em negrito.

AN02FREV001/REV 4.0

15

Passo 18: Posicione o cursor na clula A24 e digite o ttulo: Maior Salrio
Pago, deixando o formato do texto em negrito.
Passo 19: Posicione o cursor na clula A25 e digite o ttulo: Menor Salrio
Pago, deixando o formato do texto em negrito.

Compare se os procedimentos anteriores correspondem ao mesmo formato


do modelo:

FIGURA 04 - MODELO DE PLANILHA DE FOLHA DE PAGAMENTO

FONTE: Arquivo pessoal do autor (Renato Nicodemos).

AN02FREV001/REV 4.0

16

4.1 OS AJUSTES DAS TABELAS DE PESQUISAS E OUTROS CAMPOS

A partir daqui desenvolveremos as tabelas de pesquisas a serem utilizadas


na planilha de folha de pagamento.

Procedimentos prticos:
Passo 01: Digite a listagem de funcionrios e de seus cdigos de cargos,
comparando a sua entrada de dados com o modelo abaixo que mostra a disposio
dessas informaes na planilha de folha de pagamento a partir da clula A6.

FIGURA 05 - DISPOSIO DAS INFORMAES NA PLANILHA FOLHA DE


PAGAMENTO

FONTE: Arquivo pessoal do autor (Renato Nicodemos).

AN02FREV001/REV 4.0

17

Funcionrio: a lista de dezesseis funcionrios que faz parte da


folha de pagamento.
Cd.: o cdigo de cada funcionrio que dever ser fornecido, o
qual deve estar entre 1 e 16.

Passo 02: Digite a Tabela de Cargos e Salrios a partir da clula M5, pois
ela a base para diversos clculos na planilha, observe o modelo:

FIGURA 06 - TABELA DE CDIGOS, CARGOS E SALRIOS

FONTE: Arquivo pessoal do autor (Renato Nicodemos).

Passo 03: Digite a partir da clula Q5 a Tabela de INSS conforme o modelo:

FIGURA 07 - TABELA DE INSS

FONTE: Arquivo pessoal do autor (Renato Nicodemos).

AN02FREV001/REV 4.0

18

Passo 04: Digite a partir da clula U5 a tabela para os devidos clculos do


IRRF, conforme o modelo:

FIGURA 08 - TABELA IRRF

FONTE: Arquivo pessoal do autor (Renato Nicodemos).

Passo 05: A partir do momento em que as tabelas de auxlio esto prontas


na planilha, necessrio continuar a montagem. V at a clula G6 e digite o
nmero de dependentes de cada funcionrio na coluna Dep.. Observe o modelo:

FIGURA 09 - COLUNA DE DEPENDENTES

FONTE: Arquivo pessoal do autor (Renato Nicodemos).


AN02FREV001/REV 4.0

19

Faa uma comparao com os modelos abaixo:

FIGURA 10 - PLANILHA DE FOLHA DE PAGAMENTO

FIM DO MDULO I

FONTE: Arquivo pessoal do autor (Renato Nicodemos).

AN02FREV001/REV 4.0

20

FIGURA 11 - REA RESERVADA S TABELAS DE PESQUISA

FONTE: Arquivo pessoal do autor (Renato Nicodemos).

4.2 CLCULOS DOS DEMAIS CAMPOS

Os campos seguintes sero completados com as informaes j dispostas e


devidamente preparadas na planilha de folha de pagamento, de tal modo que para
cada um deles h um tipo de clculo diferente, obedecendo s caractersticas
particulares.

Procedimentos prticos:
Passo 01: O campo Cargo tem por finalidade apresentar o nome do cargo a
partir do cdigo fornecido nas clulas da coluna Cd.. Assim sendo, ser utilizada
uma frmula baseada na funo =PROCV( ). Na clula C6 informe a funo:

AN02FREV001/REV 4.0

21

=PROCV(B6M$6;O$20;2)

Onde:
B6
M$6:O$22
2

Clula que possui o nmero referente ao Cdigo.


Faixa de clulas onde se encontra a tabela de Cdigo, Cargo e
Salrio.
a segunda coluna que deseja pesquisar dentro da tabela que est na
faixa M$6:O$22, ou seja, pretende-se retornar o nome do Cargo
correspondente ao Cdigo localizado.

Todavia, pode acontecer de ser fornecido um valor de cdigo que


no existe na tabela. Neste caso, a frmula deve prever essa
situao e alertar o usurio quanto ao erro.

A frmula da clula C6 dever ser efetivamente digitada como:

=SE(OU(B6<1;B6>15);ERRO!!!;PROCV(B6;M$6:O$20;2))

Onde:

OU(B6<=0;B6>=15)
ERRO!!!
PROCV(...)

Verifica se o valor do cdigo menor que 1 ou maior que 15.


a mensagem que se apresenta caso os nmeros realmente
sejam menores que 1 e maiores que 15.
a resposta desejada e apresentada quando o valor fornecido for
vlido.

Abrindo-se parnteses na apresentao do tema, cabe apresentar


detalhes sobre o uso de funes lgicas no Excel 2010. Observe
que a frmula anterior usa-se a funo OU( ) que uma funo
lgica. Alm da funo lgica OU( ), encontram-se ainda as
funes lgicas E( ) e NO( ).

As funes lgicas E( ) e OU( ) so utilizadas quando h a necessidade de avaliar


mais de uma condio para a tomada de uma deciso. possvel avaliar de 1 at
256 condies como argumentos dessas condies.
AN02FREV001/REV 4.0

22

A funo lgica E( ) de conjuno e a funo lgica OU( ) de disjuno


inclusiva. Para entender melhor estas questes, observe as tabelas verdade em
seguida para cada uma dessas funes.

4.2.1 Funo Lgica de Conjuno E( )

Do ponto de vista filosfico, a lgica de conjuno a relao entre duas ou


mais proposies (entende-se como proposio como sendo condio) que geram
um resultado lgico verdadeiro quando todas as proposies, sem exceo, forem
verdadeiras. Observe a tabela seguinte:

Tabela verdade do operador lgico de conjuno


Condio 1
Condio 2
Resultado lgico
Verdadeiro
Verdadeiro
Verdadeiro
Falso
Falso
Verdadeiro
Verdadeiro
Falso
Falso
Falso
Falso
Falso

4.2.2 Funo Lgica de Conjuno OU( )

Do ponto de vista filosfico, a lgica de disjuno inclusiva a relao lgica


entre duas ou mais proposies de tal modo que seu resultado lgico ser
verdadeiro quando pelo menos uma das proposies for verdadeira. Observe a
tabela seguinte:

AN02FREV001/REV 4.0

23

Tabela verdade do operador lgico de disjuno inclusiva


Condio 1
Condio 2
Resultado lgico
Verdadeiro
Verdadeiro
Verdadeiro
Falso
Verdadeiro
Verdadeiro
Verdadeiro
Verdadeiro
Falso
Falso
Falso
Falso

A funo lgica NO( ) opera apenas com um argumento e tem


por finalidade inverter o resultado lgico da condio a ela
atribuda. Assim sendo, se a condio for verdadeira, a funo
NO( ) far com que essa condio seja considerada falsa, mas
se o valor da condio for falso, a funo NO( ) far com que essa condio seja
considerada verdadeira.

4.2.3 Funo Lgica de Negao NO( )

Do ponto de vista filosfico, a negao uma rejeio ou a contradio do


todo ou parte desse todo. Pode ser a relao entre uma proposio p e a sua
negao no-p. Se p for verdadeira, no-p falsa e se p for falsa, no-p
verdadeira.
Observe atentamente a seguinte tabela:

Verdadeiro
Falso

Tabela verdade do operador lgico de negao


Resultado lgico
Condio 1
Falso
Verdadeiro

De volta a montagem da planilha de folha de pagamento, defina a frmula


anterior para a clula C6 e copie esta frmula para a faixa de clulas de C7 at C21.
Aps a cpia ajuste o tamanho da coluna de forma que todas as descries de
cargos caibam nas extenses de clulas da coluna C. Observe o modelo:
AN02FREV001/REV 4.0

24

FIGURA 12 - CAMPO CARGO DEVIDAMENTE CALCULADO

FONTE: Arquivo pessoal do autor (Renato Nicodemos).

Na sequncia chegou a vez de obter o nmero de salrios mnimos pagos


(coluna Nr. Sal.) para o cargo definido. Esse campo tambm ser calculado a partir
da funo =PROCV( ), que faz a pesquisa no cdigo e retorna o salrio
correspondente. Assim sendo, na clula D6 digite a seguinte frmula:

=SE(C6=ERRO!!!;0;PROCV(B6;M$6:O$20;3))

Onde:
C6=ERRO!!!
0
PROCV(...)

Verifica se h o texto ERRO!!!.


Caso haja o referido texto que indica o erro, mostrado o valor 0.
Caso contrrio, efetuado o retorno do valor referente ao Nr. Sal.
Correspondente ao Cdigo localizado.

Copie esta frmula a qual definida em D6 para a faixa de clulas de D7 at D21,


em seguida salve a planilha.

AN02FREV001/REV 4.0

25

Na sequncia ser definido o valor bruto de salrio a ser recebido (coluna Sal.
Bruto). Na clula E6 digite a frmula:

=D6*B$3

Copie-a para as clulas de E7 at E21. Formate a coluna de valores do salrio com


duas casas decimais com separadores de milhares.
Para a coluna do INSS ser feito o clculo com base no nmero de salrios mnimos
recebidos e de acordo com a tabela de alquotas. Assim sendo, na clula F6 digite a
frmula:

=PROCV(D6;Q$7:S$10;3)*E6

Copie para as clulas de F7 at F21. Formate a coluna de valores do salrio bruto


com duas casas decimais com separadores de milhares.

Note que a frmula anterior, alm de trazer o valor da alquota


correspondente, efetua a multiplicao desta pelo valor do salrio
bruto a fim de obter o valor a ser reduzido.

O clculo do salrio famlia (coluna Sal. Fam.) deve verificar se o cargo desse
funcionrio existe, e em seguida, calcular o valor do salrio mnimo vigente dividido
por 8 e multiplicando pelo nmero de dependentes. Digite na clula H6 a seguinte
frmula:
=SE(C6=ERRO!!!;0;B$3/8*G6)

Em seguida copie a frmula para as clulas de H7 at H21. Formata a coluna de


valores do salrio bruto com duas casas decimais com separadores de milhares.
Observe o modelo:

AN02FREV001/REV 4.0

26

FIGURA 13 - PLANILHA DE FOLHA DE PAGAMENTO PARCIALMENTE


PREENCHIDA

FONTE: Arquivo pessoal do autor (Renato Nicodemos).

Agora ser preparado o clculo do Imposto de Renda Retido na Fonte (IRRF). Na


clula I6 digite a frmula de clculo do IRRF:

=PROCV(D6;U$7:W$14;3)*E6

Copie a frmula para as clulas de I7 at I21. Formate a coluna de valores do salrio


bruto com duas casas decimais com separadores de milhares e atente para os
seguintes dados:

D6
U$7:W$14
3
*E6

Efetua a pesquisa a partir de Nr. Sal.


Tabela que mostra a abrangncia do desconto do IRRF.
a terceira coluna dentro da faixa U$7:W$4.
Aps ter descoberto a Alquota de desconto de IRRF, deve-se
multiplicar pelo Sal. Bruto.

AN02FREV001/REV 4.0

27

A partir do momento que j so realizados os clculos anteriores, sero realizados o


clculo do total de descontos (coluna Tot. Desc.). Assim sendo, posicione o cursor
na clula J6 e digite a frmula:

=F6+I6

Copie-a para as clulas de J7 at J21 e formate a coluna de valores do salrio bruto


com duas casas decimais e com separadores de milhares.

Para finalizar a montagem das colunas da planilha de folha de pagamento, posicione


o cursor na clula K6 e digite a frmula:

=E6+H6-J6

Depois copie para as clulas K7 at K21 e formate a coluna de valores do salrio


bruto com duas casas decimais com separadores de milhares. Observe o modelo:

FIGURA 14 - PLANILHA DE FOLHA DE PAGAMENTO QUASE FINALIZADA

FONTE: Arquivo pessoal do autor (Renato Nicodemos).

AN02FREV001/REV 4.0

28

Na sequncia necessrio criar a parte de extrato da folha de pagamento. Assim


sendo, na clula E22 digite a frmula:

=SOMA(E6:E21)

Na clula E23 digite a frmula:

=MDIA(E6:E21)

Na clula E24 digite a frmula:

=MXIMO(E6:E21)

Na clula E25 digite a frmula:

=MN(E6:E21)

Em seguida, copie as quatro frmulas anteriores para as colunas F, H, I, J e K.


Salve a planilha de folha de pagamento e observe o modelo:

FIGURA 15 - PLANILHA DE FOLHA DE PAGAMENTO FINALIZADA

AN02FREV001/REV 4.0

29

FONTE: Arquivo pessoal do autor (Renato Nicodemos).

5 OUTRAS OPERAES COM FUNES

O uso das funes no Excel sem dvida o seu ponto forte mais alto, pois o
uso de funes poupa muito trabalho. Conhecer ao mximo as funes do programa
ter certeza de saber trabalhar melhor com o programa.
Cabe apresentar algumas funes que podem ser teis, em seu trabalho
profissional ou mesmo escolar. So apresentadas informaes bsicas para usar as
funes

=ABS,

=AGORA,

=CONT.SE,

=FATO,

=POTNCIA,

=SOMA

=SOMA.SE. Para maiores detalhes a respeito destas e outras funes,


fundamental consultar o recurso de ajuda do programa.

5.1 FUNO =ABS( )

AN02FREV001/REV 4.0

30

Funo da categoria matemtica e trigonomtrica que tem por finalidade


retornar o valor do mdulo de um nmero, ou seja, seu valor absoluto, sendo
sempre um valor positivo.

A funo ABS usa apenas um argumento.

Exemplo 01:
=ABS(-7) , retorna o valor 7.

Exemplo 02:
=ABS(9), retorna o valor 9.

5.2 FUNO =AGORA( )

Funo da categoria data e hora que tem por finalidade retornar o valor de srie da
data e da hora atual do sistema.

A funo =AGORA no usa argumento.

Exemplo 01:
=AGORA( ) - retorna um valor numrico serial como 403312,62688 que corresponde a
informao de data e hora 14/05/2010 15:02.

AN02FREV001/REV 4.0

31

A informao como data e hora apresenta numa clula


formatada. Ao fazer uso da funo, a formatao ocorre
automaticamente.

5.3 FUNO =CONT.SE( )

Funo da categoria estatstica que conta em um intervalo de clula


quantas vezes certa informao ocorre. Dessa forma, possvel contar quantas
vezes certo nome aparece em uma lista.

A funo =CONT.SE faz uso de dois argumentos, sendo o


primeiro caracterizado pelo intervalo de clula e o segundo pelo
critrio de pesquisa.

Exemplo 01:
=CONT.SE(D1:D10; Abacate) retorna o nmero de vezes que abacate aparece na faixa
de clulas informada.

AN02FREV001/REV 4.0

32

5.4 FUNO =FATORIAL( )

Funo da categoria matemtica e trigonomtrica que retorna a fatorial de


um valor numrico inteiro.

A funo FATORIAL faz uso de um argumento.

Exemplo 01:
=FATO(5) - retorna 120, pois seria o mesmo que multiplicar 1x2x3x4x5.

5.5 FUNO =POTNCIA( )

Funo da categoria matemtica e trigonomtrica que retorna a potncia


de um valor numrico fornecido como base elevado a outro valor numrico fornecido
como expoente.

A funo =POTNCIA( ) faz uso de dois argumentos, sendo o


primeiro o valor da base e o segundo o valor do expoente.

Exemplo 01:
=POTCIA(2;3) - retorna 8.

Exemplo 02:
=POTNCIA (10,5;1,5) - retorna 34,02388867

O clculo de potncia tambm pode ser efetuado pelo operador


aritmtico (^). Assim sendo, =2^3 retorna o resultado 8.

AN02FREV001/REV 4.0

33

5.6 FUNO =SOMA( )

Funo da categoria matemtica e trigonomtrica que tem por finalidade


retornar o valor da soma de todos os nmeros da lista de argumentos.

A funo SOMA utiliza at 255 argumentos.

Exemplo 01:
=SOMA(A1:A5) - retorna a soma de todos os valores na faixa de clulas A1 at A5, ou seja,
os valores da linha 1 at a linha 5 da coluna A.

Exemplo 02:
=SOMA(A1:E1) - retorna a soma de todos os valores na faixa de clulas A1 at E1, ou seja,
os valores da coluna A at a coluna E da linha 1.

Exemplo 03:
=SOMA(A1:E5) - retorna a soma de todos os valores na faixa de clulas A1 at E5, ou seja,
os valores da coluna A da linha 1 at a coluna E da linha 5.

Exemplo 04:
=SOMA(A1:A5;C1:C5) - retorna a soma de todos os valores na faixa de clulas de C1 at
C5.

AN02FREV001/REV 4.0

34

6 ERROS OCORRIDOS NO USO DE FUNES

Na utilizao das funes e clculos no programa Excel, alguns erros podem


surgir como resposta ao uso desses recursos, dependendo do que faa com eles. O
erro apresentado quando uma funo no consegue realizar o que pedido. No
sentido de saber os erros retornados e como evit-los, seguem suas descries.

###

#DIV/0!

#N/A

#NOME?
#NULO

#NUM!
#REF!
#VALOR!

Ocorre quando a largura de uma coluna menor que a extenso do valor


numrico a ser apresentado. Neste caso, basta aumentar o tamanho da
coluna para visualizar o valor apresentado. Caso se realizem operaes com
data e hora, necessrio verificar se o valor resultante no negativo.
Ocorre quando se divide um valor por zero. Uma soluo para evitar esse tipo de
erro usar a funo SE que pode permitir o clculo quando valor do divisor for
diferente de zero
Acontece quando se utiliza certo valor que no se encontra disponvel para a
funo em uso, normalmente quando se esquece de usar um argumento
obrigatrio em uma funo.
Ocorre quando se usa o nome de funo que no existe no programa Excel.
Aparece quando se usa o intervalo de clulas de duas reas que no se cruzam. O
operador que estabelece o ponto de cruzamento das faixas um caractere de
espao entre as referncias usadas. Por exemplo, ao usar a funo
=CL(endereo;(B1:B5 A5:C6)), ter-se- como ponto de cruzamento o retorno de
endereo $B$5, mas se usar a funo =CL(endereo;(B1:B5A6:C6)), ter-se-
como resultado de endereo e mensagem de erro #NULO!.
Ocorre quando so fornecidos valores invlidos para a ao de uma funo ou
frmula
Ocorre geralmente quando se utiliza um endereo de clula que existia na planilha,
mas foi removido, por algum motivo.
Acontece quando se usa certo tipo de valor incorreto para o argumento da funo
em uso.

AN02FREV001/REV 4.0

35

7 EXERCCIOS

Agora chegou o momento de fazermos alguns exerccios para fixarmos o


contedo estudado neste primeiro mdulo. Procure desenvolver todos os
exerccios propostos e pea auxlio sempre que necessitar ao seu Tutor.

Questo 01: O que funo para o Microsoft Office Excel?

Questo 02: Explique a diferena entre funo com argumento e funo sem
argumento.

Questo 03: O que argumento de funo?

Questo 04: Como se obtm ajuda a respeito do Microsoft Office Excel?

Questo 05: Qual a finalidade da funo =SOMA( )?

Questo 06: Cite a finalidade da funo =MDIA( ).

Questo 07: Qual a finalidade da funo =MXIMO( )?

Questo 08: Qual a finalidade da funo =MNIMO( )?

AN02FREV001/REV 4.0

36

Questo 09: Descreva a finalidade da funo =SE( ).

Questo 10: Qual a finalidade da funo =PROCV( )?

Questo 11: Qual a finalidade da funo =OU( ).

Questo 12: possvel ter mais de uma funo associada funo =PROCV( )?

Questo 13: O que faz a funo =SE( ).

Questo 14: possvel ter mais de uma funo associada funo SE.

Questo 15: Para que serve o caractere $ colocado em um endereo de clula da


planilha? Qual a diferena em usar o smbolo $ antes da letra e do nmero, antes
do nmero ou da letra do endereo de uma clula?

Questo 16: Crie e explique uma funo =PROCV( ) com outra associada e o
mecanismo de seu funcionamento.

Questo 17: Crie e explique uma funo =SE( ) com outra associada e o
mecanismo de seu funcionamento.

FIM DO MDULO I

AN02FREV001/REV 4.0

37