P. 1
indir (1)

indir (1)

|Views: 3,911|Likes:
Yayınlayan: bonur61

More info:

Published by: bonur61 on Sep 03, 2011
Telif Hakkı:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as PDF, TXT or read online from Scribd
See more
See less

01/01/2013

pdf

text

original

Sections

Makrolar, kullanıcıya kolaylık sağlamak amacıyla tasarlanmış küçük bir
programlama dili olarak tanımlanabilir. Makrolar kullanılarak, yapılması
zaman alan bir çok işlem pratik bir şekilde çözümlenebilir. Bu küçük
programlama dili şu an NETCAD/NETPRO içerisinde,

• Tip Kesit Editörü
• Enkesit Editörü
• Kübaj Editörü
• Platform Editörü
• Enkesit Tabloları içerisinde kullanılmaktadır.

Bu bölümde kullanıcıya, makro editörüne giriş, makroların hazırlanması
ve çalıştırılması ile ilgili bilgiler verilecektir.

T.1.Makro Editörü

Makro Editörüne girmek için Kesit Editörü, Kübaj Editörü ve Platform
Editöründe Makro Edit Đşlemi, Enkesit Tabloları işleminde ise Tablo
Makrosu Hazırla işlemi kullanılır. Tip kesit editöründe herhangi bir
tanımın üzerinde farenin sağ tuşuna tıklanır ve açılan menüden Yeni
Makro işlemine girilir.

Kesit, Platform ve Kübaj editörlerinde işlemin seçilmesi ile birlikte daha
önceden oluşturulan makroların bulunduğu liste ekrana gelir. Bu
ekrandan daha önce oluşturulan makrolar seçilerek [Sil] işlemi ile
silinebilir. Seçilen makroların içerikleri Ön izleme Penceresinde
görülebilir.

Platform Makroları Penceresi

NETPRO 6.0 321

Daha önceden hazırlanmış bir makroyu Editlemek için makro seçilir ve
Tamam butonuna basılır, Makro Editörüne geçtikten sonra gerekli
editlemeler yapılır.

Yeni Makro oluşturmak içinde ilk önce mevcut makrolardan birisi
seçilerek Tamam butonu ile Makro Editörüne geçilir. Daha sonra Dosya
menüsünden Yeni işlemi seçilerek boş bir makro dosyası açılır.

Makro Editöründeki işlemler Dosya menüsü içerisinden ve ORNEK
MAKRO ekranında sağ mouse tuşuna basılarak açılan pencereden
seçilebilir.

Makrolara istenirse açıklama bilgisi girilebilir.

Dosya Menüsünde yer alan işlemler aşağıda anlatılmıştır;

Yeni : Boş bir makro dosyası açmak için kullanılır. Editördeki makro
silinerek boş bir dosya oluşturulur ve yeni makro yazılır.

Yükle : Daha önceden oluşturulan makrolar seçilerek editöre yüklenir.

Sakla : Oluşturulan makro dosyası saklanır.

Farklı Sakla : Oluşturulan makro dosyası yeni bir isim verilerek
saklanır.

ASCII Yükle : Eski versiyonlarda oluşturulmuş ASCII yapıdaki makro
dosyalarının yüklenmesi için kullanılır.

Makro Editörü Penceresi

NETPRO 6.0 322

ASCII Sakla: Oluşturulan makro dosyalarının ASCII yapıda saklanması
için kullanılır.

T.2.Kesit Editörü Makroları

Enkesit Editörü makroları, editörde seçili olan kesit dosyasında bulunan
noktaların kodlarına bağlı olarak oluşturulan makrolardır. Bu nedenle
Makro yazmaya başlamadan önce Kesit Editöründe ilgili kesit dosyası
seçilmiş olmalıdır. Kesit Editörü makrolarında temel kural kesitleri
oluşturan noktaların hesaplatılması işlemidir. Hesaplatılan noktalar
daha sonra “Ekle” makrosu ile enkesitin oluşturulmasında kullanılır.

Yazmış olduğunuz makroları daha sonra oluşturacağınız kesit
dosyalarında kullanmak daha da önemlisi NETCAD/NETPRO’yu iyi bir
şekilde kullanabilmek için kodlamalarda standartlaşmaya gitmeniz
önerilir.

Makro yazabilmek için ilk önce Yeni Makro satırı seçilir ve makro
penceresinde (sağ pencere) sağ mouse tuşuna basarak açılan
pencereden istenen işlem seçilir. Makro yazarken araya ekleme
yapılabilir bunun için eklenecek satırın altındaki satır seçildikten sonra
mouse sağ tuşuna basılır ve işlem seçilir.

Adını Değiştir: Oluşturulan makro dosyasının adını girmek yada
değiştirmek için kullanılır. Yeni oluşturulan makro dosyaları için
mutlaka Adını Değiştir işlemi ile isim girilmelidir.

Makro Edit: Oluşturulan satırlar daha sonra tekrar seçilerek
editlenebilir. Editleme işlemi için ayrıca ilgili satır mouse ile iki kez
seçilerek editleme yapılabilir.

Makro Sil: Seçili olan satırın silinmesi için kullanılır.

Soldan Topla: Kod bilgisi girilir. Girilen Kod’a kadar olan tüm noktalar
makro sonucu oluşacak dosyaya eklenir.

Topla: 2 Kod girilir. Girilen Kodlar arasında kalan tüm noktalar makro
sonucu oluşacak dosyaya eklenir.

Soldan Topla Penceresi

NETPRO 6.0 323

Sona Kadar Topla: Başlangıç noktası girilir. Girilen noktadan sonraki
tüm noktalar makro sonucu oluşacak dosyaya eklenir.

Nokta: Yeni nokta hesaplamak için kullanılacak işlemlerin bulunduğu
menüdür. Bu menüden uygun işlem seçilerek yeni nokta
hesaplatılabilir.

Nokta Kodundan Tanım ile Hesapla: Tanım ile yeni nokta
hesaplanması işlemidir. Hesaplanacak nokta için isim girilir, kullanılacak
referans nokta seçilir ve tanım girilir.

Nokta Kodundan Tanım ile
Hesapla Penceresi

Sona Kadar Topla Penceresi

Topla Penceresi

NETPRO 6.0 324

Đki Doğrunun Kesişimi: Đki doğrunun kesişimleri hesaplanarak yeni
bir nokta oluşturma işlemidir. Daha önce işlemde kullanılacak doğrular
makro ile tanımlanmış olmalıdır.

Oluşacak nokta için isim girilir, 1. Doğru ve 2. Doğru seçilir.
Hesaplanacak yeni nokta için Kod girilir.

Doğrunun Uç Noktaları: Doğruların başlangıç ve bitişlerinin nokta
olarak tanımlanması için kullanılan işlemdir. Daha önce işlemde
kullanılacak doğrular makro ile tanımlanmış olmalıdır. Oluşacak nokta
için isim girilir, Đşlemde kullanılacak doğru seçilir. Doğrunun
Başlangıç/Bitiş seçeneklerinden uygun olan işaretlenir. Hesaplanacak
yeni nokta için Kod girilir.

Önceki Noktadan Tanım ile Hesapla: Nokta makrosu ile oluşturulan
noktalar kullanılır. Hesaplama verilen tanıma göre yapılır. Oluşacak
nokta için isim girilir, Đşlemde kullanılacak nokta seçilir ve tanım girilir.

Doğrunun Uç Noktaları Penceresi

Đki Doğru Kesişimi

NETPRO 6.0 325

Doğru Yap: Đki nokta arasını doğru olarak tanımlamak için kullanılır.
Başlangıç noktası tipi ve Bitiş noktası tipi için değişik seçenekler
kullanılabilir.

KOD: Başlangıç ve Bitiş noktası için kullanılacak kod noktaları seçilir.
Kodu girilen noktadan bir önceki nokta kullanılır.
>KOD: Kodu girilen noktadan bir sonraki nokta kullanılır.
=i (Kesitin i. Noktası): Numaralar soldan başlayarak hesaplanır. Đlgili
noktanın sıra numarası girilerek doğru tanımlanır.
$Px Nokta Makrosu: Makroda tanımlanan noktalar kullanılarak doğru
tanımlanır.
Ekle: Enkesit noktaları ve tanımlanan noktalar seçilerek yeni kesit
tanımlanır.

Doğru Yap Penceresi

Önceki Noktadan Tanım ile Hesapla Penceresi

NETPRO 6.0 326

Nokta ve Kodlar: Bölümünde kesit dosyasındaki tüm noktalar ve
makroda tanımlanan noktalar yer alır. Seçilen Noktalar ve Kodlar
bölümünde ise oluşacak enkesit dosyasında yer alacak noktalar eklenir,
çıkarılır ya da sırası değiştirilebilir. Noktalar soldan sağa doğru sıralı
olmalıdır.

Ekleme, çıkarma ve sıra değiştirme işlemleri oklar yardımı ile
yapılır.

Paralel: Oluşturulan doğruların paralel olarak ötelenmesi amacıyla
kullanılır. Değerler doğrunun oluşturulma yönüne göre sol negatif (-),
sağ pozitif (+) olarak girilir.

Doğrunun Paralellerini Al Penceresi

Ekle/ Nokta ve Kodlar Penceresi

NETPRO 6.0 327

Doğru: Đşlemde kullanılacak doğru seçilir. Doğrunun daha önce
tanımlanmış olması gerekmektedir.

Mesafe: Sabit ya da değişken bir değer girilir. Bunun için öncelikle
Sabit ya da Değişken seçeneğinin işaretlenmiş olması gerekmektedir.
Değişkenler için daha önceden, Değişkenler makrosu ile liste
oluşturulmuş olmalıdır. Sabit seçeneğinin işaretlenmesi durumunda
sayısal değer girilir. Değişken seçeneğinin işaretlenmesi durumunda ise
istenen değişken listeden seçilir. Değişken seçeneğinin kullanılmasının
avantajı makronun çalıştırılması sırasında yeni değer girilebiliyor
olmasıdır.

Değişkenler: Kullanılacak değişkenlerin tanımlandığı bölümdür.
Değişken ekleme ve silme işlemi mouse sağ tuşuna basılarak yapılır,
Değişken ekle işlemi ile açılan pencereden değişkenin adı ve değeri
girilir. Sil işlemi ise listede seçili olan değişkeni silmek için kullanılır.

Uzat: Oluşturulan doğruların sola/ sağa uzatılması için kullanılır.
Uzatma işlemi başka bir doğruya uzatma olarak algılanmamalıdır.
Verilen mesafe/değişken kadar uzatma yapılır.

Değişkenler Penceresi

NETPRO 6.0 328

Yön: Uzatmanın eksene göre sola ya da sağa mı olacağı belirlenir.

Doğru: Uzatma işleminin yapılacağı doğru seçilir.

Mesafe: Sabit ya da değişken bir değer girilir. Bunun için öncelikle
Sabit ya da Değişken seçeneğinin işaretlenmiş olması gerekmektedir.
Değişkenler için daha önceden, Değişkenler makrosu ile liste
oluşturulmuş olmalıdır. Sabit seçeneğinin işaretlenmesi durumunda
sayısal değer girilir. Değişken seçeneğinin işaretlenmesi durumunda
istenen değişken listeden seçilir. Değişken seçeneğinin kullanılmasının
avantajı makronun çalıştırılması sırasında yeni değer girilebiliyor
olmasıdır.

IF/ENDIF: Makroların çalışması nokta koşuluna bağlıdır. Makroda
kullanılan nokta o kesitte varsa makro çalışır yoksa makro hata verir.
Bu nedenle bazı kesitler için nokta koşulunun kullanıcı tarafından
belirlenmesi gerekebilir.

Örneğin dolgu kesitlerindeki ve yarma kesitlerindeki kodlandırma farklı
olduğu için dolgu ve yarma durumu için koşul vermek gerekebilir. Koşul
için IF makrosu seçilir ve koşulun bağlı olduğu nokta belirlenir. Koşulun
bitiminde ENDIF makrosu kullanılır.

Uzat Đşlemi Penceresi

NETPRO 6.0 329

T.2.1.Örnek Kesit Editörü Makrosu

Kesit Editörü makrolarının daha iyi anlaşılması amacı ile aşağıdaki
örneği incelemeniz faydalı olacaktır.

T.2.1.1.Makro Kodu

$MAKRO ÖRNEK MAKRO (FORMASYON)
$L1 $L2 YKO,EKS //
$L3 EKS,YKA //
$L4 YKA,>YKA //
$MP $L2 0.5 //
$MP $L3 0.5 //
$P1 X YKO,$L1,$L2 //
$P2 N EKS,-0.5,0,EKS //
$P3 X YKA,$L3,$L4 //
$E $P1+$P2+$P3 //

T.2.1.2.Makro ile Formasyon Yüzeyi Oluşturulması

Doğru (L1)

Başlangıç Noktası: “ Bitiş Noktası: “YKO”

IF/ENF IF Penceresi

NETPRO 6.0 330

Doğru (L2)

Başlangıç Noktası: “YKO”
Bitiş Noktası: “EKS”

Doğru (L3)

Başlangıç Noktası: “EKS”
Bitiş Noktası: “YKA”

Doğru (L4)

Başlangıç Noktası: “YKA”
Bitiş Noktası: “>YKA”

Paralel

Doğru: “L2”
Mesafe: “0.50”

Paralel

Doğru: “L3”
Mesafe: “0.50”

Nokta (2 Doğrunun Kesişimi)

Nokta No: “1”
Doğru 1: “L1”
Doğru 2: “L2”

Nokta (2 Doğrunun Kesişimi)

Nokta No: “1”
Doğru 1: “L1”
Doğru 2: “L2”
Yeni Nokta Kodu: “YKO”

NETPRO 6.0 331

Nokta (Nokta Kodundan Tanım ile Hesapla)

Nokta No: “2”
Referans Nokta Kodu: “EKS”
Tanım: “-0.50,0,EKS”

Nokta (2 Doğrunun Kesişimi)

Nokta No: “3”
Doğru 1: “L3”
Doğru 2: “L4”
Yeni Nokta Kodu: “YKO”

Ekle

P1,P2,P3

T.3.Kübaj Editörü Makroları

Enkesitler oluşturulduktan sonra yapılabilecek her türlü kübaj hesabı
için makro komutları kullanılabilmektedir. Makro sonucu hesaplanan
değerler gene makro içerisinden seçilen rapor dosyası ile çıktı olarak
alınabilir.

Adını Değiştir: Oluşturulan makro dosyasının adını girmek ya da
değiştirmek için kullanılır. Yeni oluşturulan makro dosyaları için
mutlaka Adını Değiştir işlemi ile isim girilmelidir.

Kübaj Editörü \
Dosya Seç Penceresi

NETPRO 6.0 332

Makro Edit: Oluşturulan satırlar daha sonra tekrar seçilerek
editlenebilir. Editleme işlemi için ayrıca ilgili satır mouse ile iki kez
seçilerek editleme yapılabilir.

Makro Sil: Seçili olan satırın silinmesi için kullanılır.

Dosya Seç: Bu bölümden makroda kullanılacak tüm dosyaların
kullanıcıya sorulması sağlanır. Mouse sağ tuşu “Ekle” işlemi ile listeye
ekleme ve yine Mouse sağ tuşu “Çıkart” işlemi ile listeden silme
yapılabilir. Listeye ekleme işlemi tek tek her dosya için yapılır,
eklenecek dosya için Dosya Açıklaması ve Dosya Tipi girilir.

Alan Hesabı: Alan Hesabı için kullanılır. Alan Hesabı işlemi aynı makro
içerisinde birden çok kullanılarak farklı dosyalar arasında farklı
kolonlara alanlar hesaplatılabilir.

Kolon: Değerlerin yazılacağı kolon seçilir.

Dosya 1,Dosya 2: Hesapta kullanılacak kesit dosyaları seçilir.

Kolonlar Arası Hesap: Kolonlar arası aritmetik hesaplamalar
yapılabileceği gibi bir kolonun bir sabitle çarpılması bölünmesi gibi
hesaplamalarda da kullanılabilir.

Mutlak Değer: Seçilen kolonun Kazı ve Dolgu değerlerinin mutlak
değerlerinin toplamı kazı kolonuna aktarılır.

Kübaj Editörü
\ Kolon Hesabı Penceresi

Kübaj Editörü \
Alan Hesabı Penceresi

NETPRO 6.0 333

Đki Kolon Yer Değiştir: Seçilen iki kolondaki değerler yer değiştirilir.

Kübaj Hesabı: Seçilen kolonların kübaj hesaplarının yaptırılması
amacıyla kullanılır.

Kolon Kazı ve Dolgusu Yer Değiştir: Seçilen kolonun Kazı ve Dolgu
değerleri yer değiştirilir.

Kübaj Editörü \ Mutlak
Değer Penceresi

Kübaj Editörü \ Kolon
Yer Değiştir Penceresi

Kübaj Editörü \ Kübaj
Hesabı Penceresi

NETPRO 6.0 334

Rapor: Kullanılacak rapor dosyası seçilir. Makro sonucu hesaplanan
değerler seçilen rapor formatında ekrana gelir.

T.3.1.Örnek Kübaj Editörü Makrosu

Kübaj Editörü makrolarının daha iyi anlaşılması amacı ile aşağıdaki
örneği incelemeniz faydalı olacaktır.

T.3.1.1.Makro Kodu

$MAKRO SIYIRMA
$DS //
YOL,KSP
ARAZI,KSE
SIYIRMA,KSE
$SON
$AH A //
@0
@2
$SON
$AH B //
@0
@1
$SON
$HE //
C=@AK-@BK
C=@AD-@BD
$SON
$MD C //
$HE //
D=@AK+@BK+@CK
D=0
$SON

T.3.1.2.Makro ile Kazı, Dolgu ve Sıyırma Kazısı Alanları Hesabı

Dosya Seç

Yol,KSP
Arazi,KSE
Sıyırma,KSE

Kübaj Editörü \ Kolon Kazı ve
Dolgusu Yer Değiştir Penceresi

NETPRO 6.0 335

Alan Hesapla

Kolon: “A” Kolonu.
Dosya1: Yol,KSP
Dosya2: Sıyırma,KSE

Alan Hesapla

Kolon: “B” Kolonu.
Dosya1: Yol,KSP
Dosya2: Arazi,KSE

Kolonlar Arası Hesap

Kolon

T.3.1.2.1.Formül

C

@AK-@BK

C

@AD-@BD

Mutlak Değer

Kolon: “C” Kolonu.

Kolonlar Arası Hesap

Kolon

T.3.1.2.2.Formül

D

@AK+@BK+@CK

D

0 (Sıfır)

Rapor

Sıyırma 1 Makrosu Sonucu Alanlar

T.4.Platform Editörü Makroları

Benzer nitelikteki tip kesitler için hazırlanacak makrolar ile tekrar tekrar
yüzey tanımlamak yerine tek seferde kesitler hızlı ve pratik bir şekilde
oluşturulabilir. Bunun için kullanılması gereken makro komutları ile ilgili
açıklamalar aşağıda verilmiştir.

Adını Değiştir: Oluşturulan makro dosyasının adını girmek yada
değiştirmek için kullanılır. Yeni oluşturulan makro dosyaları için
mutlaka Adını Değiştir işlemi ile isim girilmelidir.

Makro Edit: Oluşturulan satırlar daha sonra tekrar seçilerek
editlenebilir. Editleme işlemi için ayrıca ilgili satır mouse ile iki kez
seçilerek editleme yapılabilir.

Makro Sil: Seçili olan satırın silinmesi için kullanılır.

NETPRO 6.0 336

Dosya Seç: Bu bölümden makroda kullanılacak tüm dosyaların
kullanıcıya sorulması sağlanır. Mouse sağ tuşu “Ekle” işlemi ile listeye
ekleme ve yine Mouse sağ tuşu “Çıkart” işlemi ile listeden silme
yapılabilir. Listeye ekleme işlemi tek tek her dosya için yapılır,
eklenecek dosya için Dosya Açıklaması ve Dosya Tipi girilir.

Doğal Zemin: Dosya seç makrosunda tanımlanan dosyalardan, doğal
zemin dosyası olarak kullanılacak dosya seçilir. Genel olarak seçilen
dosya, tip kesitlerin kilometrelerinin belirlenmesinde ve uzatma
işleminde kullanılır.

Yol Dosyası: Dosya seç makrosunda tanımlanan dosyalardan, yol
dosyası olarak kullanılacak dosya seçilir. Enkesite Çevir ve Uzat
makrosu sonucunda oluşacak dosyadır.

Platform Makroları \ Dosya
Seç Penceresi

Platform Makroları \
Doğal Zemin Dosyası
Tanımlama Penceresi

NETPRO 6.0 337

Yol+Şev: Yol tanımı, şev tanımı, kritik yükseklik ve mesafe
tanımlarının beraber verildiği makro tanımıdır. Yol + Şev tanımı
kullanıcı için kolaylık sağlayan bir tanımdır, tüm değerler tek işlemde
girilir, Đstenirse Yol Tanım, Dolgu Tanım, Yarma Tanım, Kritik Yükseklik
ve Mesafe makroları ile değerler ayrı ayrı da verilebilir.

Yol Tanım: Sadece yol tanımının verildiği makro tanımıdır. Yolun solu
ve sağı için ayrı ayrı tanım yapılır.

Dolgu Tanımı: Sadece dolgu şevinin tanımlandığı makrodur. Yolun
solu ve sağı için ayrı ayrı tanım yapılır.

Yarma Tanımı: Sadece yarma şevinin tanımlandığı makrodur. Yolun
solu ve sağı için ayrı ayrı tanım yapılır.

Kritik Yükseklik ve Mesafe: Sadece kritik yükseklik ve mesafe
değerlerinin girildiği bölümdür. Yolun solu ve sağı için ayrı ayrı tanım
yapılır.

Şev Uygula: Yol, Dolgu, Yarma, Kritik Yükseklik ve Mesafe makroları
ayrı ayrı kullanılmışsa (Yol+Şev makrosu kullanılmamışsa) şevlerin
oluşturulması için Şev Uygula makrosu kullanılmalıdır.

Enkesite Çevir: Đşlem sonunda enkesit dosyası oluşturulur fakat
uzatma işlemleri yapılmaz şevler olduğu gibi bırakılır.

Enkesite Çevir ve Uzat: Đşlem sonunda seçilen arazi dosyasına göre
gerekli uzatma, kırpma işlemleri yapılarak enkesit dosyası oluşturulur.

Sapma: Bilindiği gibi tanımlar, girilen kırmızı kot değerindeki bir
eksenden sola ve sağa doğru yapılmaktadır. Sapma makrosu ile
tanımların istenilen bir kot/ mesafeye göre verilmesi mümkündür.
Bunun için 3 tane seçenek kullanılabilir. Sapmalarla ilgili ayrıntılı bilgi
için kitabın Platform Editörü bölümünü incelemeniz faydalı olacaktır.

Diğer: Yüzey tanımlamada kullanılan diğer bazı standart işlemlerin
bulunduğu menüdür. Bu menü içerisinden Kilometre Oku, Kilometre Sil,
Kot Kaydır ve Kırmızı Kot Hesapla işlemleri seçilerek kullanılabilir.

Platform Makroları \ Yol
Dosyası Tanımlama
Penceresi

NETPRO 6.0 338

T.4.1.Örnek Platform Editörü Makrosu

Platform Editörü makrolarının daha iyi anlaşılması amacı ile aşağıdaki
örneği incelemeniz faydalı olacaktır.

T.4.1.1.Makro Kodu

$MAKRO MAKRO1
$DS //
Yol,KSP
Arazi,KSE
$SON
$DZ @1 //
$YOL @0 //
$KMOKU @1 //
$KIRMIZIKOTHESAPLA //
$YS * //
SolY=3.5%D,YKO
SolSY=1.2,3,HDO 1,1,KYO
SolSD=-2,3,KDO
SolKY=1.2
SolKM=3
SagY=3.5%D,YKA
SagSY=1.2,3,HDA 1,1,KYA
SagSD=-2,3,KDA
SagKY=1.2
SagKM=3
$SON
$UCEVIR * //
YolKenari(YKO,YKA)
HendekDibi(HDO,HDA)

$SON

T.4.1.2.Örnek Platform Editörü Makrosu

Dosya Seç

Yol,KSP
Arazi,KSE

Arazi Dosyası

Arazi,KSE

Yol Dosyası

Yol,KSP

Diğer-Kilometre Oku

Arazi,KSE

NETPRO 6.0 339

Diğer-Kırmızı Kot Hesapla
Yol+Şev

Kilometre Süzgeci *

Solda Yol 3.5%D,YKO
Sağda Yol 3.5%D,YKA
Solda Dolgu Tanımı -2,3,KDO
Sağda Dolgu Tanımı -2,3,KDA
Solda Yarma Tanımı -1.2,3,HDO 1,1,KYO
Sağda Yarma Tanımı -1.2,3,HDA 1,1,KYA
Hendek Kritik Yüksekliği 1.2
Hendek Kritik Mesafesi 3

Enkesite Çevir ve Uzat

T.5.Enkesit Tablo Makroları

Enkesit Tabloları bölümünden hazırlanan makrolar, enkesit Çizimleri
sonrasında enkesit değerlerinin (alan değerleri, kot ve mesafe değerleri
vs.), enkesitlerin yanına yazdırılması amacıyla kullanılır. Makro
yardımıyla istenen değerler öncelikle bir dosyaya yazılır, daha sonra bu
değerler program tarafından okunarak enkesitlerin yanına yazdırılır.

Adını Değiştir: Oluşturulan makro dosyasının adını girmek yada
değiştirmek için kullanılır. Yeni oluşturulan makro dosyaları için
mutlaka Adını Değiştir işlemi ile isim girilmelidir.

Makro Edit: Oluşturulan satırlar daha sonra tekrar seçilerek
editlenebilir. Editleme işlemi için ayrıca ilgili satır mouse ile iki kez
seçilerek editleme yapılabilir.

Makro Sil: Seçili olan satırın silinmesi için kullanılır.

Enkesit Tabloları \
Dosya Seç Penceresi

NETPRO 6.0 340

Dosya Seç: Makroda kullanılacak dosyaların seçildiği bölümdür. Genel
olarak Enkesit Tablosu Makroları ile direk olarak ilgili olan dosyalar;
Enkesit (KSP,KSE) Dosyaları, Kübaj (KUB) Dosyaları ve makro
sonucu oluşturulan bilgilerin kaydedildiği Enkesit Tablosu (EKT)
Dosyaları
dır. Gelişen yapı içerisinde gerektiğinde bu listeye yeni dosya
tipleri de eklenebilecektir.

Dosya Seç işlemi seçildiğinde ekrana yan taraftaki pencere gelir. Bu
pencereden makroda kullanılacak dosya adı girilir ve dosyanın tipi
belirlenir. Đstenirse makroya açıklama bilgisi girilebilir. Girilen bilgiler
Kabul butonu ile eklenir.

Tablo Hazırla: Makroda kullanılan değişkenlerin seçildiği bölümdür.

Açıklama: Đstenirse makro ile ilgili açıklama bilgisi girilebilir.

Enkesit Tablosu: Makro sonucu bilgilerin kaydedileceği dosyadır.
Bilgiler bu bölümden seçilen dosyaya yazılır. Tek EKT dosya seçilmişse
bu dosya varsayılan dosyadır.

Kilometre Referansı: Referans olarak kilometre bilgilerinin
alınacağı dosya seçilir. Sadece bir tane kesit dosyası seçilmişse bu
dosya varsayılan dosyadır.

Komut Penceresi: Makro kullanılan değişkenleri seçileceği
penceredir. Enkesit Tablosu Makrolarında 3 tip değişken vardır;
Enkesit Değerleri, Diğer Kübaj Değerleri ve Kazı Dolgu Alanları.

Enkesit Değerleri: Mesafe ve Kot değerlerinin yazdırılması için
kullanılan değişkenlerin bulunduğu bölümdür.

Enkesit Tabloları \
Tablo Hazırla Penceresi

NETPRO 6.0 341

Açıklama

Açıklama yazısı, ekranda ilgili değerin karşısında
çıkar. (Örneğin “Sol Şev Kazığı L : ” )

Dosya

Seçilen değişkenin okunacağı enkesit dosyası bu
bölümden seçilir.

Birim

Đlgili değişken için birim değeri bu bölümden
seçilir yada girilebilir. (Örneğin “m2, m3, m, ...
)

Değer

Değişkenlerin seçildiği bölümdür. Değişkenler
programda tanımlıdır, bu bölüme ekleme
yapılamaz.

EKM

Enkesitin kilometre değeri yazdırılabilir.
SOLSEVAMES Sol şev kazığının eksene olan mesafesi
yazdırılabilir.

SOLSEVKOT

Sol şev kazığının kot değeri yazdırılabilir.
SAGSEVAMES Sağ şev kazığının eksene olan mesafesi
yazdırılabilir.

SAGSEVKOT

Sağ şev kazığının kot değeri yazdırılabilir.
SOLSEVEGIM Sol şev eğimi yazdırılabilir.
SAGSEVEGIM Sağ şev eğimi yazdırılabilir.

Diğer Kübaj Değerleri: Toprak sınıfı ile ilgili değerlerin
yazdırılması için kullanılan değişkenlerin bulunduğu bölümdür.

Açıklama

Açıklama yazısı, ekranda ilgili değerin karşısında
çıkar. (Örneğin “Sıkışma Değeri : ” )

Dosya

Seçilen değişkenin okunacağı enkesit dosyası bu
bölümden seçilir.

Birim

Đlgili değişken için birim değeri bu bölümden
seçilir yada girilebilir. (Örneğin “m2, m3, m, ...
)

Değer

Değişkenlerin seçildiği bölümdür. Değişkenler
programda tanımlıdır, bu bölüme ekleme
yapılamaz.

SK

Sıkışma / Kabarma

SIKISMA

Sıkışma değeri yazılır.

KABARMA

Kabarma değeri yazılır.

TOPRAK

Toprak % değeri yazılır.

KUSKU

Küskü % değeri yazılır.

YKAYA

Yumuşak Kaya % değeri yazılır.

SKAYA

Sert Kaya % değeri yazılır.

CSKAYA

Çok Sert Kaya % değeri yazılır.

Kazı/Dolgu Alanları: Seçilen kübaj dosyasından, istenilen
kolondaki kazı/dolgu değerinin yazdırılması için kullanılan
bölümdür.

NETPRO 6.0 342

Kazı/Dolgu

Kazı ve Dolgu değerleri aynı kolonda farklı
alanlarda tutulduğu için ayrıca Kazı veya
Dolgu olduğu başlangıçta seçilmelidir.

Açıklama

Açıklama yazısı, ekranda ilgili değerin
karşısında çıkar. (Örneğin “Sıyırma Kazısı :
)

Dosya

Seçilen değişkenin okunacağı enkesit
dosyası bu bölümden seçilir.

Birim

Đlgili değişken için birim değeri bu
bölümden seçilir yada girilebilir. (Örneğin
“m2, m3, m, ... ” )

Kolon

Kazı/Dolgu alanlarının kübaj dosyasından
okunması amacı ile kullanılır. Bu işlemde
Değişkenler yerine Kolon kullanılır. Yani
ilgili değerin hangi kolondan okunacağı
belirlenir.

Kot ve Mesafe Farkları: Kot ve mesafe farklarının
hesaplatılmasına yönelik işlemlerin yapıldığı bölümdür. Đşlem için
hesaplanacak değer ve hesaplamada kullanılacak dosya/dosyaların
seçilmesi gereklidir.

Hesaplanacak Değer
Ara mesafe

Dosya 1 ve Kod 1, Dosya 2 ve Kod 2
seçilir. Aynı dosyadaki iki kod
arasındaki mesafe hesaplatılabileceği
gibi farklı iki dosyadaki kodlar
arasındaki mesafe de hesaplatılabilir.

Kot Farkı

Dosya 1 ve Kod 1, Dosya 2 ve Kod 2
seçilir. Aynı dosyadaki iki kod
arasındaki kot farkı hesaplatılabileceği
gibi farklı iki dosyadaki kodlar
arasındaki kot farkı da hesaplatılabilir.
“Kod 1” deki Kot Farkı Dosya 1, Kod 1 ve Dosya 2 seçilir.
Dosya 1 ve Dosya 2 farklı dosyalar
olmalıdır. Kod 1 noktasında iki dosya
arasındaki kot farkı hesaplanır.

Belirli mesafedeki kot
farkı

Sol için negatif, sağ için pozitif değer
girilir. Seçilen iki dosya arasında
verilen

mesafedeki

kot

farkı

hesaplanır.

Sil: Seçili olan satırın (yapılan tanımlamanın) silinmesi amacıyla
kullanılır.

Ok tuşları ile seçilen satır aşağı yada yukarı kaydırılarak
sıralama değiştirilebilir.

NETPRO 6.0 343

T.5.1.Örnek Enkesit Tablosu Makrosu

Enkesit Tabloları makrolarının daha iyi anlaşılması amacı ile aşağıdaki
örneği incelemeniz faydalı olacaktır.

T.5.1.1.Makro Kodu

$MAKRO ALANLAR
$DS //
Yol Dosyası,KSP
Kübaj Dosyası,KUB
Enkesit Tablo,EKT
$SON
$TABLO //
@2
REF,=@0 KM
Sıyırmalı Kazı Alanı,m2=@1 @AK:0
Sıyırmalı Dolgu Alanı,m2=@1 @AD:0
Kazı Alanı,m2=@1 @BK:0
Dolgu Alanı,m2=@1 @BD:0
Sıyırma Kazısı,m2=@1 @CK:0
$SON

T.5.1.2.Makro ile Kazı, Dolgu ve Sıyırma Kazısı Değerleri
Tablosu

Đşlem için öncelikle kübaj değerleri hesaplatılmış olmalıdır. Kübaj
hesabında;

Yol Sıyırma Alanları

A Kolonu
Yol Doğal Zemin Alanları B Kolonu
Sıyırma Alanları

C Kolonu

olarak hesaplatılmış olsun.

Dosya Seç

Yol Dosyası,KSP
Kübaj dosyası,KUB
Enkesit Tablo,EKT

Tablo Hazırla (Kazı Dolgu Alanları seçilecek)

Kazı/Dolgu: Kazı
Açıklama: Sıyırmalı Kazı Alanı
Dosya: Kübaj Dosyası,KUB
Birim: m2
Kolon: A
Kazı/Dolgu: Dolgu
Açıklama: Sıyırmalı Dolgu Alanı

NETPRO 6.0 344

Dosya: Kübaj Dosyası,KUB
Birim: m2
Kolon: A
Kazı/Dolgu: Kazı
Açıklama: Kazı Alanı
Dosya: Kübaj Dosyası,KUB
Birim: m2
Kolon: B
Kazı/Dolgu: Dolgu
Açıklama:Dolgu Alanı
Dosya:Kübaj Dosyası,KUB
Birim: m2
Kolon: B
Kazı/Dolgu: Kazı
Açıklama:Sıyırma Kazısı
Dosya:Kübaj Dosyası,KUB
Birim: m2
Kolon: C

T.6.Tip Kesit Editörü Makroları

Tip kesit editöründeki kullanılan makro yapısı, enkesit editöründeki
makro yapısı ile aynı türdendir. Ancak tip kesit editörünün yapısı itibari
ile makro kullanmak için tanım ile ilişkilendirilmelidir. Her tanımın bir
altındaki makro o tanıma etki eder. Tanıma yeni bir makro ataması
yapmak için o tanım üzerinde farenin sağ tuşuna tıklanır ve “ Yeni
Makro “ işlemine girilir. Yeni bir makro ataması yapılan tanımın
üzerinde ön izleme penceresinde kesikli çizgi şeklinde gösterim oluşur.

Tip Kesit Editörü \
Platfrom Tanımları Makro Kullanımı

NETPRO 6.0 345

Atanan makro içeriğinin oluşturulması için editörün sağ tarafında yer
alan detay içeriği kısmında farenin sağ tuşuna tıklanır ve “ Makro
Düzenle “ işlemine girilir. Buradaki düzenleme ve oluşturma yapısı
tamamıyla enkesit editöründeki makro kullanımı gibidir. Kesit
editöründe kullanılan makrolar, detay içeriği kısmına kopyalanabilir.

T.6.1. Örnek Tip Kesit Editörü Makrosu

Aşağıdaki makro kullanılarak Basit Tek Yol tanımının üst yapı
katmanları dinamik olarak oluşturulabilir.

• Basit Tek Yol Tanımı
• Sol : 3.5%D,YKO
• Sağ : 3.5%D,YKA

Makro ilgili tanıma atandıktan sonra uygulanması için öncelikle tanım
ile birlikte kaydedilmelidir. Ardında Enkesitleri Üret ile enkesitlerin
üretimi sırasında bu makrolar otomatik olarak devreye girecektir.
Atanan makro için kesit üretimi sırasında kullanıcı tarafında girilmesi
gereken bir parametre var ise, bu değerin girilmesi gerekir. Aşağıdaki
örnek makro da bu parametre D1 olarak belirlenmiş ve varsayılan
değer olarak 0.05 m verilmiştir. Kullanıcı dilerse işlem sırasında bu
değeri değiştirebilir. Đşlem sonucunda makro adıyla yeni bir kesit
dosyası oluşur.

Makro Kodu

$MAKRO USTYAPI KATMANLARI (TEK YOL)
$IF HDO //
$SOT HDO //
$ENDIF //
$IF KDO //
$SOT KDO //
$ENDIF //
$L1 $L2 YKO,EKS //
$P10 N EKS,-5,0,EKS //
$L3 EKS,$P10 //
$L4 EKS,YKA //
$L5 YKA,>YKA //
$DE //
D1=0.05
$SON

Kesit editöründeki herhangi bir makroyu tip kesit editöründe
kullanmak için kesit editöründeki makro düzenle penceresinden
dosyayı ascii olarak saklayınız. Herhangi bir yazı editörü ile (ör. :
notepad) bu dosyayı açınız ve içeriğini kopyalayıp, tip kesit
editöründeki macro detay içeriği kısmına yapıştırınız.

NETPRO 6.0 346

$MP $L2 #D1# //
$MP $L4 #D1# //
$P1 X YKO,$L1,$L2 //
$P2 X EKS,$L2,$L3 //
$P3 X YKA,$L4,$L5 //
$E $P1+$P2+$P3 //
$IF HDA //
$SKT HDA //
$ENDIF //
$IF KDA //
$SKT KDA //
$ENDIF //

Enkesit Üretiminde Makroda Đstenen Parametrenin Girilmesi

NETPRO 6.0 347

U. Manuel Kesit Girişi

Đşleme Kesit Editörü ekranında farenin sağ tuşuna basılarak açılan
menüden Edit işlemi ile girilebilir. Ayrıca Đmar veya Harita modülü
yüklü kullanıcılar hesap menüsü içerisindeki Netveri kısmından Enkesit
Editörünü seçerek de ulaşabilirler.

Kesit verilerinin metin ekranda görüntülendiği, klavyeden veri girişi ve
değişikliklerin yapılabilmesi için düzenlenmiş bir bölümdür.

Đşlemine girilmesi ile birlikte dosya seçim penceresi gelir, buradan yeni
bir dosya ismi verilerek açılabilir veya mevcut dosyalar ekleme ve
değişiklikler için seçilebilir.

Kesit No: Yalnızca kullanım sırasında kilometreye ek bir referans
özelliği taşır. Bunun dışında herhangi bir özelliği yoktur.

Kilometre: Kesitin, kesit alınan güzergah başlangıcına olan
mesafesidir. Aynı kilometrede iki kesit olması durumunda yalnızca ilk
kesit dikkate alınır.

Eksene Mesafe: Kesit üzerindeki noktaların eksene olan mesafesidir.
Kilometre artış yönünde sol taraf negatif, sağ taraf pozitiftir. Değerlerin
karışık girilmesi durumunda “F5” tuşu Sıralama işlemi gerekli
düzeltmeyi yapacaktır.

Kot: Noktanın kotudur. Bir kesit dosyası içerisindeki tüm kotlar aynı
referansa bağlıdır.

Kod: Noktanın özelliği ile ilgili kullanıcı tanımlı koddur. Bu kodların
tanımlanması zorunlu olmamakla birlikte, tanımlanması durumunda
çizim ve raporlamada pek çok kolaylık sağlayacaktır.

Manuel Kesit Giriş Editörü

NETPRO 6.0 348

U.1.Editör Kullanımı

"F2" tuşuna basılarak kayıtlar üzerinde değişiklik yapılabilir.

"F3" tuşuna basılarak yeni bir kayıt satırı açılır. Veri girişi bittiğinde
ekleme modundan Esc tuşu ile çıkılır.

"F4" tuşuna basılarak istenilen kesite; numara, kilometre ve kod
verilerek ulaşılabilir.

Kesit No: Kesit numarası verilerek arama yapılır.

Kesit Kilometre: Kesit kilometresinden arama yapılır. Kesit
kilometresi 3 desimal noktası ile birlikte verilmelidir. Arama her zaman
son bulunulan kayıttan dosya sonuna doğru yapılır. Herhangi bir kayıt
bulunamaması durumunda mesaj verilir ve bir sonraki arama tekrar
dosya başından itibaren yapılır.
Nokta Kodu: Nokta kodundan arama yapılır. Aynı kod pek çok kesitte
bulunabilir. Đşlem arka arkaya girilerek tüm kesitler taranabilir. Uygun
kaydın bulunması ile, kayıt ekrana gelir. Bulunamaması durumunda
bulunamadı mesajı gelir ve pencere kapanır.

"F5" tuşu yada Mouse sağ tuşu ile işlem menüsüne ulaşılabilir. Bu
menüden;

Yükle : Mevcut kesit dosyalarını yüklemek için kullanılır.

Sakla : Üzerinde çalışılan dosya yeni bir isim verilerek saklanabilir.

Sırala : Kesitler kilometre ve eksene mesafe sırasına sokulur

"F6" tuşu ile bulunulan satırın üzerine yeni bir satır açar.

"F7" tuşu bulunulan satır silinir. Aynı işlem Delete tuşu ile de
yapılabilir.

"F9" tuşu ile çıkmadan saklama yapılabilir. Veri girişi sırasında, veri
kaybını engellemek için periyodik aralıklarla girilen veriler
saklanmalıdır.

U.2.Kayıt Girişi

"F3" tuşuna basılması ile yeni bir kayıt satırı açılır. Kursor Kesit No
üzerindedir. Bir değer girilmesi durumunda kayıt kesit başlığı olur, daha
sonra kilometre değeri sorulur. Kesit numarasının boş geçilmesi
durumunda kursor eksene mesafe alanı üzerine geçer ve sırasıyla kot
ve nokta kodu değerleri sorulur.

NETPRO 6.0 349

Ekleme modunda iken veri girişine Enter tuşu ile devam edilmelidir.
Ctrl+Sola/Sağa ok tuşları ile yatayda, Yukarı/Aşağı ok tuşları ile
düşeyde kayıtlar arasında dolaşılabilir. Sola/Sağa ok tuşu ile ise aynı
kayıt içerisinde hareket edilebilir.

Ekleme modunda iken yatay veya düşeyde yer değiştirme yapılırsa
değiştirme (F2) moduna geçilir. Aksi takdirde kayıt ekleme işlemi Esc
tuşuna basana kadar devam eder.

"F2" tuşu ile kayıtlar üzerinde değişiklik yapılabilir. Değişiklikler
yapıldıktan sonra ekleme modundan Esc tuşu ile çıkılır. Ekleme veya
değiştirme modunda değil iken kesinlikle kayıtlar üzerinde değişiklik
yapılamaz.

NETPRO 6.0 350

You're Reading a Free Preview

İndirme
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->