You are on page 1of 3

HQ(config)#interface g0/1

HQ(config-if)#description Link to HQ LAN


HQ(config-if)#ip address 192.168.123.1 255.255.255.0
HQ(config-if)#no shutdown
HQ(config-if)#exit
HQ(config)#interface s0/0/1
HQ(config-if)#description Link between HQ & HQ
HQ(config-if)#ip address 10.10.10.13 255.255.255.252
HQ(config-if)#no shutdown
HQ(config-if)#clock rate 128000
HQ(config-if)#exit
HQ(config)#interface g0/0
HQ(config-if)#description Link to Core Switch
HQ(config-if)#ip address 10.10.10.1 255.255.255.248
HQ(config-if)#no shutdown
HQ(config-if)#exit
HQ(config)#interface s0/1/0
HQ(config-if)#description Link between HQ & RBR2
HQ(config-if)#ip address 10.10.10.9 255.255.255.252
HQ(config-if)#no shutdown
HQ(config-if)#clock rate 128000
HQ(config-if)#exit
RBR1(config)#interface s0/0/0
RBR1(config-if)#description Link between RBR1 & HQ
RBR1(config-if)#ip address 10.10.10.14 255.255.255.252
RBR1(config-if)#no shutdown
RBR1(config-if)#exit
RBR1(config)#interface f0/0
RBR1(config-if)#description Link to RBR1 LAN
RBR1(config-if)#ip address 192.168.1.1 255.255.254.0
RBR1(config-if)#no shutdown
RBR1(config-if)#exit
RBR2(config)#interface s0/0/0
RBR2(config-if)#description Link between HQ & RBR2
RBR2(config-if)#ip address 10.10.10.10 255.255.255.252
RBR2(config-if)#no shutdown
RBR2(config-if)#exit
RBR2(config)#interface f0/0
RBR2(config-if)#description Link to RBR2 LAN
RBR2(config-if)#ip address 192.168.2.1 255.255.255.240
RBR2(config-if)#no shutdown
RBR2(config-if)#exit
BR1(config)#interface g0/0
BR1(config-if)#description Link to Core Switch
BR1(config-if)#ip address 10.10.10.2 255.255.255.248
BR1(config-if)#no shutdown
BR1(config-if)#exit
BR1(config)#interface g0/1
BR1(config-if)#description Link to BR1 LAN1
BR1(config-if)#ip address 172.20.1.1 255.255.255.128
BR1(config-if)#no shutdown
BR1(config-if)#exit
BR1(config)#interface g0/2
BR1(config-if)#description Link to BR1 LAN2
BR1(config-if)#ip address 172.20.1.200 255.255.255.224
BR1(config-if)#no shutdown

BR1(config-if)#exit
BR2(config)#interface g0/0
BR2(config-if)#description Link to Core Switch
BR2(config-if)#ip address 10.10.10.3 255.255.255.248
BR2(config-if)#no shutdown
BR2(config-if)#exit
BR2(config)#interface g0/1
BR2(config-if)#description Link to BR2 LAN1
BR2(config-if)#ip address 172.20.2.1 255.255.255.128
BR2(config-if)#no shutdown
BR2(config-if)#exit
BR2(config)#interface g0/2
BR2(config-if)#description Link to BR2 LAN2
BR2(config-if)#ip address 172.20.2.200 255.255.255.224
BR2(config-if)#no shutdown
BR2(config-if)#exit
HQ(config)#router ospf 10
HQ(config-router)#network 10.10.10.0 0.0.0.7 area 0.0.0.0
HQ(config-router)#network 192.168.123.0 0.0.0.255 area 0.0.0.0
HQ(config-router)#network 10.10.10.8 0.0.0.3 area 0.0.0.10
HQ(config-router)#network 10.10.10.12 0.0.0.3 area 0.0.0.20
HQ(config-router)#passive-interface g0/1
HQ(config-router)#default-information originate
HQ(config-router)#exit
RBR1(config)#router ospf 20
RBR1(config-router)#network 10.10.10.12 0.0.0.3 area 0.0.0.20
RBR1(config-router)#network 192.168.1.0 0.0.1.255 area 0.0.0.20
RBR1(config-router)#passive-interface f0/0
RBR1(config-router)#exit
RBR2(config)#router ospf 20
RBR2(config-router)#network 10.10.10.8 0.0.0.3 area 0.0.0.10
RBR2(config-router)#network 192.168.2.0 0.0.15.255 area 0.0.0.10
RBR2(config-router)#passive-interface f0/0
RBR2(config-router)#exit
BR1(config)#router ospf 10
BR1(config-router)#network 10.10.10.0 0.0.0.7 area 0.0.0.0
BR1(config-router)#network 172.20.1.0 0.0.0.127 area 0.0.0.0
BR1(config-router)#network 172.20.1.192 0.0.0.31 area 0.0.0.0
BR1(config-router)#passive-interface g0/1
BR1(config-router)#passive-interface g0/2
BR1(config-router)#exit
BR2(config)#router ospf 10
BR2(config-router)#network 10.10.10.0 0.0.0.7 area 0.0.0.0
BR2(config-router)#network 172.20.2.0 0.0.0.127 area 0.0.0.0
BR2(config-router)#network 172.20.2.192 0.0.0.31 area 0.0.0.0
BR2(config-router)#passive-interface g0/1
BR2(config-router)#passive-interface g0/2
BR2(config-router)#exit
-------------------------------------------------------------

You might also like